Bug 1563649 - Package ansible-doc-2.5.0-2.fc27.noarch.rpm too big
Summary: Package ansible-doc-2.5.0-2.fc27.noarch.rpm too big
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ansible
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 11:52 UTC by Artur Penttinen
Modified: 2018-05-13 20:31 UTC (History)
7 users (show)

Fixed In Version: ansible-2.5.1-1.el7 ansible-2.5.1-1.fc27 ansible-2.5.1-1.fc28 ansible-2.5.1-1.fc26 ansible-2.5.2-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-21 02:57:36 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github /ansible ansible issues 38288 None None None 2018-04-04 17:02:17 UTC

Description Artur Penttinen 2018-04-04 11:52:46 UTC
Description of problem:

Package ansible-doc-2.5.0-2.fc27.noarch.rpm contains badly prepared
html documentation, thus after installing it takes a lot of disk space (~3.8G).

Version-Release number of selected component (if applicable):

ansible-doc-2.5.0-2.fc27.noarch.rpm 

How reproducible:


Steps to Reproduce:
1. Download package: dnf download ansible-doc
2. rpm -qipf ~/ansible-doc-2.5.0-2.fc27.noarch.rpm | grep Size
Size        : 4093582960
3.

Actual results:

3.8Gb

Expected results:

Smaller

Additional info:

Comment 1 Tim Bielawa 2018-04-04 12:36:57 UTC
This is truly wild. I wonder how long it's been like this.

The majority of the content seems to be the embedded TOC tree. Each module help page (there are 1679 module pages shipped) is coming in at about 2.2 MiB with 15116 toctree list-items.

No wonder the file compressed down to just 35 MiB. It's just copies of that huge toc tree over and over again.

Comment 2 Toshio Ernie Kuratomi 2018-04-04 14:46:01 UTC
I think that the change is the new upstream side navigation.

* The old side navigation (2.4.3): http://docs.ansible.com/ansible/2.4/index.html
* The new side navigation (2.5.0): http://docs.ansible.com/ansible/2.5/index.html

For instance, the old one links to a single page for the module documentation.  The new one links to all modules multiple times.

Comment 3 Tim Bielawa 2018-04-04 16:32:06 UTC
(In reply to Toshio Ernie Kuratomi from comment #2)
> I think that the change is the new upstream side navigation.
> 
> * The old side navigation (2.4.3):
> http://docs.ansible.com/ansible/2.4/index.html
> * The new side navigation (2.5.0):
> http://docs.ansible.com/ansible/2.5/index.html
> 
> For instance, the old one links to a single page for the module
> documentation.  The new one links to all modules multiple times.

Whoa! For fun and profit I did a little experiment:

ansible-doc-2.4 (package was only 4.7M, per DNF):

> $ du -sh /usr/share/doc/ansible-doc/
> 88M     /usr/share/doc/ansible-doc/
> $ find /usr/share/doc/ansible-doc/ | wc -l
> 3238

ansible-doc-2.5 (package is 35M, per DNS):

> $ du -sh /usr/share/doc/ansible-doc/
> 3.9G    /usr/share/doc/ansible-doc/
> find /usr/share/doc/ansible-doc/ | wc -l
> 2368

I'm going to report this issue upstream

Comment 4 Tim Bielawa 2018-04-04 17:02:50 UTC
Issue reported upstream: https://github.com/ansible/ansible/issues/38288

Comment 5 Tim Bielawa 2018-04-05 13:53:16 UTC
This issue has been fixed upstream in [0].

Fedora 26+ though all need rebuilds. I suspect this fix will be delivered when Kevin submits the next batch of updated package builds. 

(The el6,7 [1,2] builds seems to be fine when I extracted their -doc packages.)



[0] https://github.com/ansible/ansible/pull/38311
[1] https://koji.fedoraproject.org/koji/buildinfo?buildID=1063170
[2] https://koji.fedoraproject.org/koji/buildinfo?buildID=1063168

Comment 6 Kevin Fenzi 2018-04-05 16:28:30 UTC
Awesome. Thanks for the quick work. 

I will try and push this with the next round of builds indeed.

Comment 7 Fedora Update System 2018-04-19 05:02:52 UTC
ansible-2.5.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d35b90fd1d

Comment 8 Fedora Update System 2018-04-19 05:03:32 UTC
ansible-2.5.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-ad971a0926

Comment 9 Fedora Update System 2018-04-19 05:03:58 UTC
ansible-2.5.1-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-abc92e5946

Comment 10 Fedora Update System 2018-04-19 05:04:23 UTC
ansible-2.5.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-de434df4ac

Comment 11 Fedora Update System 2018-04-19 05:04:49 UTC
ansible-2.5.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b2058f774a

Comment 12 Fedora Update System 2018-04-19 08:55:27 UTC
ansible-2.5.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-de434df4ac

Comment 13 Fedora Update System 2018-04-19 16:58:57 UTC
ansible-2.5.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-ad971a0926

Comment 14 Fedora Update System 2018-04-19 17:12:11 UTC
ansible-2.5.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b2058f774a

Comment 15 Fedora Update System 2018-04-19 17:38:31 UTC
ansible-2.5.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d35b90fd1d

Comment 16 Fedora Update System 2018-04-19 21:56:52 UTC
ansible-2.5.1-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-abc92e5946

Comment 17 Artur Penttinen 2018-04-20 04:00:01 UTC
# dnf download ansible-doc --enablerepo=updates-testing
# rpm -qipf ansible-doc-2.5.1-1.fc27.noarch.rpm | grep Size
Size        : 503331670
# print -f "%.1fMb\\n" $[503331670/1024./1024.]
480.0Mb

Looks good!

Comment 18 Fedora Update System 2018-04-21 02:57:36 UTC
ansible-2.5.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2018-04-21 03:40:27 UTC
ansible-2.5.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-04-26 22:23:40 UTC
ansible-2.5.2-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-cd33ebf025

Comment 21 Fedora Update System 2018-04-27 04:08:09 UTC
ansible-2.5.1-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2018-04-27 11:17:54 UTC
ansible-2.5.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2018-04-28 17:36:03 UTC
ansible-2.5.2-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-cd33ebf025

Comment 24 Fedora Update System 2018-05-13 20:31:23 UTC
ansible-2.5.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.