Bug 1563653 - Adding a 4.1 RHVH host to a 4.2 engine fails
Summary: Adding a 4.1 RHVH host to a 4.2 engine fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Host-Deploy
Version: 4.2.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.2.3
: ---
Assignee: bugs@ovirt.org
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 12:01 UTC by Yuval Turgeman
Modified: 2019-04-28 13:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-05 06:53:44 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)

Description Yuval Turgeman 2018-04-04 12:01:35 UTC
Description of problem:
When trying to add a 4.1 RHVH to a 4.2 engine, add host fails with the following error:

2018-04-04 07:38:49,984 p=22959 u=ovirt |  TASK [ovirt-provider-ovn-driver : Install ovirt-provider-ovn-driver] ***********
2018-04-04 07:38:52,761 p=22959 u=ovirt |  fatal: [192.168.122.41]: FAILED! => {
    "changed": false, 
    "rc": 126, 
    "results": [
        "No package matching 'ovirt-provider-ovn-driver' found available, installed or updated"
    ]
}


How reproducible:
Install a 4.1 RHVH and add it to a 4.2 engine.

Steps to Reproduce:
1. Install RHVH-4.1
2. Add the installed machine to RHVM

Actual results:
Fails to add host

Expected results:
Host should be added to RHVM (unless a 4.1 host is not supported in 4.2)

Comment 1 Ryan Barry 2018-04-04 12:46:45 UTC
Changing components, since we're trying to track deps for this in ovirt-host now, to have a unified place for all oVirt dependencies.

Comment 2 Sandro Bonazzola 2018-04-04 12:56:14 UTC
Dan, do we really need to enforce ovirt-provider-ovn-driver on 4.1 hosts?

Sahina, please check 3.6 hosts can still be added too, I've the feeling this may impact 3.6 hosts for RHGS if we still need to support them.

Comment 3 Red Hat Bugzilla Rules Engine 2018-04-04 12:57:46 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 4 Sandro Bonazzola 2018-04-04 12:59:49 UTC
Moved to engine component, since this is a regression introduced in the ansible post-deploy code

Comment 5 Martin Perina 2018-04-04 13:07:39 UTC
AFAIK OVN shouldn't be configured for hosts in clusters with level 4.1 and below:

https://github.com/oVirt/ovirt-engine/blob/master/packaging/playbooks/roles/ovirt-provider-ovn-driver/tasks/main.yml#L27

Could you please add engine logs?

Comment 6 Yuval Turgeman 2018-04-04 13:55:06 UTC
Managed to get around this, cluster level was indeed wrong.  But I hit a different issue:

2018-04-04 09:48:13,139 p=2560 u=ovirt |  TASK [ovirt-host-deploy-firewalld : Check if VDSM version is supported for FirewallD] ***
2018-04-04 09:48:13,171 p=2560 u=ovirt |  fatal: [192.168.122.174]: FAILED! => {
    "changed": false
}

MSG:

VDSM version 4.19.51 is not supported for FirewallD.


Is that covered in a different bug ?

Comment 7 Dan Kenigsberg 2018-04-04 14:59:43 UTC
(In reply to Yuval Turgeman from comment #6)
> VDSM version 4.19.51 is not supported for FirewallD.
> 
> Is that covered in a different bug ?

probably yes, though similar.

to which cluster level is this host added?

if it is cluster of level 4.2, this is not a bug - a 4.1 host cannot be added to it. if, however, this is a new cluster, or a 4.1 cluster, we'd need to fix both bugs (requiring of ovn driver and FirewallD)

Comment 8 Yuval Turgeman 2018-04-04 15:12:57 UTC
Ovn rpm issue encountered in a 4.2 cluster, Firewalld issue encountered in cluster level 4.1

Comment 9 Martin Perina 2018-04-04 17:49:26 UTC
FirewallD works as expected, it's not bound to cluster level, but to the VDSM version on the host. So if all your hosts contains VDSM from 4.2, you can have firewalld enabled even though cluster level is 4.1

Comment 10 Yuval Turgeman 2018-04-04 17:55:57 UTC
(In reply to Martin Perina from comment #9)
> FirewallD works as expected, it's not bound to cluster level, but to the
> VDSM version on the host. So if all your hosts contains VDSM from 4.2, you
> can have firewalld enabled even though cluster level is 4.1

So RHVH 4.1 with firewalld enabled can't be added to a 4.2 engine even if the cluster level is 4.1 ?

Comment 11 Martin Perina 2018-04-04 17:58:58 UTC
(In reply to Yuval Turgeman from comment #10)
> (In reply to Martin Perina from comment #9)
> > FirewallD works as expected, it's not bound to cluster level, but to the
> > VDSM version on the host. So if all your hosts contains VDSM from 4.2, you
> > can have firewalld enabled even though cluster level is 4.1
> 
> So RHVH 4.1 with firewalld enabled can't be added to a 4.2 engine even if
> the cluster level is 4.1 ?

Correct, firewalld works only with RHVH 4.2. If you want to add RHVH 3.6/4.0/4.1 to engine 4.2, then the cluster needs to be set to iptables

Comment 12 Yuval Turgeman 2018-04-04 18:25:31 UTC
Got it, it works now, I guess we can close this - it would have been nice if the default firewall type would change to iptables if the user selects a cluster level < 4.2.  Anyway, sorry for the noise.

Comment 13 Sandro Bonazzola 2018-04-05 06:53:44 UTC
Closing as per comment #12


Note You need to log in before you can comment on or make changes to this bug.