Bug 1563664 - Ansible deployments fails on NFS with root_squash option
Summary: Ansible deployments fails on NFS with root_squash option
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.NFS
Version: 2.2.14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.2.2
: 2.2.16
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1458709
TreeView+ depends on / blocked
 
Reported: 2018-04-04 12:20 UTC by Simone Tiraboschi
Modified: 2018-04-27 07:22 UTC (History)
3 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.16-1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 07:22:52 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
he_images (355.15 KB, application/x-gzip)
2018-04-18 14:47 UTC, Polina
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 89801 0 master MERGED ansible: correctly set become 2018-09-03 09:34:01 UTC
oVirt gerrit 89847 0 ovirt-hosted-engine-setup-2.2 MERGED ansible: correctly set become 2018-04-05 07:13:39 UTC

Description Simone Tiraboschi 2018-04-04 12:20:17 UTC
Description of problem:
Ansible deployments fails on NFS with root_squash option


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-2.2.14

How reproducible:
100%

Steps to Reproduce:
1. configure the NFS share with root_squash option
2. deploy hosted-engine
3.

Actual results:
2018-04-03 15:01:55,423+0000 INFO otopi.ovirt_hosted_engine_setup.ansible_utils ansible_utils._process_output:100 TASK [Copy configuration archive to storage]
2018-04-03 15:01:55,729+0000 DEBUG otopi.ovirt_hosted_engine_setup.ansible_utils ansible_utils._process_output:94 {u'_ansible_parsed': True, u'stderr_lines': [u'dd: failed to open \u2018/rhev/data-center/mnt/node.local:_srv_data/81292f3f-11d3-4e38-9afa-62e133aa8017/images/c5510e77-1ee0-479c-b6cf-24c179313a45/5ef881f5-c992-48d2-b969-a0b6156bdf7c\u2019: Permission denied'], u'cmd': [u'dd', u'bs=20480', u'count=1', u'oflag=direct', u'if=/var/tmp/localvmbCDQIR/5ef881f5-c992-48d2-b969-a0b6156bdf7c', u'of=/rhev/data-center/mnt/node.local:_srv_data/81292f3f-11d3-4e38-9afa-62e133aa8017/images/c5510e77-1ee0-479c-b6cf-24c179313a45/5ef881f5-c992-48d2-b969-a0b6156bdf7c'], u'end': u'2018-04-03 15:01:55.581823', u'_ansible_no_log': False, u'stdout': u'', u'changed': True, u'start': u'2018-04-03 15:01:55.577487', u'delta': u'0:00:00.004336', u'stderr': u'dd: failed to open \u2018/rhev/data-center/mnt/node.local:_srv_data/81292f3f-11d3-4e38-9afa-62e133aa8017/images/c5510e77-1ee0-479c-b6cf-24c179313a45/5ef881f5-c992-48d2-b969-a0b6156bdf7c\u2019: Permission denied', u'rc': 1, u'invocation': {u'module_args': {u'warn': True, u'executable': None, u'_uses_shell': False, u'_raw_params': u'dd bs=20480 count=1 oflag=direct if="/var/tmp/localvmbCDQIR/5ef881f5-c992-48d2-b969-a0b6156bdf7c" of="/rhev/data-center/mnt/node.local:_srv_data/81292f3f-11d3-4e38-9afa-62e133aa8017/images/c5510e77-1ee0-479c-b6cf-24c179313a45/5ef881f5-c992-48d2-b969-a0b6156bdf7c"', u'removes': None, u'creates': None, u'chdir': None, u'stdin': None}}, u'stdout_lines': [], u'msg': u'non-zero return code'}

Expected results:
Successfully deployment 

Additional info:

Comment 1 Simone Tiraboschi 2018-04-04 14:10:28 UTC
anonuid=36,anongid=36 seams enough to prevent this.
It happens only with root_squash and no anonuid=36,anongid=36.

Comment 2 Polina 2018-04-18 14:47:09 UTC
Created attachment 1423630 [details]
he_images

Comment 3 Polina 2018-04-18 14:48:13 UTC
Hi, could you please confirm that the verifying steps answer the requirement.
packages:
rhv-release-4.2.3-1-001.noarch
rhvm-appliance-4.2-20180410.0.el7.noarch
ovirt-hosted-engine-setup-2.2.17-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.10-1.el7ev.noarch

1. on nfs-server in /etc/exports add -
/Compute_NFS/nsednev_he_4_data_sd_2 10.0.0.0/255.0.0.0(rw,root_squash)
2. yum install ovirt-hosted-engine-setup
   yum install rhvm-appliance
   hosted-engine --deploy

Result:
[ INFO  ] Hosted Engine successfully deployed

hosted-engine storage and vm images attached

Comment 4 Simone Tiraboschi 2018-04-18 15:05:29 UTC
(In reply to Polina from comment #3)
> Hi, could you please confirm that the verifying steps answer the requirement.

Yes, exactly that.

Comment 5 Sandro Bonazzola 2018-04-27 07:22:52 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.