Bug 1563678 - Neutron test_trunk_subport_lifecycle failure on OVN setup
Summary: Neutron test_trunk_subport_lifecycle failure on OVN setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Daniel Alvarez Sanchez
QA Contact: Eran Kuris
URL:
Whiteboard:
: 1558570 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 12:28 UTC by Eran Kuris
Modified: 2019-09-09 13:54 UTC (History)
7 users (show)

Fixed In Version: python-networking-ovn-4.0.1-0.20180420150809.c7c16d4.el7ost
Doc Type: Bug Fix
Doc Text:
When a subport was reassigned to a different trunk on another hypervisor, it did not get its binding info updated and the subport did not transition to ACTIVE. This fix clears up the binding info when the subport is removed from the trunk. The subport now transitions to ACTIVE when it is reassigned to another trunk port that resides on a different hypervisor.
Clone Of:
Environment:
Last Closed: 2018-06-27 13:50:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1761194 0 None None None 2018-04-04 13:47:41 UTC
OpenStack gerrit 558844 0 None MERGED Clear binding:host_id when a subport is removed from a trunk 2021-01-08 00:48:24 UTC
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:50:53 UTC

Description Eran Kuris 2018-04-04 12:28:40 UTC
Description of problem:
 Neutron test_trunk_subport_lifecycle failure on OVN setup

        Body: None
    Response - Headers: {'status': '200', u'content-length': '1560', 'content-location': 'http://10.0.0.102:8774/v2.1/servers/ded7e586-addf-4d41-971e-03c0de078e7b', u'x-compute-request-id': 'req-6d709d63-0456-451e-a474-c161d70bfd81', u'vary': 'OpenStack-API-Version,X-OpenStack-Nova-API-Version,Accept-Encoding', u'server': 'Apache', u'openstack-api-version': 'compute 2.1', u'connection': 'close', u'x-openstack-nova-api-version': '2.1', u'date': 'Sat, 31 Mar 2018 15:35:10 GMT', u'content-type': 'application/json', u'x-openstack-request-id': 'req-6d709d63-0456-451e-a474-c161d70bfd81'}
        Body: {"server": {"OS-EXT-STS:task_state": "deleting", "addresses": {"tempest-test-network--1787378211": [{"OS-EXT-IPS-MAC:mac_addr": "fa:16:3e:88:c1:6a", "version": 4, "addr": "10.100.0.14", "OS-EXT-IPS:type": "fixed"}, {"OS-EXT-IPS-MAC:mac_addr": "fa:16:3e:88:c1:6a", "version": 4, "addr": "10.0.0.215", "OS-EXT-IPS:type": "floating"}]}, "links": [{"href": "http://10.0.0.102:8774/v2.1/servers/ded7e586-addf-4d41-971e-03c0de078e7b", "rel": "self"}, {"href": "http://10.0.0.102:8774/servers/ded7e586-addf-4d41-971e-03c0de078e7b", "rel": "bookmark"}], "image": {"id": "93ef2b63-3732-46d1-8e2d-49bc879e8c12", "links": [{"href": "http://10.0.0.102:8774/images/93ef2b63-3732-46d1-8e2d-49bc879e8c12", "rel": "bookmark"}]}, "OS-EXT-STS:vm_state": "active", "OS-SRV-USG:launched_at": "2018-03-31T15:30:42.000000", "flavor": {"id": "200", "links": [{"href": "http://10.0.0.102:8774/flavors/200", "rel": "bookmark"}]}, "id": "ded7e586-addf-4d41-971e-03c0de078e7b", "user_id": "6fa067de11754d93aa74199a8668287a", "OS-DCF:diskConfig": "MANUAL", "accessIPv4": "", "accessIPv6": "", "progress": 0, "OS-EXT-STS:power_state": 1, "OS-EXT-AZ:availability_zone": "nova", "config_drive": "", "status": "ACTIVE", "updated": "2018-03-31T15:35:10Z", "hostId": "c8cc696576e5b2b82fd415cca9ce66da0d111a0299a2bd95dc46b099", "OS-SRV-USG:terminated_at": null, "key_name": "tempest-keypair-test-1172149803", "name": "tempest-server-test-1773727956", "created": "2018-03-31T15:30:28Z", "tenant_id": "54c431fbb7484f7ba539430f7e0405e0", "os-extended-volumes:volumes_attached": [], "metadata": {}}}
2018-03-31 11:35:11,891 31887 INFO     [tempest.lib.common.rest_client] Request (TrunkTest:_run_cleanups): 404 GET http://10.0.0.102:8774/v2.1/servers/ded7e586-addf-4d41-971e-03c0de078e7b 0.120s
2018-03-31 11:35:11,891 31887 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '404', u'content-length': '111', 'content-location': 'http://10.0.0.102:8774/v2.1/servers/ded7e586-addf-4d41-971e-03c0de078e7b', u'x-compute-request-id': 'req-5c3be544-77bc-4949-b563-e89cc88c42fe', u'vary': 'OpenStack-API-Version,X-OpenStack-Nova-API-Version', u'server': 'Apache', u'openstack-api-version': 'compute 2.1', u'connection': 'close', u'x-openstack-nova-api-version': '2.1', u'date': 'Sat, 31 Mar 2018 15:35:11 GMT', u'content-type': 'application/json; charset=UTF-8', u'x-openstack-request-id': 'req-5c3be544-77bc-4949-b563-e89cc88c42fe'}
        Body: {"itemNotFound": {"message": "Instance ded7e586-addf-4d41-971e-03c0de078e7b could not be found.", "code": 404}}
}}}

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/scenario/test_trunk.py", line 219, in test_trunk_subport_lifecycle
    "transition to ACTIVE." % s['port_id']))
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/common/utils.py", line 72, in wait_until_true
    raise exception
RuntimeError: Timed out waiting for subport 0bb6993a-f28c-4d93-9575-72731302bcdf to transition to ACTIVE.
Version-Release number of selected component (if applicable):
OSP13 ha ovn p 29_3_18

How reproducible:
always

Steps to Reproduce:
1. deploy OSP13 ovn HA  and ru hte test
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Daniel Alvarez Sanchez 2018-04-11 14:02:54 UTC
*** Bug 1558570 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2018-06-27 13:50:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.