Bug 1563681 - Add OpenShift 3.9 ansible inventory file and copy in to metrics store machine
Summary: Add OpenShift 3.9 ansible inventory file and copy in to metrics store machine
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic
Version: 1.1.3.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.3
: ---
Assignee: Shirly Radco
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 12:32 UTC by Shirly Radco
Modified: 2018-05-10 06:28 UTC (History)
1 user (show)

Fixed In Version: ovirt-engine-metrics-1.1.4-1.el7ev
Doc Type: Enhancement
Doc Text:
Feature: To make OpenShift installation easier, we generate the inventory files and vars.yml file and copy them to the metrics store machine. Reason: To make OpenShift installation easier Result: The user does not need to handle the inventory and vars.yml file and can use them when running the OpenShift ansible playbooks.
Clone Of:
Environment:
Last Closed: 2018-05-10 06:28:52 UTC
oVirt Team: Metrics
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 89820 0 master MERGED Added ansible-inventory 3.9 2018-04-08 06:37:54 UTC

Description Shirly Radco 2018-04-04 12:32:08 UTC
Description of problem:
To support for OpenShift 3.9 we need to add the ansible inventory files and copy them to metrics store machine or installation of the metrics store machine will faile. 

Version-Release number of selected component (if applicable):
1.1.3.4

How reproducible:
100%


Steps to Reproduce:
1.Run Installation of metrics store machine, based on OpenShift 3.9, according to instructions.
2.
3.

Actual results:
Metrics store fails on OpenShift version

Expected results:
Installation of metrics store machine should support OpenShift 3.9

Additional info:

Comment 1 Lukas Svaty 2018-04-10 09:56:11 UTC
verified in ovirt-engine-metrics-1.1.4-0.0.master.20180408064245.el7.centos.noarch

TASK [oVirt.metrics/roles/oVirt.metrics-store-installation : Copy inventory files to metrics store machine] *******************************************************************************************************
changed: [10-37-138-124.rhev.lab.eng.brq.redhat.com] => (item=ansible-inventory-ocp-39-aio)
changed: [10-37-138-124.rhev.lab.eng.brq.redhat.com] => (item=ansible-inventory-origin-39-aio)

Comment 2 Sandro Bonazzola 2018-05-10 06:28:52 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.