Bug 1563800 - Fedora 28 Beta 1.3 won't boot on Raspberry Pi 3+
Summary: Fedora 28 Beta 1.3 won't boot on Raspberry Pi 3+
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 28
Hardware: armhfp
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Václav Pavlín
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 18:00 UTC by Markku Kolkka
Modified: 2018-04-05 18:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-05 18:17:36 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of the messages (256.53 KB, image/jpeg)
2018-04-04 18:00 UTC, Markku Kolkka
no flags Details

Description Markku Kolkka 2018-04-04 18:00:02 UTC
Created attachment 1417384 [details]
screenshot of the messages

Description of problem:
KDE desktop spin does not boot on the new Pi 3+, gets stuck at a U-Boot prompt

Version-Release number of selected component (if applicable):
Fedora-KDE-armhfp-28_Beta-1.3

How reproducible:
100% (2 out of 2 attempts)

Steps to Reproduce:
1. Download Fedora-KDE-armhfp-28_Beta-1.3-sda.raw.xz
2. Burn to a micro SD card with fedora-arm-installer
3. Insert card to a Rasberry Pi 3+ and connect the power

Actual results:
Long list of text messages finishing with:
Config file not found
U-Boot>

Expected results:
KDE desktop starting

Additional info:

Comment 1 Kevin Fenzi 2018-04-05 17:54:12 UTC
This might be a uboot bug... but not sure. 

Adding some Arm folks.

Comment 2 Peter Robinson 2018-04-05 18:17:36 UTC
No, it's a kernel problem, we didn't have a suitable kernel in Beta. It works fine with the nightly from 20180404 but I suggest you wait until the compose that includes the 4.16.0-300 kernel because that fixes a whole bunch of stuff on the 3+, it's on it's way to stable now.


Note You need to log in before you can comment on or make changes to this bug.