Bug 1563815 - Prod VM accidently created in 4.2 Beta, unable to export and import it to 4.1 GA
Summary: Prod VM accidently created in 4.2 Beta, unable to export and import it to 4.1 GA
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 19:20 UTC by Jason
Modified: 2021-06-10 15:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-23 19:48:27 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)

Description Jason 2018-04-04 19:20:21 UTC
Description of problem (Responses are direct from customer):

Unable to Export and Import Machine

I am unable to export a virtual machine that was accidentally created in a 4.2 datacenter to a 4.1 datacenter. A mission critical VM was created in a 4.2 Beta with teh requirement to run in 4.1

Where are you experiencing the behavior?  What environment?

Redhat 4.2 Beta exporting via Export Domain is able to mount to 4.1 Datacenter but is unable to display the contained VM but throws an OVF failure.

When does the behavior occur? Frequently?  Repeatedly?   At certain times?

It is consistent and complete. We can always reproduce this error and need to find a method to migrate this VM.

What information can you provide around timeframes and the business impact?

This is a mission critical VM that has to be migrated immediately. We need to find a method for migration.  We need to determine a method of either doing a V2V to the 4.1 data-center or I need advise on the proper migration method.


Actual results:


If I am unable to export out of the datacenter. Is there a method to us Virt-V2V to migrate it to a 4.1 datacenter. I know 4.2 is not intended for production but one of the engineers did not. This was an error and I am looking for a potential migration path if possible.

Expected results:

Be able to export from 4.2 Beta into 4.1 GA environment

Comment 1 Yaniv Kaul 2018-04-04 20:18:13 UTC
Logs?
Was it reproduced?

Comment 2 Michal Skrivanek 2018-04-05 05:03:03 UTC
if we ignore the VM configuration(that could be easily recreated) then the only issue is with disk(s). You can use image download/upload then to copy it to a different DC

Still, export/import should work too so indeed please reproduce and attach logs

Comment 3 Michal Skrivanek 2018-04-16 13:10:53 UTC
ping?

Comment 4 Marina Kalinin 2018-04-23 19:48:27 UTC
The customer has reported that the issue was resolved and closed the case.
I suggest closing this bug too for now.

Comment 6 Franta Kust 2019-05-16 13:04:49 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.