Bug 1563897 - [abrt] openscad: std::__replacement_assert(char const*, int, char const*, char const*)(): openscad killed by SIGABRT
Summary: [abrt] openscad: std::__replacement_assert(char const*, int, char const*, cha...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openscad
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:e4af10747bd69dac52c79e8629c...
: 1564734 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-05 02:24 UTC by Craig Robson
Modified: 2018-04-29 20:52 UTC (History)
3 users (show)

Fixed In Version: openscad-2015.03.3-16.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-29 20:52:57 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (78.93 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: cgroup (399 bytes, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: core_backtrace (16.32 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: cpuinfo (1.38 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: dso_list (15.81 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: environ (6.14 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: maps (79.16 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: mountinfo (4.16 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: open_fds (1.15 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
File: proc_pid_status (1.28 KB, text/plain)
2018-04-05 02:24 UTC, Craig Robson
no flags Details
OpenSCAD file that causes issue (652 bytes, text/plain)
2018-04-05 02:26 UTC, Craig Robson
no flags Details

Description Craig Robson 2018-04-05 02:24:25 UTC
Description of problem:
Trying to render a drawing that contains a linear_extrude() command.

Version-Release number of selected component:
openscad-2015.03.3-14.fc28

Additional info:
reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        openscad
crash_function: std::__replacement_assert(char const*, int, char const*, char const*)
executable:     /usr/bin/openscad
journald_cursor: s=3f4a7380bb154de8ba87433d459d604b;i=1d725e;b=6907c0d9d0ad4a838a8711eb94c3cba8;m=9930bae88;t=569107dfd3ae8;x=803d14caacdd2a1d
kernel:         4.16.0-300.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Craig Robson 2018-04-05 02:24:30 UTC
Created attachment 1417486 [details]
File: backtrace

Comment 2 Craig Robson 2018-04-05 02:24:31 UTC
Created attachment 1417487 [details]
File: cgroup

Comment 3 Craig Robson 2018-04-05 02:24:33 UTC
Created attachment 1417488 [details]
File: core_backtrace

Comment 4 Craig Robson 2018-04-05 02:24:34 UTC
Created attachment 1417489 [details]
File: cpuinfo

Comment 5 Craig Robson 2018-04-05 02:24:35 UTC
Created attachment 1417490 [details]
File: dso_list

Comment 6 Craig Robson 2018-04-05 02:24:36 UTC
Created attachment 1417491 [details]
File: environ

Comment 7 Craig Robson 2018-04-05 02:24:37 UTC
Created attachment 1417492 [details]
File: limits

Comment 8 Craig Robson 2018-04-05 02:24:38 UTC
Created attachment 1417493 [details]
File: maps

Comment 9 Craig Robson 2018-04-05 02:24:39 UTC
Created attachment 1417494 [details]
File: mountinfo

Comment 10 Craig Robson 2018-04-05 02:24:40 UTC
Created attachment 1417495 [details]
File: open_fds

Comment 11 Craig Robson 2018-04-05 02:24:41 UTC
Created attachment 1417496 [details]
File: proc_pid_status

Comment 12 Craig Robson 2018-04-05 02:26:43 UTC
Created attachment 1417497 [details]
OpenSCAD file that causes issue

Adding OpenSCAN input file that causes the issue.

Comment 13 Miro Hrončok 2018-04-12 09:42:04 UTC
linear_extrude() square(); -> F6 -> crash

Comment 14 Miro Hrončok 2018-04-12 09:42:19 UTC
*** Bug 1564734 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2018-04-21 14:55:57 UTC
openscad-2015.03.3-16.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ace1f19028

Comment 16 Fedora Update System 2018-04-23 22:51:09 UTC
openscad-2015.03.3-16.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ace1f19028

Comment 17 Craig Robson 2018-04-24 03:09:50 UTC
openscad-2015.03.3-16.fc28 works for me.  Thanks.

Comment 18 Fedora Update System 2018-04-29 20:52:57 UTC
openscad-2015.03.3-16.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.