Bug 15640 - 3c556 Ethernet cards
3c556 Ethernet cards
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-07 10:24 EDT by Frank Sweetser
Modified: 2014-03-16 22:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 15:39:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for 3c556 (5.17 KB, patch)
2000-08-07 10:26 EDT, Frank Sweetser
no flags Details | Diff

  None (edit)
Description Frank Sweetser 2000-08-07 10:24:42 EDT
The 3c556 ethernet card (also known as the "mini-pci" card, appearing on
more and more laptops recently) isn't supported out of the box.  However,
the 3c59x driver will support it with a fairly trivial patch (attached).
Comment 1 Frank Sweetser 2000-08-07 10:26:46 EDT
Created attachment 2177 [details]
Patch for 3c556
Comment 2 Frank Sweetser 2000-08-07 10:37:00 EDT
Almost forgot - PCI id 6055.
Comment 3 Michael K. Johnson 2000-08-07 23:56:03 EDT
Thanks for the patch, will include it in our source
package.  I assume that you are sending the patch
up-stream, or that you got it from up-stream?
Comment 4 Frank Sweetser 2000-08-08 10:01:55 EDT
I recieved this patch from Alan Cox on testers-list, so I guess that counts as
upstream =)  Upon further experimenting, it seems that on this laptop at least,
the card doesn't wake up from a suspend/resume, requring a driver
unload/reload.  I've been talking with Don Becker, and he seems to be working on
an idea for how to fix that in his driver.
Comment 5 Michael K. Johnson 2000-08-10 15:39:45 EDT
Bill, does this need any changes in kudzu?
Adrian, want to append lspci output for Bill?
Comment 6 Bill Nottingham 2000-08-11 09:53:47 EDT
Added to CVS, will be in next kudzu build.

Note You need to log in before you can comment on or make changes to this bug.