Bug 1564037 - pep8 job failing on networking-ovn component CI
Summary: pep8 job failing on networking-ovn component CI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 13.0 (Queens)
Assignee: Lucas Alvares Gomes
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-05 07:42 UTC by anil venkata
Modified: 2019-09-09 14:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 15:35:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 559066 0 None None None 2018-04-09 08:10:37 UTC

Description anil venkata 2018-04-05 07:42:36 UTC
Description of problem:
pep8 job failing on networking-ovn component CI on OSP13 branch

https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/DFG-network-networking-ovn-13-pep8-rhos/9/consoleFull

10:31:17 ************* Module networking_ovn.cmd.neutron_ovn_db_sync_util
10:31:17 E: 20, 0: No name 'topics' in module 'neutron.common' (no-name-in-module)

networking-ovn imports topics.py from neutron.common
In upstream master branch, topics.py is removed from neutron repo and added to neutron_lib. But in queens branch, topics.py still exists in neutron repo. 

Looks like tox is using neutron master branch instead of queens(or osp13) branch.
In my local OSP13 setup, I see tox executing below command(from tools/tox_install.sh) which is pulling master branch instead of queens.

pip install -chttps://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt?h=stable/queens -U -e git+https://git.openstack.org/openstack/neutron@master#egg=neutron

I faced the same issue when I tried locally running pep8 on upsteam queens branch, but CI pep8 job on upstream queens branch is successful. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Lucas Alvares Gomes 2018-04-05 10:34:13 UTC
Apparently we have the same error for stable/queens upstream, I've backported the fix here https://review.openstack.org/#/c/559046/

Comment 2 Lucas Alvares Gomes 2018-04-05 12:43:43 UTC
(In reply to Lucas Alvares Gomes from comment #1)
> Apparently we have the same error for stable/queens upstream, I've
> backported the fix here https://review.openstack.org/#/c/559046/

Ignore this... It just worksaround the problem. Apparently the error was in the tox_install.sh script. I've uploaded another patch to fix it at https://review.openstack.org/#/c/559066/


Note You need to log in before you can comment on or make changes to this bug.