Bug 156405 - Fedora cd boot doesn't work on Dell Latitude c600 laptop
Fedora cd boot doesn't work on Dell Latitude c600 laptop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Brock Organ
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-04-29 16:08 EDT by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: test3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 16:34:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FC4-test3 boot failure (1.04 MB, image/jpeg)
2005-05-11 09:08 EDT, Kyrre Ness Sjøbæk
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2005-04-29 16:08:53 EDT
Description of problem:
If i burn a "boot.iso" image and boot a Dell Lattitude (c600) laptop computer
with it, i get to the "type linux text for textmode install, or just press
enter" display (isolinux?). It seems kind of borked - the nice fedora logo is
gone, and the computer just hangs dead, nothing more happens. I know the cd is
all well - i just booted another computer off it, just to test.

Version-Release number of selected component (if applicable):
rawhide as of 29 apr.
boot.iso md5:
79a823a94e5c503a1ad30a349e179b73  boot.iso
(thats the best version ID i can get on it... Where can i find the exact version?)

Poster to fedora-test-list talked about it happening to a fc4t2 (full ?) iso as
well.

How reproducible:
Every time.

Steps to Reproduce:
1.Burn boot.iso
2.insert into dell lattitude laptop
3.boot
4.hang
  
Actual results:
Hangs

Expected results:
Works

Additional info:
I was able to workaround the bug using these instructions
http://www.johnwyles.com/archives/2004/07/05/fedora_core_2_network_install.php

I know "distrobution" component is wrong, but i found no isolinux component. I
guess somebody knows which component this is.

I can probably use the machine for some experimenting/reinstalling etc.

This problem was talked about at the fedora-test-list
Comment 1 Sean Bruno 2005-04-29 16:37:26 EDT
I have a bit newer model, D800.  No installation and bootup issues noted at this
time.  I have issues with sound and temperature(fans running constantly).
Comment 2 Kyrre Ness Sjøbæk 2005-04-29 19:33:09 EDT
On my c600 ACPI works completely flawlessly (even ACPI sleep "just works"), same
with sound. It is a ESS board. Only thing that wasn't autodetected was the LCD,
leading to a text-mode install.

but this is offtopic.

Anyway, here comes lspci:
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge
(rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge
(rev 03)
00:03.0 CardBus bridge: Texas Instruments PCI1420
00:03.1 CardBus bridge: Texas Instruments PCI1420
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:08.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI Audio
Accelerator (rev 10)
00:10.0 Ethernet controller: 3Com Corporation 3c556 Hurricane CardBus [Cyclone]
(rev 10)
00:10.1 Communication controller: 3Com Corporation Mini PCI 56k Winmodem (rev 10)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M3 AGP 2x
(rev 02)
Comment 3 Raymond Lillard 2005-04-29 20:47:30 EDT
I tried to boot the FC4-test1 iso in a Latitude D810 with the identical result 
observed by the original poster.  The Latitude D810 uses the M70 class
processor.  I lacked the time to mess with it so I moved on.

I installed the latest OpenBSd-v3.7 snapshot and all went well except no DMA 
on either the harddrive or CD drive.  A quick patch from one of the developers 
and all was well.  I now use OpenBSD except when I need to work with Microsoft 
documents (OpenOffice doesn't work with OpenBSD). Then I use Linux FC3.

I installed FC3 on a different drive (I swap drives rather than that silly 
dual-boot thing).  That installation went well, except that I haven't been 
able to get the CD/DVD drive to use DMA. This prevents me from watching 
movies and in all likelyhood burning CDs or DVDs.

On another disk I tried Ubuntu 5.04 with the same no DMA problem.  It uses a 
2.6.10 kernel.

Next along came a FC3 kernel update to 2.6.11 and my machine will not boot 
it, so when I use Linux, I revert back to the last v2.6.10 kernel. and all 
is well, except for the CD/DVD DMA thing.

I even tried downloading a 2.6.11 kernel from kernel.org and was unable to 
build one that worked.

The common thread for me seems that the v2.6.11 kernel is completely borked 
on M70 hardware and v2.6.10 won't do DMA.  I looked at the OpenBSD code and 
tried to figure out how to fix the Linux kernel, but eventually gave up.  I 
leave to problem to better men (or women) than me.

I can see this as a crisis for some, but I am spending most of my time in 
OpenBSD, because it works.

If any Linux kernel hacker would like a dmesg, I'd be pleased to send one. 
I would also be happy to test any patches.  Contact me at: ryl@sonic.net

Comment 4 Kyrre Ness Sjøbæk 2005-04-30 06:53:27 EDT
Whats crazy about this laptop, is that syslinux did work without problems on
ubuntu. And as soon as i got the kernel booting using the workaround (compying
the  isolinux folder from the cd to /boot/f4install and modifyed the grub config
of the ubuntu install to boot it - i.e. avoiding isolinux completely) - it did work.

A curious problem i discovered while running ubuntu on it, is that it seemed to
"stutter" and freeze for a quarter of a secound randomly. Fedora doesn't do that.

About cdrom DMA i don't know - but i only have a CD (no DVD, no burner) drive.
How can i find it out? hdparm /dev/hdc gives me "permission denied" (as root -
even with a cd inside), but hdparm /dev/hda works. Whats curious is that
inserting a cd doesn't trigger the automount feature of gnome-volume-manager.
(cdrom isn't even in fstab) - but mounting it manually works without trouble.

Only HW problem i have experienced exept from this one, is:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=156418
Comment 5 Kyrre Ness Sjøbæk 2005-05-11 09:09:00 EDT
Created attachment 114242 [details]
FC4-test3 boot failure
Comment 6 Kyrre Ness Sjøbæk 2005-05-11 09:10:59 EDT
As the attachment indicate, its still here in test3. What is Fedora syslinux
doing that Ubuntu doesn't?

Anyway, if this is not fixed at the relase of FC4, it should (imho) be included
in the release notes.
Comment 7 Jeremy Katz 2005-05-11 10:45:39 EDT
What version of syslinux is ubuntu using?  It doesn't look like there's a newer
final version available.  Also, you could try editing the boot.msg file and
turning off the splash image and then remaking a boot.iso to see if that helps
at all.  
Comment 8 Peter Jones 2005-05-11 16:06:57 EDT
This should be fixed in syslinux 3.08, but it hasn't been released yet.
Comment 9 Kyrre Ness Sjøbæk 2005-05-11 17:49:31 EDT
Trying to make a new boot.iso - got some fairly interesting results...
First attemt was to remove the image from the boot.msg. It worked - kindof. The
text was displayed, no image - for about 1/10 of a secound, then reboot.

I then tried to replace isolinux.bin with the debug version (version 3.07),
which resulted in a red check-board all over the screen... The fan of the
computer started, indicating furious CPU activity.
Comment 10 Peter Jones 2005-05-19 21:55:20 EDT
Kyrre, can you try with the boot.iso from the (upcoming) May 20 rawhide build?

It'll be using syslinux 3.08, which hopefully will behave better.
Comment 11 Kyrre Ness Sjøbæk 2005-05-20 11:01:24 EDT
It works now. Only strange thing was that the picture was missing (it was there
when i booted the image in qemu before burning) - but that's okay - it *works*
now :)
Comment 12 Peter Jones 2005-05-20 13:49:28 EDT
OK, missing picture is still a bug, but not as important of one.  Moving this
down to lower priority, and taking it off the FC4Blocker list.
Comment 13 Dave Knight 2005-08-01 14:31:19 EDT
Same kind of problem with old Dell Latitude CP (166MHz... ARRGH!), however the
following details may be of interest to someone:

   This laptop properly boots the following from CDs I burned with the .iso
images:
   
    Redhat 9
    Knoppix 3.2.x
    Caldera (never again)
    
but will NOT boot FC2 or FC4 from CD.  I have re-burned the disk1 isos (yes, the
md5sums check out) to CDR several times, on different burners on different
systemsAll failures with the Redhat/FedoraCore CDs appear to occur for the same
reason, and in the same exact place, suggesting that there may be a problem in
the ide driver(?).  Here is
what happenes:

    -  boot from Disk1

    - alternate between Alt-F1 to view boot sequence and Alt-F4 to
      observe events log

F1 screen advances to the part where it runs sloader and stops.

F4 screen reveals that, somewhere after the NE2000 network card is recognized,
the CD drive seems to become inaccessible or otherwise unable to handle a
"command 0x28", which times out, repeatedly.  Because other Linux distributions
do not seem to have this problem

This is not a drop-dead issue for me, as I can go back to RH9 or run Knoppix, or
some other Linux distribution on this painfully slow laptop, but it should
probably be fixed before the next Enterprise release.
Comment 14 Dave Knight 2005-08-02 10:08:10 EDT
Attempts to install SuSE 9.3 Professional (a 2.6.11* Kernel) from CD failed with
the identical error (IDE cmd 0x28 times out) at the same point in the
installation (when it tries to mount the CD).  This suggests that the cause may
be a generic 2.6.x IDE-CD or ide-scsi kernel/driver problem.

More on Redhat 9:  Although my Redhat 9 (Shrike) installation CDs boot ok, the
CD drive is not accessible from the installed (and fully updated via
up2date/yum) Redhat 9 system.  All attempts to mount or access iso9660 or audio
CDs log errors indicating that the drive "returns" 4096 bytes of data when the
"max" expected or allowed is 2048.  This suggests that this drive or controller
behaves in a way the was handled OK by older kernel/drivers, but the
kernel/drivers were broken by an update sometime during the evolution of Redhat
9.   
Comment 15 Kyrre Ness Sjøbæk 2005-08-06 12:40:52 EDT
Dave: The problem here was syslinux - the thing that is booted by bios, and
boots the kernel - not the kernel. If the kernel boots at all, its not this bug.
It migth be another one - but not this one.
Comment 16 Jeremy Katz 2006-01-31 15:24:30 EST
Is tihs still a problem with FC5 test2?
Comment 17 Kyrre Ness Sjøbæk 2006-02-10 10:18:27 EST
FC5 test2's boot.iso works like a charm.
Comment 18 Kyrre Ness Sjøbæk 2006-02-10 10:21:08 EST
Just one thing before i forget it - the colour of the labels "[F1 - ??] [F2 -
??] ..." at the bottom of the screen was very hard to read, or even discover at
all - bad choice of colour!
Comment 19 Jeremy Katz 2006-02-27 16:34:51 EST
Labels fixed post test2

Note You need to log in before you can comment on or make changes to this bug.