Bug 1564065 - System critical updates report takes over 15 minutes to run
Summary: System critical updates report takes over 15 minutes to run
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 2.7
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space29
TreeView+ depends on / blocked
 
Reported: 2018-04-05 09:16 UTC by Laurence Rochfort
Modified: 2019-01-15 07:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-15 07:59:28 UTC


Attachments (Terms of Use)

Description Laurence Rochfort 2018-04-05 09:16:17 UTC
Description of problem:
The 'critical updates available' report takes over 15 minutes to run with around 400 systems in a group.

This causes an ISE due to the query taking too long to return.

This is due to a correlated subquery in the "relevant_to_server_group" query.

Version-Release number of selected component (if applicable):
2.6, 2.7

How reproducible:
a. Click on 'Systems'.
b. Click on 'System Groups'.
c. Click on a Group Name that has over 300 entries
d. Click on 'critical updates available'

Actual results:
15+ minute query time

Expected results:
Query response in under 15 seconds

Additional info:
Reproducible on Oracle and PostgreSQL

Comment 1 Tomáš Kašpárek 2018-04-06 08:15:34 UTC
spacewalk.git(master): f7b0e626fb5cdf1fb14043a43b3a5bda92574599

Comment 2 Michael Mráka 2018-11-26 09:44:05 UTC
Move Spacewalk 2.9 bugs ON_QA.

Comment 3 Michael Mráka 2019-01-15 07:59:28 UTC
Spacewalk 2.9 has been released.
https://github.com/spacewalkproject/spacewalk/wiki/ReleaseNotes29


Note You need to log in before you can comment on or make changes to this bug.