Bug 1564092 - Tuned: sysctl: support assignment modifiers as other plugins do.
Summary: Tuned: sysctl: support assignment modifiers as other plugins do.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Dominik Rehák
URL:
Whiteboard: aos-scalability-39
Depends On:
Blocks: 1561005
TreeView+ depends on / blocked
 
Reported: 2018-04-05 10:49 UTC by jmencak
Modified: 2018-10-30 10:51 UTC (History)
8 users (show)

Fixed In Version: tuned-2.10.0-0.1.rc1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:50:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3172 None None None 2018-10-30 10:51:10 UTC

Description jmencak 2018-04-05 10:49:19 UTC
Description of problem:
The current version of tuned does not support assignment modifiers as other plugins do for the sysctl plugin.

How reproducible:
Always

Steps to Reproduce:
1. systemctl stop tuned
2. Verify that `sysctl -n kernel.pid_max` is lower than 131072
32768
3. Use
[sysctl]
kernel.pid_max=>131072
in one of the tuned profiles.

4. Make the tuned profile active (+systemctl start tuned).
5. Query sysctl -n kernel.pid_max

Actual results:
32768

Expected results:
131072

Additional info:
Fixed upstream by 
https://github.com/redhat-performance/tuned/commit/90c371fc00df87ff5cf89616867ea7ba4348eef5

Comment 4 Jaroslav Škarvada 2018-04-05 13:55:24 UTC
This is regular bug and the patch is already upstream:
https://github.com/redhat-performance/tuned/commit/90c371fc00df87ff5cf89616867ea7ba4348eef5

Backport seems to be easy. From the developer point of view I do not see any problem with the z-stream.

Comment 7 jmencak 2018-06-12 13:49:48 UTC
Functionality verified with tuned-2.10.0-0.1.rc1.el7.noarch, works as expected. Thank you.

Comment 12 errata-xmlrpc 2018-10-30 10:50:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3172


Note You need to log in before you can comment on or make changes to this bug.