Bug 1564119 - need option 'run all-tests-in-regression' in reviews
Summary: need option 'run all-tests-in-regression' in reviews
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard: Process-Automation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-05 12:26 UTC by Amar Tumballi
Modified: 2018-10-05 06:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-05 06:20:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amar Tumballi 2018-04-05 12:26:11 UTC
# Description of problem:

Today, if a regression test fails regression due to some errors, by default, there is no way for the author to figure out if there are any more tests failing. Most of the times, they have to fix it and send another patch to figure out there is another one which fails. This process continues till all tests pass, or author has to send a patch with changing the 'run-tests.sh' to not fail on failure, and then again send another one disabling that.

The best way is to have an option to run the regression tests with '--exit-on-failures=no' option given a review command called 'run all-tests-in-regression'. 

Not critical about changing the command, but need a announcement on this.

# Additional info:

Search bugs with 'Process-Automation' in Whiteboard for the series of bugs.


Note You need to log in before you can comment on or make changes to this bug.