Bug 1564135 - Wrong data format in clipboard when copy-paste from Windows client to Windows guest
Summary: Wrong data format in clipboard when copy-paste from Windows client to Windows...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: mingw-virt-viewer
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Radek Duda
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-05 12:42 UTC by Radek Duda
Modified: 2020-05-18 11:04 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-18 11:04:19 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
top - copying from rhel client/ middle - copying from Win client/ bottom copying from within Win guest (deleted)
2018-04-05 12:42 UTC, Radek Duda
no flags Details
top - copying from rhel client/ middle - copying from Win client/ bottom copying from within Win guest (162.14 KB, image/png)
2018-04-05 12:43 UTC, Radek Duda
no flags Details
spice-debug log - paste picture to libreoffice from win7 client to win10 guest (124.41 KB, text/plain)
2018-04-05 14:11 UTC, Radek Duda
no flags Details

Description Radek Duda 2018-04-05 12:42:37 UTC
Description of problem:
I cannot paste image to Libreoffice in Windows guest when copying from Windows client. Data stored in clipboard differs when compared to those copied from RHEL client

Version-Release number of selected component (if applicable):
client: Win7
virt-viewer 2.0-240

guest: Win10/Win7
rhev-tools 4.2-4
vdagent 1.1.4.1005

How reproducible:
always

Steps to Reproduce:
1. Copy an image in Windows client (ctrl+c)
2. Paste this (ctrl+v) to Libreoffice in Windows guest VM

Actual results:
nothing is pasted

Expected results:
image is pasted to libreoffice

Additional info:
* Image is pasted to libreoffice when copying from RHEL 7.5 client to Windows guest.
* Image is also pasted when copying from Windows 7 guest to RHEL 7.5 guest.

To examine deeper this problem I used InsideClipboard utility (http://www.nirsoft.net/utils/inside_clipboard.html)

In attached screenshot one can see that clipboard data differs:
Top InsideClipboard utility window - copying image from RHEL7.5 client (feasible to paste into libreoffice)
Middle InsideClipboard utility window - copying image from Windows 7 client (impossible to paste into libreoffice)
Bottom InsideClipboard utility window - copying from within Win guest

from vdagent log after pasting:
...
1496::INFO::2018-04-05 14:32:23,474::handle_control_event::Control command 4
1496::INFO::2018-04-05 14:32:23,474::handle_clipboard_grab::grab type 3 format=8
1496::INFO::2018-04-05 14:32:29,958::handle_control_event::Control command 4

Comment 1 Radek Duda 2018-04-05 12:43:32 UTC
Created attachment 1417683 [details]
top - copying from rhel client/ middle - copying from Win client/ bottom copying from within Win guest

Comment 2 Victor Toso 2018-04-05 12:50:50 UTC
Could you please attach the client's debug too?

Comment 3 Radek Duda 2018-04-05 14:11:49 UTC
Created attachment 1417744 [details]
spice-debug log - paste picture to libreoffice from win7 client to win10 guest

Comment 4 Sandro Bonazzola 2019-01-28 09:40:05 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 6 Frediano Ziglio 2020-05-08 10:13:51 UTC
Got a pretty different result but probably I'm using different versions. On my VM (win7) copy from another VM (win10) virt-viewer is just storing the PNG image which is not that good for windows.

Comment 7 Frediano Ziglio 2020-05-11 11:54:25 UTC
I cannot reproduce with the combination of software mentioned in the description

Comment 8 Frediano Ziglio 2020-05-15 08:17:43 UTC
Checked all versions, it seems the problem is not present anymore. Reassigning to Radek

Comment 9 Radek Duda 2020-05-18 11:04:19 UTC
I can copy from Win10 client to Win10 guest libreoffice Drawing now. So closing this.


Note You need to log in before you can comment on or make changes to this bug.