Bug 1564142 - [abrt] rpl: main(): rpl:172:main:NameError: name 'raw_input' is not defined
Summary: [abrt] rpl: main(): rpl:172:main:NameError: name 'raw_input' is not defined
Keywords:
Status: CLOSED DUPLICATE of bug 1524082
Alias: None
Product: Fedora
Classification: Fedora
Component: rpl
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Jackson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:28896710b0735d135365861feef...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-05 13:10 UTC by Johannes Berg
Modified: 2018-05-10 22:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 22:15:50 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (803 bytes, text/plain)
2018-04-05 13:10 UTC, Johannes Berg
no flags Details
File: cgroup (355 bytes, text/plain)
2018-04-05 13:10 UTC, Johannes Berg
no flags Details
File: cpuinfo (1.40 KB, text/plain)
2018-04-05 13:10 UTC, Johannes Berg
no flags Details
File: environ (4.01 KB, text/plain)
2018-04-05 13:10 UTC, Johannes Berg
no flags Details
File: mountinfo (3.83 KB, text/plain)
2018-04-05 13:10 UTC, Johannes Berg
no flags Details
File: namespaces (129 bytes, text/plain)
2018-04-05 13:10 UTC, Johannes Berg
no flags Details
File: open_fds (244 bytes, text/plain)
2018-04-05 13:10 UTC, Johannes Berg
no flags Details

Description Johannes Berg 2018-04-05 13:10:41 UTC
Description of problem:
This happens when running "rpl" to delete something:

  rpl "asdf" ""

will do.

Version-Release number of selected component:
rpl-1.5.7-4.fc27

Additional info:
reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 -s /usr/bin/rpl asdf '' test
crash_function: main
exception_type: NameError
executable:     /usr/bin/rpl
kernel:         4.15.14-300.fc27.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
rpl:172:main:NameError: name 'raw_input' is not defined

Traceback (most recent call last):
  File "/usr/bin/rpl", line 314, in <module>
    main()
  File "/usr/bin/rpl", line 172, in main
    line = raw_input()
NameError: name 'raw_input' is not defined

Local variables in innermost frame:
file: 'test'
files: ['test']
new_str: ''
old_str: 'asdf'
args: ['asdf', '', 'test']
opts: <Values at 0x7fcd84e23780: {'suffixen': [], 'ignore_case': False, 'whole_words': False, 'do_backup': False, 'quiet': False, 'verbose': False, 'dry_run': False, 'recurse': False, 'escapes': False, 'prompt': False, 'force': False, 'keep_times': False, 'use_tmpdir': False, 'hidden_files': False}>
parser: <optparse.OptionParser object at 0x7fcd8d7182b0>
usage: 'usage: %prog [options] old_string new_string target_file(s)'

Comment 1 Johannes Berg 2018-04-05 13:10:46 UTC
Created attachment 1417701 [details]
File: backtrace

Comment 2 Johannes Berg 2018-04-05 13:10:48 UTC
Created attachment 1417702 [details]
File: cgroup

Comment 3 Johannes Berg 2018-04-05 13:10:49 UTC
Created attachment 1417703 [details]
File: cpuinfo

Comment 4 Johannes Berg 2018-04-05 13:10:51 UTC
Created attachment 1417704 [details]
File: environ

Comment 5 Johannes Berg 2018-04-05 13:10:52 UTC
Created attachment 1417705 [details]
File: mountinfo

Comment 6 Johannes Berg 2018-04-05 13:10:54 UTC
Created attachment 1417706 [details]
File: namespaces

Comment 7 Johannes Berg 2018-04-05 13:10:56 UTC
Created attachment 1417707 [details]
File: open_fds

Comment 8 Tim Jackson 2018-05-10 22:15:50 UTC

*** This bug has been marked as a duplicate of bug 1524082 ***


Note You need to log in before you can comment on or make changes to this bug.