Bug 1564151 - lsmcli volume-replicate-range is missing checking for src_starts, dst_starts and count
Summary: lsmcli volume-replicate-range is missing checking for src_starts, dst_starts ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tony Asleson
QA Contact: Jakub Krysl
URL:
Whiteboard:
: 1583753 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-05 13:32 UTC by Filip Suba
Modified: 2019-08-06 12:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 12:40:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2064 None None None 2019-08-06 12:40:29 UTC

Description Filip Suba 2018-04-05 13:32:52 UTC
Description of problem:
When you try to run volume-replicate-range with wrong type in src_starts or dst_starts or count it will return traceback.

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/lsm/lsmcli/cmdline.py", line 67, in cmd_line_wrapper
    cli.process(c)
  File "/usr/lib/python2.7/site-packages/lsm/lsmcli/cmdline.py", line 1809, in process
    self.args.func(self.args)
  File "/usr/lib/python2.7/site-packages/lsm/lsmcli/cmdline.py", line 1532, in volume_replicate_range
    long(counts[b])))
ValueError: invalid literal for long() with base 10: 'aaa'

Version-Release number of selected component (if applicable):
libstoragemgmt 1.6.1, 1.4.0-1

How reproducible:
100%

Steps to Reproduce:
1. lsmcli -u 'sim://' volume-create --name VOL_ID_00001 --size 1G --pool POOL_ID_00001
2. 1. lsmcli -u 'sim://' volume-create --name VOL_ID_00002 --size 1G --pool POOL_ID_00001
3. lsmcli -u "sim://" volume-replicate-range -f --src-vol=VOL_ID_00001 --dst-vol=VOL_ID_00002 --rep-type=COPY --src-start=0.0 --dst-start=0.0 --count=100.0 --src-start=aaa --dst-start=aaa --count=aaa
 
Actual results:
Returns traceback.

Expected results:
It should return some error message.

Additional info:

Comment 3 Tony Asleson 2018-12-07 19:14:14 UTC
*** Bug 1583753 has been marked as a duplicate of this bug. ***

Comment 5 Jakub Krysl 2019-01-28 16:33:23 UTC
libstoragemgmt-1.7.2-1.el7.x86_64

lsmcli -u "sim://" volume-replicate-range --count='100' --src-vol='VOL_ID_00001' --rep-type='CLONE' --dst-vol='VOL_ID_00002' --dst-start='WRONG' --src-start='0'         
usage: lsmcli volume-replicate-range [-h] [-v] [-u <URI>] [-P] [-H] [-t <SEP>]                                                                                                                                     
                                     [-e] [-f] [-w CHILD_WAIT] [--header] [-b]                                                                                                                                     
                                     [-s] --src-vol <SRC_VOL_ID> --dst-vol                                                                                                                                         
                                     <DST_VOL_ID> --rep-type <REP_TYPE>                                                                                                                                            
                                     --src-start <SRC_START_BLK> --dst-start                                                                                                                                       
                                     <DST_START_BLK> --count <BLK_COUNT>                                                                                                                                           
lsmcli volume-replicate-range: error: argument --dst-start: invalid: not a positive integer value 'WRONG'


lsmcli -u "sim://" volume-replicate-range --count='100' --src-vol='VOL_ID_00001' --rep-type='CLONE' --dst-vol='VOL_ID_00002' --dst-start='0' --src-start='WRONG'     
usage: lsmcli volume-replicate-range [-h] [-v] [-u <URI>] [-P] [-H] [-t <SEP>]                                                                                                                                     
                                     [-e] [-f] [-w CHILD_WAIT] [--header] [-b]                                                                                                                                     
                                     [-s] --src-vol <SRC_VOL_ID> --dst-vol                                                                                                                                         
                                     <DST_VOL_ID> --rep-type <REP_TYPE>                                                                                                                                            
                                     --src-start <SRC_START_BLK> --dst-start                                                                                                                                       
                                     <DST_START_BLK> --count <BLK_COUNT>                                                                                                                                           
lsmcli volume-replicate-range: error: argument --src-start: invalid: not a positive integer value 'WRONG'


lsmcli -u "sim://" volume-replicate-range --count='WRONG' --src-vol='VOL_ID_00001' --rep-type='CLONE' --dst-vol='VOL_ID_00002' --dst-start='0' --src-start='0'       
usage: lsmcli volume-replicate-range [-h] [-v] [-u <URI>] [-P] [-H] [-t <SEP>]                                                                                                                                     
                                     [-e] [-f] [-w CHILD_WAIT] [--header] [-b]                                                                                                                                     
                                     [-s] --src-vol <SRC_VOL_ID> --dst-vol                                                                                                                         
                                     <DST_VOL_ID> --rep-type <REP_TYPE>                                                                                                                                            
                                     --src-start <SRC_START_BLK> --dst-start                                                                                                                                       
                                     <DST_START_BLK> --count <BLK_COUNT>                                                                                                                                          
lsmcli volume-replicate-range: error: argument --count: invalid: not a positive integer value 'WRONG'

Comment 7 errata-xmlrpc 2019-08-06 12:40:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2064


Note You need to log in before you can comment on or make changes to this bug.