Bug 1564154 - Openshift container retirement [NEEDINFO]
Summary: Openshift container retirement
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.0
Hardware: All
OS: All
medium
low
Target Milestone: GA
: 5.10.0
Assignee: Lucy Fu
QA Contact: juwatts
URL:
Whiteboard:
Depends On:
Blocks: 1578398
TreeView+ depends on / blocked
 
Reported: 2018-04-05 13:37 UTC by Cyril Coupel
Modified: 2019-02-11 14:03 UTC (History)
8 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1578398 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:03:48 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:
lufu: needinfo? (ccoupel)


Attachments (Terms of Use)

Description Cyril Coupel 2018-04-05 13:37:58 UTC
Description of problem:
As container retirement is not (yet?) supported, the retirement button is still displayed in the UI (as well as in the Self Service UI), which ends with a fatal error method not implemented.

Version-Release number of selected component (if applicable):
5.9.0.22

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
run the container retirement or remove the life cycle buttons

Additional info:

Comment 2 Greg McCullough 2018-04-05 15:54:48 UTC
Lucy - Check with Bill, we fixed a similar issue with Ansible objects and should apply the same logic here.

We need to keep the LifeCycle buttons as the user may also want to support retirement through custom automation.  And we still want to support retiring the service (or service bundle) that may include this type of object.

Comment 6 CFME Bot 2018-04-13 15:41:05 UTC
New commit detected on ManageIQ/manageiq/master:

https://github.com/ManageIQ/manageiq/commit/1eb5531b63a12302b3fc2da7534b5ef2bf56e67e
commit 1eb5531b63a12302b3fc2da7534b5ef2bf56e67e
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Fri Apr 13 10:49:46 2018 -0400
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Fri Apr 13 10:49:46 2018 -0400

    Add method retire_now to container OrchestrationStack.

    So the container service may be retired.

    https://bugzilla.redhat.com/show_bug.cgi?id=1564154

 app/models/manageiq/providers/container_manager/orchestration_stack.rb | 5 +
 spec/factories/orchestration_stack.rb | 2 +
 spec/models/manageiq/providers/container_manager/orchestration_stack_spec.rb | 10 +
 3 files changed, 17 insertions(+)

Comment 8 juwatts 2018-11-02 19:53:25 UTC
Verified in 5.10.0.22.20181030184024_26956a0.

Creation of the Catalog Item fails due to https://bugzilla.redhat.com/show_bug.cgi?id=1645676 but this does not block the Retirement of the item


Note You need to log in before you can comment on or make changes to this bug.