Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1564177 - Changing primary Interface of host in WebGUI leads to error
Summary: Changing primary Interface of host in WebGUI leads to error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Networking
Version: 6.3.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-05 14:49 UTC by Daniel Kuß
Modified: 2019-06-03 12:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-03 12:05:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Daniel Kuß 2018-04-05 14:49:16 UTC
Description of problem:

If the primary Interface of a host managed by Satellite is changed within the WebGUI, an error occurs that the hostname is already taken.
A manual deletion of the hostname within the old primary Interface doesn't solve this.

Version-Release number of selected component (if applicable):
 Satellite 6.3.0

How reproducible:
Changing the primary Interface on any Node managed by the Satellite

Steps to Reproduce:
1. Open the WebGUI
2. Go to All hosts
3. Select Any host
4. Change the Primary Interface
5. Click Submit

Actual results:
An error occurs, stating that the hostname is already taken

Expected results:
Changing the Primary Interface


Additional info:
The Problem can be solved by pressing submit after each of the Following steps:
1. Change the hostname -> submit
2. Set new primary Interface -> submit
3. Unset the name at the old primary Interface -> submit
4. Change the hostname to the old one -> submit

Comment 2 Marek Hulan 2018-04-06 06:50:09 UTC
Thanks for detailed report and documenting the workaround.

I tried to reproduce the issue and realized that this only happens if your new primary interface is in the same domain (or didn't have the domain assigned yet). 

In that case, host FQDN is supposed to remain the same, but the interface primary flag should move. I wonder what is the use case for this? Note that primary flag determines the host FQDN, which is then used e.g. when puppet cert is generated. Why do you want to change the primary interface?

When I reassign the primary flag to interface with another domain, it works just fine.

Comment 5 Daniel Kuß 2018-04-06 07:02:31 UTC
Hello,

we have three Network Interfaces within our Cluster.

One is for a Omnipath Interconnect
One for a iLO Network
One for a administrativ Network

Within our configuration we have the Primary search Domain within the /etc/resolv.conf

Due to our company dns decission, we only have one Domain for all three used Networks.

So our Name scheme is like this:
hostname -> admin network
ilohostname -> iLO Network
opahostname -> Omnipath Network

The satellite now assigned the Primary Interface to the iLO Network (which is the slowest) but used the Name from the Admin Network.

This may be a very Special Situation, but still is very troublesome for us.

Comment 6 Bryan Kearney 2019-05-02 19:06:51 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 7 Bryan Kearney 2019-06-03 12:05:36 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.