Bug 1564182 - [3.6] Upgrade playbook fails with TemplateRuntimeError: no test named 'equalto'
Summary: [3.6] Upgrade playbook fails with TemplateRuntimeError: no test named 'equalto'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.6.z
Assignee: Vadim Rutkovsky
QA Contact: Mike Fiedler
URL:
Whiteboard:
Depends On: 1564180
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-05 14:59 UTC by Scott Dodson
Modified: 2018-04-11 04:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1564180
Environment:
Last Closed: 2018-04-09 14:33:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1106 normal SHIPPED_LIVE OpenShift Container Platform 3.6 and 3.5 bug fix update 2018-04-16 05:20:11 UTC

Description Scott Dodson 2018-04-05 14:59:57 UTC
+++ This bug was initially created as a clone of Bug #1564180 +++

Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
>>> openshift-ansible-3.7.42-1.git.0.427f18c.el7.noarch
rpm -q ansible
>>> ansible-2.4.1.0-1.el7.noarch
ansible --version
>>> ansible 2.4.1.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, May  3 2017, 07:55:04) [GCC 4.8.5 20150623 (Red Hat 4.8.5-14)]

How reproducible:

Always

Steps to Reproduce:
1. Upgrade the rpms to v3.7.42
2. ansible-playbook -i <ansible_hosts_file> /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_7/upgrade.yml

Actual results:

TASK [Upgrade master packages] ******************************************************************************************************************************************************
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: TemplateRuntimeError: no test named 'equalto'
fatal: [master.ocp.io]: FAILED! => {"failed": true, "msg": "Unexpected failure during module execution.", "stdout": ""}
	to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_7/upgrade.retry


Expected results:

Upgrade is successful

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

--- Additional comment from Scott Dodson on 2018-04-05 10:59:30 EDT ---

Fixed in https://github.com/openshift/openshift-ansible/pull/7747

Comment 2 Scott Dodson 2018-04-05 16:08:23 UTC
Reproducer:

1) Install 3.6
2) Run control plane and node upgrade playbooks from latest 3.6 shipped versions, this should fail with the error above
3) Update your playbooks to the package referenced in comment 3, re-run, this should work

Comment 3 Scott Dodson 2018-04-05 16:17:36 UTC
Upon further review it looks as if this hasn't actually shipped.

The problem was introduced in openshift-ansible-3.6.173.0.111-1 so we just need to make sure that we produce a new build before shipping the 3.6 errata.

Comment 4 Mike Fiedler 2018-04-05 18:02:10 UTC
Reproduced the issue with: openshift-ansible-3.6.173.0.112-1.git.0.b920505.el7.noarch.rpm

Verified upgrade runs successfully with:  openshift-ansible-3.6.173.0.112-1.git.2.17a27d3.el7.noarch


Note You need to log in before you can comment on or make changes to this bug.