Bug 1564250 - [RFE] CFME 5.9.4 - pre/post playbook support
Summary: [RFE] CFME 5.9.4 - pre/post playbook support
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: GA
: 5.10.0
Assignee: Marco Berube
QA Contact: Kedar Kulkarni
Steve Bream
URL:
Whiteboard: v2v
: 1599999 1607727 1607730 (view as bug list)
Depends On: 1609908 1613935
Blocks: 1564236 1599999 1608420
TreeView+ depends on / blocked
 
Reported: 2018-04-05 19:22 UTC by Brett Thurber
Modified: 2019-02-11 14:05 UTC (History)
14 users (show)

Fixed In Version: 5.10.0.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1608420 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:05:25 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Brett Thurber 2018-04-05 19:22:10 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dave Johnson 2018-04-05 19:45:26 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Dave Johnson 2018-04-05 20:04:11 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 8 Greg McCullough 2018-07-11 17:04:34 UTC
*** Bug 1599999 has been marked as a duplicate of this bug. ***

Comment 9 Greg McCullough 2018-07-11 17:08:27 UTC
RFE Description from dup bug 1599999

Add support to call playbooks in pre and post migration phases. The implementation should be generic to allow calling playbooks for other hooks. The backend provides methods to get the service template associated to pre and post hooks. The implementation should also updates the Ansible Tower job status in the task options hash, so that the UI can display it and also collect the job output.


PRs
https://github.com/ManageIQ/manageiq-content/pull/355
https://github.com/ManageIQ/miq_v2v_ui_plugin/pull/467

Comment 11 Fabien Dupont 2018-07-24 12:51:37 UTC
*** Bug 1607727 has been marked as a duplicate of this bug. ***

Comment 12 Fabien Dupont 2018-07-24 12:52:05 UTC
*** Bug 1607730 has been marked as a duplicate of this bug. ***

Comment 15 Fabien Dupont 2018-07-26 06:20:27 UTC
Extra UI PR. Fixes #399 and refactors #467.
https://github.com/ManageIQ/miq_v2v_ui_plugin/pull/491

Comment 16 Fabien Dupont 2018-07-28 22:13:23 UTC
Extra PR - Allow running playbook against powered off VM:
https://github.com/ManageIQ/manageiq-content/pull/380

Comment 17 Kedar Kulkarni 2018-07-30 19:20:55 UTC
Blocked by BZ ID :1609908

Comment 18 Satoe Imaishi 2018-07-30 21:53:50 UTC
Brett, this is for cfme-5.10 and 5.9.z clone exists (bug #1608420). Setting Target Release back to 5.10.0.

Also changing status as extra PR was added, which is not in the build yet.

Comment 20 Kedar Kulkarni 2018-08-23 17:44:27 UTC
With CFME 5.10.0.11 I was able to execute pre and post playbooks in migration plan.Post migration playbook execute against localhost falsely, but we have a bug to track that at https://bugzilla.redhat.com/show_bug.cgi?id=1619461


Note You need to log in before you can comment on or make changes to this bug.