Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1564382 - The /usr/libexec/openldap/convert-config.sh doesn't take SLAPD_OPTIONS arguments set in /etc/sysconfig/slapd
Summary: The /usr/libexec/openldap/convert-config.sh doesn't take SLAPD_OPTIONS argume...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openldap
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matus Honek
QA Contact: Jiri Jaburek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 06:48 UTC by Ming Davies
Modified: 2021-06-10 15:41 UTC (History)
3 users (show)

Fixed In Version: openldap-2.4.44-17.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 07:47:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3024 0 None None None 2018-10-30 07:48:24 UTC

Description Ming Davies 2018-04-06 06:48:06 UTC
Description of problem:
The /usr/libexec/openldap/convert-config.sh doesn't take SLAPD_OPTIONS arguments set in the /etc/sysconfig/slapd file.

The load_sysconfig function in the /usr/libexec/openldap/functions calls the parse_config_options in /usr/libexec/openldap/functions with SLAPD_OPTIONS as arguments:

function load_sysconfig()
{
        [ -r "$SLAPD_SYSCONFIG_FILE" ] || return

        . "$SLAPD_SYSCONFIG_FILE"
        [ -n "$SLAPD_OPTIONS" ] && parse_config_options $SLAPD_OPTIONS
}


The parse_config_options uses getopts to parse these arguments and the valid options are:

function parse_config_options()
{
        user=
        config_file=
        config_dir=
        while getopts :u:f:F: opt; do
                case "$opt" in
                u)
                        user="$OPTARG"
                        ;;
                f)
                        config_file="$OPTARG"
                        ;;
                F)
                        config_dir="$OPTARG"
                        ;;
                esac
        done
...
}


Version-Release number of selected component (if applicable):
openldap-servers-2.4.40-13.el7

How reproducible:
I can easily reproduce the issue on openldap-servers-2.4.44-5.el7.x86_64.


Steps to Reproduce:
1. Specify the SLAPD_OPTIONS in the /etc/sysconfig/slapd file:
  # grep SLAPD_OPTIONS /etc/sysconfig/slapd
SLAPD_OPTIONS="-s 384"
2. Attempt to run the script:
 # /usr/libexec/openldap/convert-config.sh -f /var/openldap/legacy/slapd.conf
usage: convert-config.sh [-f config-file] [-F config-dir]

3.

Actual results:


Expected results:


Additional info:
The customer's workaround is to add "unset OPTIND" in the function parse_config_options in the /usr/libexec/openldap/functions file, i.e

function parse_config_options()
{
       ...
                esac
        done

        unset OPTIND   <<<<<<<<<<<

        if [ -n "$user" ]; then
                SLAPD_USER="$user"
}

Comment 2 Matus Honek 2018-04-06 11:09:58 UTC
The workaround actually seems to be the correct way to fix this as it is doing a clean up as soon as possible after getopts usage. Setting the bug's status to POST as we seem to have a fix, then.

Comment 8 errata-xmlrpc 2018-10-30 07:47:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3024


Note You need to log in before you can comment on or make changes to this bug.