Bug 1564434 - python crashes in nss shutdown
Summary: python crashes in nss shutdown
Keywords:
Status: CLOSED DUPLICATE of bug 1564145
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.7-Alt
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 09:36 UTC by German Parente
Modified: 2018-04-06 15:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-06 14:59:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description German Parente 2018-04-06 09:36:05 UTC
Description of problem:

please, feel free to change the component to nss if needed.

In some scenario, this command makes python crash:

ipa-replica-manage list
Directory Manager password:

master1 : master
master2 : master
Segmentation fault (core dumped)

I get the coredump and this is the stacktrace:


{   "signal": 11
,   "executable": "/usr/bin/python2.7"
,   "stacktrace":
      [ {   "crash_thread": true
        ,   "frames":
              [ {   "address": 139644333435952
                ,   "build_id": "249e20cc7e8eaa757a14ecdab432d4bed513c0c4"
                ,   "build_id_offset": 39984
                ,   "file_name": "/usr/lib64/libpthread-2.17.so"
                }
              , {   "address": 139644188073545
                ,   "build_id": "6ab0c0852005e296fac8b881f62827127be39bbe"
                ,   "build_id_offset": 142921
                ,   "function_name": "PR_Lock"
                ,   "file_name": "/usr/lib64/libnspr4.so"
                }
              , {   "address": 139644197027945
                ,   "build_id": "10eddc308d132d8e3835dce217c23936b7af5a5c"
                ,   "build_id_offset": 233577
                ,   "function_name": "secmodLockMutext"
                ,   "file_name": "/usr/lib64/libnss3.so"
                }
              , {   "address": 139643902305622
                ,   "build_id": "f6db71875d04187e0436b36d41ffa51e26dd5f2d"
                ,   "build_id_offset": 353622
                ,   "function_name": "Mutex::lock()"
                ,   "file_name": "/usr/lib64/pkcs11/libsofthsm2.so"
                }
              , {   "address": 139643902425085
                ,   "build_id": "f6db71875d04187e0436b36d41ffa51e26dd5f2d"
                ,   "build_id_offset": 473085
                ,   "function_name": "HandleManager::allSessionsClosed(unsigned long)"
                ,   "file_name": "/usr/lib64/pkcs11/libsofthsm2.so"
                }
              , {   "address": 139643902158205
                ,   "build_id": "f6db71875d04187e0436b36d41ffa51e26dd5f2d"
                ,   "build_id_offset": 206205
                ,   "function_name": "SoftHSM::C_CloseAllSessions(unsigned long)"
                ,   "file_name": "/usr/lib64/pkcs11/libsofthsm2.so"
                }
              , {   "address": 139643902036788
                ,   "build_id": "f6db71875d04187e0436b36d41ffa51e26dd5f2d"
                ,   "build_id_offset": 84788
                ,   "function_name": "C_CloseAllSessions"
                ,   "file_name": "/usr/lib64/pkcs11/libsofthsm2.so"
                }
              , {   "address": 139644197146632
                ,   "build_id": "10eddc308d132d8e3835dce217c23936b7af5a5c"
                ,   "build_id_offset": 352264
                ,   "function_name": "PK11_DestroySlot"
                ,   "file_name": "/usr/lib64/libnss3.so"
                }
              , {   "address": 139644197161993
                ,   "build_id": "10eddc308d132d8e3835dce217c23936b7af5a5c"
                ,   "build_id_offset": 367625
                ,   "function_name": "SECMOD_DestroyModule"
                ,   "file_name": "/usr/lib64/libnss3.so"
                }
              , {   "address": 139644197162842
                ,   "build_id": "10eddc308d132d8e3835dce217c23936b7af5a5c"
                ,   "build_id_offset": 368474
                ,   "function_name": "SECMOD_DestroyModuleListElement"
                ,   "file_name": "/usr/lib64/libnss3.so"
                }
              , {   "address": 139644197163989
                ,   "build_id": "10eddc308d132d8e3835dce217c23936b7af5a5c"
                ,   "build_id_offset": 369621
                ,   "function_name": "SECMOD_DestroyModuleList"
                ,   "file_name": "/usr/lib64/libnss3.so"
                }
              , {   "address": 139644197164121
                ,   "build_id": "10eddc308d132d8e3835dce217c23936b7af5a5c"
                ,   "build_id_offset": 369753
                ,   "function_name": "SECMOD_Shutdown"
                ,   "file_name": "/usr/lib64/libnss3.so"
                }
              , {   "address": 139644196903849
                ,   "build_id": "10eddc308d132d8e3835dce217c23936b7af5a5c"
                ,   "build_id_offset": 109481
                ,   "function_name": "nss_Shutdown"
                ,   "file_name": "/usr/lib64/libnss3.so"
                }
              , {   "address": 139644196904419
                ,   "build_id": "10eddc308d132d8e3835dce217c23936b7af5a5c"
                ,   "build_id_offset": 110051
                ,   "function_name": "NSS_ShutdownContext"
                ,   "file_name": "/usr/lib64/libnss3.so"
                }
              , {   "address": 139644211617906
                ,   "build_id": "29a84b868d4888a562f6ac59f75e3ae02b299661"
                ,   "build_id_offset": 262258
                ,   "function_name": "tlsm_ctx_free"
                ,   "file_name": "/usr/lib64/libldap_r-2.4.so.2.10.7"
                }
              , {   "address": 139644211601445
                ,   "build_id": "29a84b868d4888a562f6ac59f75e3ae02b299661"
                ,   "build_id_offset": 245797
                ,   "function_name": "ldap_int_tls_destroy"
                ,   "file_name": "/usr/lib64/libldap_r-2.4.so.2.10.7"
                }
              , {   "address": 139644339653434
                ,   "build_id": "22fa66da7d14c88bf36c69454a357e5f1defae4e"
                ,   "build_id_offset": 64314
                ,   "function_name": "_dl_fini"
                ,   "file_name": "/usr/lib64/ld-2.17.so"
                }
              , {   "address": 139644322306665
                ,   "build_id": "5861cfac90a2037fb2f649fdaf1b679b2a25f1e7"
                ,   "build_id_offset": 232041
                ,   "function_name": "__run_exit_handlers"
                ,   "file_name": "/usr/lib64/libc-2.17.so"
                }
              , {   "address": 139644322306741
                ,   "build_id": "5861cfac90a2037fb2f649fdaf1b679b2a25f1e7"
                ,   "build_id_offset": 232117
                ,   "file_name": "/usr/lib64/libc-2.17.so"
                } ]
        } ]
}



Version-Release number of selected component (if applicable):


ipa-server-4.5.0-22.el7_4.x86_64                            
ipa-server-common-4.5.0-22.el7_4.noarch      

nss-3.28.4-15.el7_4.x86_64                                  Tue Dec  5 16:22:58 2017
nss-pem-1.0.3-4.el7.x86_64                                  Thu Aug 17 13:09:42 2017
nss-softokn-3.28.3-8.el7_4.x86_64                           Tue Dec  5 16:22:57 2017
nss-softokn-freebl-3.28.3-8.el7_4.i686                      Tue Dec  5 16:28:51 2017
nss-softokn-freebl-3.28.3-8.el7_4.x86_64                    Tue Dec  5 16:22:06 2017
nss-sysinit-3.28.4-15.el7_4.x86_64                          Tue Dec  5 16:22:57 2017
nss-tools-3.28.4-15.el7_4.x86_64                            Tue Dec  5 16:23:01 2017
nss-util-3.28.4-3.el7.x86_64

Comment 3 Rob Crittenden 2018-04-06 14:35:23 UTC
Looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1564145

Comment 4 German Parente 2018-04-06 14:59:58 UTC

*** This bug has been marked as a duplicate of bug 1564145 ***


Note You need to log in before you can comment on or make changes to this bug.