Bug 1564500 - Review Request: pipenv - The higher level Python packaging tool
Summary: Review Request: pipenv - The higher level Python packaging tool
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 13:15 UTC by Michal Cyprian
Modified: 2018-06-04 13:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-04 13:16:41 UTC
Type: ---
mhroncok: fedora-review+


Attachments (Terms of Use)

Description Michal Cyprian 2018-04-06 13:15:28 UTC
Spec URL: https://mcyprian.fedorapeople.org/pipenv.spec
SRPM URL: https://mcyprian.fedorapeople.org/pipenv-11.9.0-1.fc27.src.rpm
Description:
The officially recommended Python packaging tool that aims to bring
the best of all packaging worlds (bundler, composer, npm, cargo, yarn, etc.)
to the Python world. Windows is a first–class citizen, in our world.
It automatically creates and manages a virtualenv for your projects, 
as well as adds/removes packages from your Pipfile as you install/uninstall
packages. It also generates the ever–important Pipfile.lock, 
which is used to produce deterministic builds.

Fedora Account System Username: mcyprian
Successful Copr build: https://copr.fedorainfracloud.org/coprs/mcyprian/pipenv/builds/

Comment 1 Miro Hrončok 2018-04-06 13:35:03 UTC
Michal, could you please add a small explanation (comment) to each patch?

Comment 2 Michal Cyprian 2018-04-09 08:55:19 UTC
Done.

Comment 3 Miro Hrončok 2018-04-09 10:39:52 UTC
For the firts set of the bundled packages, please add a comment about them not being in Fedora yet (probably a TODO comment). In the meantime, you can send the list to python-devel as packages that need to be packaged eventually (for people who want to package something). Don't forget to mention we only need python 3 versions. Later, once this gets approved, we can open a tracking bug for them.

I'm building the package now and will do a formal review soon.

Comment 4 Miro Hrončok 2018-04-09 11:28:06 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated


Issues:
=======
- (blocking FE-Legal) The licensing of bundled libs is messy, unclear and probably violates dozens of licenses.
  More details below.

- Binary eggs must be removed in %prep
  Note: Binary egg files not removed in %prep:
  ./tests/pypi/odfpy/odfpy-1.3.6-py2.7.egg
  See:
  http://fedoraproject.org/wiki/Packaging:Python#Packaging_eggs_and_setuptools_concerns
  I assume this is for testing only, so please double check and confirm that.

- The unvendor patch is huge, it basically contains all the code of the unvendored libraries (64k lines). Could ypou please split it into:
  - small necessary patch that fixes the imports.
  - call to rm -rf in the specfile?

- Please remove "Windows is a first–class citizen, in our world" from the description, it is useless for Fedora.

- Recheck the Source URL.

- Fix the version in changelog.

- Fix the shabngs problems (chmod -x what you can, pathfix the rest).

- Fix wrong-file-end-of-line-encoding. Consider not shuiping docs sources.

- Add versions to the bundled provides if possible.

- Make sure to track all bundles (e.g. pip is missing and vendored packages in vendored packages are missing).

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[!]: License field in the package spec file matches the actual license.
     Now this is a huge problem. The license files of bundled packages are removed
     and replaced with https://github.com/pypa/pipenv/blob/master/NOTICES
     
     There are plany of licenses unknown and pleny have hears that suggest
     strong copyleft licenses such as GPL. Shipping those deps vendoret the package
     is probably supposed to by GPL as well (and upstream needs to ship it as GPL if they bundle GPL code).
     Anyway, talk to our legal@ first. This is probably a NO GO.
     
     Side note: there are vendor stuff in the vendor stuff, so thetre is even:
     pipenv -> notpip -> requests -> chardet
     pipenv -> pip9 -> requests -> chardet
     etc.
     
     You don't mention those anywhere.
[x]: License file installed when any subpackage combination is installed.
[!]: Package contains no bundled libraries without FPC exception.
     Contians plenty. That's OK, however make sure to track them all (see the side note in license section above).
[!]: Changelog in prescribed format. (Bad version!)
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[ ]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage.
[?]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel

===== SHOULD items =====

Generic:
[!]: Sources can be downloaded from URI in Source: tag
     Note: Could not download Source0:
     https://github.com/pypa/pipenv/archive/11.9.0/pipenv-11.9.0.tar.gz
     See: http://fedoraproject.org/wiki/Packaging:Guidelines#Tags
     (I suppose somehting has chnaged at GitHub's?)
[!]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[ ]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[-]: SourceX tarball generation or download is documented.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[?]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[?]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: pipenv-11.9.0-1.fc29.noarch.rpm
          pipenv-doc-11.9.0-1.fc29.noarch.rpm
          pipenv-11.9.0-1.fc29.src.rpm
pipenv.noarch: W: spelling-error %description -l en_US bundler -> bundle, blunder, bundles
pipenv.noarch: W: spelling-error %description -l en_US npm -> pm, rpm, ppm
pipenv.noarch: W: spelling-error %description -l en_US virtualenv -> virtual
pipenv.noarch: W: incoherent-version-in-changelog 9.0.1-1 ['11.9.0-1.fc29', '11.9.0-1']
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/patched/notpip/__init__.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/patched/notpip/__init__.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/appdirs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/appdirs.py 644 /usr/bin/env python
pipenv.noarch: W: pem-certificate /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/cacert.pem
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/certs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/certs.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/packages/chardet/chardetect.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/packages/chardet/chardetect.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/click_completion.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/click_completion.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/__init__.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/__init__.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/appdirs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/appdirs.py 644 /usr/bin/env python
pipenv.noarch: W: pem-certificate /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/cacert.pem
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/certs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/certs.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/packages/chardet/chardetect.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/packages/chardet/chardetect.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pipreqs/pipreqs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pipreqs/pipreqs.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/shutilwhich/__init__.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/shutilwhich/__init__.py 644 /usr/bin/env python
pipenv.noarch: W: no-manual-page-for-binary pewtwo
pipenv.noarch: W: no-manual-page-for-binary pipenv
pipenv.noarch: W: no-manual-page-for-binary pipenv-resolver
pipenv-doc.noarch: W: wrong-file-end-of-line-encoding /usr/share/doc/pipenv-doc/html/_sources/diagnose.rst.txt
pipenv.src: W: spelling-error %description -l en_US bundler -> bundle, blunder, bundles
pipenv.src: W: spelling-error %description -l en_US npm -> pm, rpm, ppm
pipenv.src: W: spelling-error %description -l en_US virtualenv -> virtual
pipenv.src:87: W: unversioned-explicit-provides bundled(python3dist(blindspin))
pipenv.src:88: W: unversioned-explicit-provides bundled(python3dist(click_completion))
pipenv.src:89: W: unversioned-explicit-provides bundled(python3dist(click_didyoumean))
pipenv.src:90: W: unversioned-explicit-provides bundled(python3dist(delegator))
pipenv.src:91: W: unversioned-explicit-provides bundled(python3dist(first))
pipenv.src:92: W: unversioned-explicit-provides bundled(python3dist(pipdeptree))
pipenv.src:93: W: unversioned-explicit-provides bundled(python3dist(pipreqs))
pipenv.src:94: W: unversioned-explicit-provides bundled(python3dist(requirements))
pipenv.src:95: W: unversioned-explicit-provides bundled(python3dist(shutilwhich))
pipenv.src:96: W: unversioned-explicit-provides bundled(python3dist(strict_rfc3339))
pipenv.src:97: W: unversioned-explicit-provides bundled(python3dist(timestamp))
pipenv.src:98: W: unversioned-explicit-provides bundled(python3dist(yarg))
pipenv.src:101: W: unversioned-explicit-provides bundled(python3dist(pew))
pipenv.src:102: W: unversioned-explicit-provides bundled(python3dist(contoml))
pipenv.src:103: W: unversioned-explicit-provides bundled(python3dist(crayons))
pipenv.src:104: W: unversioned-explicit-provides bundled(python3dist(dotenv))
pipenv.src:105: W: unversioned-explicit-provides bundled(python3dist(notpip))
pipenv.src:106: W: unversioned-explicit-provides bundled(python3dist(pipfile))
pipenv.src:107: W: unversioned-explicit-provides bundled(python3dist(piptools))
pipenv.src:108: W: unversioned-explicit-provides bundled(python3dist(prettytoml))
pipenv.src: W: invalid-url Source0: https://github.com/pypa/pipenv/archive/11.9.0/pipenv-11.9.0.tar.gz HTTP Error 404: Not Found
3 packages and 0 specfiles checked; 22 errors, 34 warnings.




Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
pipenv-doc.noarch: W: invalid-url URL: https://github.com/pypa/pipenv <urlopen error [Errno -2] Name or service not known>
pipenv-doc.noarch: W: wrong-file-end-of-line-encoding /usr/share/doc/pipenv-doc/html/_sources/diagnose.rst.txt
pipenv.noarch: W: spelling-error %description -l en_US bundler -> bundle, blunder, bundles
pipenv.noarch: W: spelling-error %description -l en_US npm -> pm, rpm, ppm
pipenv.noarch: W: spelling-error %description -l en_US virtualenv -> virtual
pipenv.noarch: W: incoherent-version-in-changelog 9.0.1-1 ['11.9.0-1.fc29', '11.9.0-1']
pipenv.noarch: W: invalid-url URL: https://github.com/pypa/pipenv <urlopen error [Errno -2] Name or service not known>
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/patched/notpip/__init__.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/patched/notpip/__init__.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/appdirs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/appdirs.py 644 /usr/bin/env python
pipenv.noarch: W: pem-certificate /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/cacert.pem
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/certs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/certs.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/packages/chardet/chardetect.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/patched/notpip/_vendor/requests/packages/chardet/chardetect.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/click_completion.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/click_completion.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/__init__.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/__init__.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/appdirs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/appdirs.py 644 /usr/bin/env python
pipenv.noarch: W: pem-certificate /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/cacert.pem
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/certs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/certs.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/packages/chardet/chardetect.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pip9/_vendor/requests/packages/chardet/chardetect.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/pipreqs/pipreqs.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/pipreqs/pipreqs.py 644 /usr/bin/env python
pipenv.noarch: E: wrong-script-interpreter /usr/lib/python3.6/site-packages/pipenv/vendor/shutilwhich/__init__.py /usr/bin/env python
pipenv.noarch: E: non-executable-script /usr/lib/python3.6/site-packages/pipenv/vendor/shutilwhich/__init__.py 644 /usr/bin/env python
pipenv.noarch: W: no-manual-page-for-binary pewtwo
pipenv.noarch: W: no-manual-page-for-binary pipenv
pipenv.noarch: W: no-manual-page-for-binary pipenv-resolver
2 packages and 0 specfiles checked; 22 errors, 12 warnings.



Requires
--------
pipenv-doc (rpmlib, GLIBC filtered):

pipenv (rpmlib, GLIBC filtered):
    /usr/bin/python3
    python(abi)
    python3-Levenshtein
    python3dist(appdirs)
    python3dist(certifi)
    python3dist(click)
    python3dist(colorama)
    python3dist(docopt)
    python3dist(flake8)
    python3dist(iso8601)
    python3dist(jinja2)
    python3dist(markupsafe)
    python3dist(parse)
    python3dist(pathlib2)
    python3dist(pexpect)
    python3dist(pip)
    python3dist(psutil)
    python3dist(ptyprocess)
    python3dist(pytoml)
    python3dist(requests)
    python3dist(semver)
    python3dist(setuptools)
    python3dist(six)
    python3dist(urllib3)
    python3dist(virtualenv)
    python3dist(virtualenv-clone)



Provides
--------
pipenv-doc:
    pipenv-doc

pipenv:
    bundled(python3dist(blindspin))
    bundled(python3dist(click_completion))
    bundled(python3dist(click_didyoumean))
    bundled(python3dist(contoml))
    bundled(python3dist(crayons))
    bundled(python3dist(delegator))
    bundled(python3dist(dotenv))
    bundled(python3dist(first))
    bundled(python3dist(notpip))
    bundled(python3dist(pew))
    bundled(python3dist(pipdeptree))
    bundled(python3dist(pipfile))
    bundled(python3dist(pipreqs))
    bundled(python3dist(piptools))
    bundled(python3dist(prettytoml))
    bundled(python3dist(requirements))
    bundled(python3dist(shutilwhich))
    bundled(python3dist(strict_rfc3339))
    bundled(python3dist(timestamp))
    bundled(python3dist(yarg))
    pipenv
    python3.6dist(pipenv)
    python3dist(pipenv)

Comment 5 Miro Hrončok 2018-04-12 11:58:11 UTC
Upstream issue https://github.com/pypa/pipenv/issues/1961

Comment 6 Michal Cyprian 2018-05-14 19:06:29 UTC
The new version 11.10.4 containing the legal issue fixes was released, so I rebased the spec file and updated all the patches.

The ./tests/pypi/odfpy/odfpy-1.3.6-py2.7.egg file is there only for testing
purpose.

I've tried to fix/workaround all the issues that were pointed out. The updated files are here:
Spec URL: https://mcyprian.fedorapeople.org/pipenv.spec
SRPM URL: https://mcyprian.fedorapeople.org/pipenv-11.10.4-1.fc28.src.rpm

Comment 7 Miro Hrončok 2018-05-14 19:30:43 UTC
The License tag needs to cover everything bundled unfortunately.

Also, I think we need to mark all LICENSE files with %license, hopefully it supports absolute paths as does %doc.

Comment 8 Michal Cyprian 2018-05-15 15:40:36 UTC
Added, I tried to follow the Licensing Guidelines https://fedoraproject.org/wiki/Packaging:LicensingGuidelines?rd=Packaging/LicensingGuideline

Comment 9 Miro Hrončok 2018-05-15 17:17:31 UTC
Was %license with absolute paths not working? I think it might be better than this.

Comment 10 Tom "spot" Callaway 2018-05-15 21:48:03 UTC
%license should support absolute paths just like %doc.

Comment 11 Michal Cyprian 2018-05-16 09:53:23 UTC
Is this absolute paths approach documented somewhere? I cannot find any example how should it looks like.

Comment 13 Michal Cyprian 2018-05-16 12:40:32 UTC
I've done it using absolute paths, updated spec is on its original URL.

Comment 14 Miro Hrončok 2018-05-16 13:43:02 UTC
I'd consider this approved.

Spot, since you are here, do you want to double check the licensing madness?

Comment 15 Miro Hrončok 2018-05-22 11:36:14 UTC
Let's unleash this monster!

Package APPROVED.

Comment 16 Gwyn Ciesla 2018-05-22 22:02:19 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/pipenv

Comment 17 Miro Hrončok 2018-05-22 22:08:49 UTC
Michal, would you mind add me as admin and python-sig as commit?

Comment 18 Michal Cyprian 2018-05-24 09:54:41 UTC
sure.

Comment 19 Fedora Update System 2018-05-24 09:56:20 UTC
pipenv-11.10.4-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-47d98b665f

Comment 20 Fedora Update System 2018-05-24 18:00:29 UTC
pipenv-11.10.4-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-47d98b665f

Comment 21 Fedora Update System 2018-06-04 13:16:41 UTC
pipenv-11.10.4-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.