Bug 1564512 - Review Request: cdargs - The shell cd with bookmarks and browser
Summary: Review Request: cdargs - The shell cd with bookmarks and browser
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jared Smith
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 13:22 UTC by Robert-André Mauchin 🐧
Modified: 2018-05-08 14:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-08 14:01:35 UTC
Type: ---
jsmith.fedora: fedora-review+


Attachments (Terms of Use)

Description Robert-André Mauchin 🐧 2018-04-06 13:22:12 UTC
Spec URL: https://eclipseo.fedorapeople.org/cdargs/cdargs.spec
SRPM URL: https://eclipseo.fedorapeople.org/cdargs/cdargs-1.35-18.fc29.src.rpm

Description:
Enables the user to quickly change working directory by navigating cd arguments
and expanding the shell built-in cd with bookmarks and browser.

Fedora Account System Username: eclipseo

Comment 1 Jared Smith 2018-04-06 15:04:26 UTC
I'm assuming this is a re-review of the orphaned "cdargs" package.  If not, there's a conflict on the package name that will need to be resolved.  Also, the header file needs to go in a -devel package, and the sub-packages should probably have archful depends (using %{?_isa})


Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Header files in -devel subpackage, if present.
  Note: cdargs-debugsource :
  /usr/src/debug/cdargs-1.35-18.fc29.x86_64/src/cdargs.h
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#DevelPackages
- Package does not use a name that already exists.
  Note: A package with this name already exists. Please check
  https://admin.fedoraproject.org/pkgdb/package/cdargs
  See:
  https://fedoraproject.org/wiki/Packaging/NamingGuidelines#Conflicting_Package_Names


===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[ ]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "GPL", "NTP", "GPL (v2 or later)", "Unknown or generated", "GPL
     (v2 or later) (with incorrect FSF address)". 28 files have unknown
     license. Detailed output of licensecheck in
     /home/jsmith/Documents/Fedora/Reviews/1564512-cdargs/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package must own all directories that it creates.
     Note: Directories without known owners: /etc/profile.d
[x]: Package does not own files or directories owned by other packages.
     Note: Dirs in package are owned also by: /usr/lib/.build-id(qemu-ui-
     gtk, cups-client, efivar-libs, qemu-block-gluster, rpm-plugin-selinux,
     abrt, libmediaart, postgresql-libs, giflib, libreoffice-graphicfilter,
     trousers, libdb-utils, tracker-miners, xorg-x11-font-utils,
     PackageKit-command-not-found, perl-Sys-Syslog, libcom_err, libseccomp,
     p11-kit, libabw, libvirt-daemon-driver-storage-iscsi, libmodman,
     argyllcms, parted, gnome-disk-utility, libdvdread, zstd, bluez-libs,
     libbs2b, libwebp, libxslt, system-config-printer-udev, perl-Encode,
     elfutils, python2-cryptography, libevdev, libgpg-error, lvm2-libs,
     perl-Digest-SHA, libzstd, wxBase, libdazzle, xdg-desktop-portal-gtk,
     lua-lpeg, symlinks, libcdr, b43-fwcutter, e2fsprogs-libs, pulseaudio-
     libs, lcms2, docker-rhel-push-plugin, qemu-guest-agent, annobin, ntfs-
     3g, libxcb, libyubikey, python3-pycurl, python3-brlapi, openconnect,
     xcb-util-keysyms, m4, hamlib, expat, libgphoto2, xcb-util, gvfs-fuse,
     pjproject, python3-coverage, anaconda-widgets, http-parser, file-
     roller-nautilus, llvm5.0-libs, libeot, ImageMagick-c++, systemd-
     bootchart, uniconvertor, perl-JSON-XS, texlive-pdftex, perl-Time-
     Piece, dbusmenu-qt, ncurses-libs, polkit, checkpolicy, libreport-
     plugin-logger, gnome-color-manager, fcoe-utils, xorg-x11-xkb-utils,
     ibus-hangul, NetworkManager-openvpn, libxkbfile, hplip-libs,
     libwvstreams, xmlrpc-c-client, sane-backends-drivers-cameras, libwpg,
     libwpd, enchant2, libdc1394, libvirt-daemon-driver-qemu, perl-Time-
     HiRes, qemu-block-ssh, libwps, gssdp, gnome-calendar, libacl, xorg-x11
     -drv-ati, libSM, policycoreutils, mcelog, samba-common-tools,
     libmusicbrainz5, pptp, sane-backends-drivers-scanners, libXxf86misc,
     foomatic, texlive-dvips, minizip, colord-gtk, libpath_utils, libicu-
     devel, rpm-build, libvirt-daemon-driver-storage-sheepdog, libglvnd-
     gles, redhat-lsb-core, freeglut, gstreamer1, gom, gmime30,
     libtomcrypt, sshpass, libreoffice-gtk3, libreoffice-gtk2, librtmp,
     cairo-gobject, gnome-screenshot, libkkc, gutenprint, openal-soft,
     usermode, qpdf-libs, linux-atm-libs, libedit, openssh, libvirt-
     gconfig, python3-cairo, accountsservice, isl, hfsplus-tools,
     ImageMagick, perl-IPC-SysV, gssproxy, mesa-libGLU, libblockdev-btrfs,
     libatomic_ops, gupnp-av, libmpcdec, gtk-update-icon-cache, tor,
     ntpdate, python3-iscsi-initiator-utils, libvirt-daemon-driver-
     interface, NetworkManager, liblangtag, libdatrie, glade-libs,
     setuptool, libcryptui, guile, pcre-utf16, tree, gvfs-goa, pipewire,
     glusterfs-libs, gnupg, cronie-anacron, xfsprogs, authselect, libcroco,
     texlive-bibtex, telepathy-glib, NetworkManager-fortisslvpn-gnome,
     plymouth-plugin-label, colord-libs, aalib-libs, perl-Unicode-Collate,
     efivar, gpgmepp, libgcab1, libzhuyin, gvnc, hypervfcopyd, cronie,
     libwnck, libexttextcat, gsl, nettle, libcacard, libverto-libev,
     colord, libpipeline, pkcs11-helper, accountsservice-libs, gnome-
     system-monitor, findutils, popt, python2-xpyb, libsss_idmap,
     libraw1394, folks, gnome-clocks, python3-dbus, iproute-tc,
     libipa_hbac, spice-glib, woff2, python2-numpy, dotconf, luajit,
     libXfont, PackageKit-glib, patch, sqlite-libs, lttng-ust, enchant,
     libXxf86dga, python2-smartcols, rhash, xdg-user-dirs-gtk, libwayland-
     client, pinentry-gnome3, libsmbios, libipt, mdadm, libchamplain,
     python2-zope-interface, device-mapper, python2-librepo, libXtst,
     xapian-core-libs, gnome-terminal, GeoIP, libpano13, GraphicsMagick,
     libsigc++20, python2-talloc, libXrandr, newt, liba52, hplip, crda,
     libical, sheepdog, qt5-qtdeclarative, vo-amrwbenc, libXfont2,
     libblockdev-loop, libmfx, libssh2, NetworkManager-adsl, open-vm-tools-
     desktop, mencoder, samba-dc-libs, libXcursor, iio-sensor-proxy,
     dracut, procps-ng, plymouth-core-libs, telnet, simple-scan, libXpm,
     xorg-x11-drv-nouveau, bluez-obexd, zlib, libpeas, pam_krb5,
     gutenprint-cups, PackageKit-gstreamer-plugin, avahi, libselinux,
     ncurses-compat-libs, libassuan, nodejs, sushi, cups-filters, iw,
     clutter-gtk, userspace-rcu, wavpack, ibus-libpinyin, setroubleshoot-
     server, make, python3-markupsafe, libsoup, glusterfs-api, fuse, perl-
     Net-SSLeay, perl-Filter, cups-libs, libappstream-glib, libsepol,
     totem-pl-parser, gzip, autogen-libopts, keyutils, isomd5sum, libfdisk,
     libdmx, openssl-libs, corosynclib, opencc, libreport-plugin-
     reportuploader, gavl, ipset, x265-libs, postgresql-devel, unique,
     libcaca, keybinder3, deltarpm, fuse-libs, xorg-x11-xauth, libglvnd-
     glx, gvfs-smb, gtkspell3, libcue, libXrender, json-glib, libX11-xcb,
     libfontenc, libicu, libgsf, xorg-x11-drv-vmware, sssd-common,
     NetworkManager-openconnect, libgtop2, btrfs-progs, tracker, wvdial,
     perl-Devel-PPPort, cogl, sni-qt, mesa-libglapi, bolt, glx-utils,
     NetworkManager-vpnc-gnome, libtommath, evolution-data-server,
     PackageKit, perl-MIME-Base64, libass, libxfce4util, SDL_image,
     libstdc++, ppp, startup-notification, python2-crypto, git, perl-
     Compress-Raw-Bzip2, jack-audio-connection-kit, mpg123-libs, opus,
     tcpdump, frei0r-plugins, libxklavier, traceroute, cyrus-sasl-plain,
     libblockdev-crypto, libreoffice-pdfimport, rp-pppoe, libtheora, attr,
     mtr, gtksourceview3, pugixml, libcanberra-gtk2, libcanberra-gtk3, php-
     json, mtdev, mailx, libmspack, systemd-udev, fftw-libs-single,
     libXvMC, cheese-libs, python2-pillow, libXmu, capstone, libreoffice-
     impress, jasper-libs, librbd1, asterisk, device-mapper-libs,
     xorg-x11-xinit, gnome-initial-setup, pyliblzma, libffi, libGLEW,
     libICE, pcre-utf32, python2-hawkey, diffutils, chrony, time, mpfr,
     iputils, qt5-qtxmlpatterns, numactl-libs, mariadb-connector-c-devel,
     libvirt-daemon-driver-nwfilter, recode, libwmf-lite, tigervnc-server-
     minimal, gpgme, hypervvssd, xorg-x11-drv-openchrome, libmcpp,
     libibverbs, rpm-devel, dleyna-core, qemu-audio-pa, libgovirt, libqmi-
     utils, libmbim-utils, psacct, lame-libs, gnome-bluetooth-libs,
     usbredir, ghostscript, libtirpc, iptables-libs, cryptsetup-libs,
     syslinux-extlinux, bind-libs, pygobject2, mesa-libwayland-egl,
     ghostscript-x11, lua-posix, libinput, libreport-cli, libpkgconf,
     teckit, python3-dmidecode, abrt-gui-libs, gegl, libosinfo, libabigail,
     corosync, libreoffice-calc, sane-backends-libs, gawk, dmraid-events,
     pcsc-lite-libs, adwaita-gtk2-theme, libbasicobjects, gdk-
     pixbuf2-devel, hdf5, baobab, rdma-core, vte291, libgweather, sssd-
     krb5, qemu-block-iscsi, perl-Devel-Peek, brotli, libgrss, httpd,
     libsmbclient, pulseaudio-utils, python2-reportlab, rpm-sign-libs,
     libvdpau, compat-openssl10, opencore-amr, abrt-addon-kerneloops,
     gnome-maps, oddjob-mkhomedir, airsnort, openCOLLADA, xcb-util-
     renderutil, qt5-qtserialport, sssd-ad, texlive-luatex, libpinyin,
     nmap-ncat, logrotate, rdist, scl-utils, libdnet, flann, ntfsprogs,
     abrt-libs, efibootmgr, libgdither, samba-common-libs, libpsl, wxGTK,
     python3-rpm, nautilus-sendto, fwupdate-libs, jimtcl, libuser, opensp,
     lksctp-tools, graphviz, kexec-tools, boost-date-time, satyr, caribou-
     gtk3-module, pixman, gnome-font-viewer, wpa_supplicant, rubygem-psych,
     xorg-x11-drv-vesa, libbluray, cifs-utils, texlive-lib, libbabeltrace,
     vpnc, psmisc, net-snmp-libs, xorg-x11-drv-libinput, libsss_certmap,
     libblockdev-mpath, ed, libgcc, libmng, ilmbase, perl-Compress-Bzip2,
     poppler, pocl, libstemmer, djvulibre-libs, ibus-libzhuyin, fftw-libs-
     double, libconfig, ModemManager, abrt-gui, ibus-m17n, qemu-img, qt5
     -qtbase-gui, rtkit, orc, libidn2, libuuid, faad2-libs, libarchive,
     libfreehand, ibus-gtk3, ibus-gtk2, xfdesktop, cheese, udisks2,
     clucene-contribs-lib, paps-libs, tcp_wrappers, compat-giflib, xz,
     libXcomposite, rpcbind, mtools, pygtk2, criu, vim-minimal, harfbuzz-
     icu, libplist, xdg-user-dirs, hwloc-libs, spice-server, gdk-pixbuf2,
     gupnp, libreport, libeasyfc-gobject, libevent, redland,
     python2-cccolutils, git-core, gnome-characters, control-center,
     NetworkManager-ssh, libblockdev, librdmacm, lua-socket, dconf, xz-
     libs, dbus-glib, PackageKit-gtk3-module, libpri, libdvdnav, libcap,
     libvirt-daemon-driver-storage-zfs, libwbclient, compiler-rt, libvirt-
     daemon-driver-storage-gluster, numad, NetworkManager-fortisslvpn,
     mod_http2, NetworkManager-pptp, libthai, fakeroot, gnome-session, nss-
     tools, adcli, iproute, python2-gpg, libsmartcols, gsound, fakeroot-
     libs, oci-systemd-hook, python3-hawkey, os-prober, ethtool,
     libreofficekit, libfprint, systemd-libs, cpio, libknet1, libfdt, util-
     linux, OpenEXR-libs, krb5-libs, gnome-online-accounts, net-tools,
     enca, libblockdev-part, libpciaccess, clucene-core, libsss_autofs,
     kmod, openscap-scanner, NetworkManager-ssh-gnome, libxml++,
     libresample, libetonyek, plymouth, libgs, asterisk-iax2, gnome-user-
     share, sssd-client, libgxps, screen, systemd, webkit2gtk3-jsc,
     libpagemaker, highlight, libxkbcommon, device-mapper-multipath-libs,
     yajl, lockdev, cups-filters-libs, poppler-utils, lpsolve, gnome-
     terminal-nautilus, xorg-x11-server-utils, torsocks, gnupg2, marisa,
     evince-libs, libepubgen, libdnf, freetds-libs, ruby, abrt-addon-
     pstoreoops, gmp-c++, libdbusmenu-gtk2, pulseaudio-libs-glib2, texlive-
     makeindex, trustedqsl, netpbm, lxpolkit, nm-connection-editor,
     python3-pyparted, libudisks2, abrt-plugin-bodhi, gstreamer1-plugins-
     bad-free, python3-setools, clutter, zenity, rhythmbox, chkconfig,
     libgnome-keyring, hostname, iscsi-initiator-utils, pangox-compat,
     librados2, libvirt-daemon-driver-storage-mpath, pam, liborcus,
     unixODBC, openldap, oniguruma, zziplib, evince-nautilus, ipcalc, SDL,
     speex, libvirt-daemon-driver-storage-logical, ibus-wayland, neon,
     rest, libsamplerate, python2-lxml, gdm, boost-iostreams, geocode-glib,
     pakchois, zfs-fuse, libusbmuxd, perl-Unicode-Normalize, gperftools-
     libs, libimobiledevice, lzop, NetworkManager-wwan, polkit-pkla-compat,
     jbig2dec-libs, epiphany-runtime, libmtp, cyrus-sasl-lib, librevenge,
     hexchat, nspr, gjs, python3-gobject-base, gnome-settings-daemon,
     dnsmasq, geoclue2-libs, libXfixes, libblkid, libcdio, libsss_sudo,
     rsync, samba-winbind, chromium, lua-libs, pavucontrol, perl-Params-
     Util, authselect-libs, soundtouch, xorg-x11-drv-evdev, libpeas-gtk,
     libXinerama, lirc-libs, libteam, vim-enhanced, libcmis, elfutils-libs,
     osm-gps-map, acl, libogg, libkadm5, libphodav, vid.stab, libgee,
     libXxf86vm, mesa-libEGL, clang-libs, rpm-plugin-systemd-inhibit, libc-
     client, perl-Storable, perl-Digest-MD5, spandsp, gvfs-gphoto2, net-
     snmp-agent-libs, fonts-tweak-tool, perl-Sort-Key, libvirt-daemon-
     driver-storage-rbd, libnfsidmap, nss-util, libsemanage, cracklib,
     mozjs52, systemd-container, libcomps, libaec, at, file, aisleriot,
     libdca, libblockdev-fs, java-1.8.0-openjdk-headless, libnma, gettext,
     pcre2-utf32, soxr, espeak, oci-umount, libvirt-gobject, libutempter,
     libmetalink, slang, gvfs-afp, gnome-keyring-pam, pulseaudio,
     e2fsprogs, libcdio-paranoia, grub2-tools-minimal, cpp, libksba,
     libwayland-server, virglrenderer, gdbm, osinfo-db-tools, libsndfile,
     libvisio, tk, ruby-libs, bzip2-libs, dbus-libs, gnome-keyring,
     openssl-pkcs11, gnutls, device-mapper-persistent-data, ykpers,
     webkit2gtk3-plugin-process-gtk2, libselinux-utils, perl-Scalar-List-
     Utils, dosfstools, rng-tools, gnome-abrt, libspectre, keyutils-libs,
     libproxy, sssd-common-pac, libreoffice-math, libtimezonemap, audit-
     libs-python3, perl-Data-Dumper, glusterfs-fuse, anaconda-core,
     python2-sqlalchemy, libatasmart, perl-XML-Parser, fortune-mod,
     mlocate, file-libs, grub2-tools, avahi-glib, mokutil, libblockdev-
     swap, libnetfilter_conntrack, python3-gobject, libev, gdb-headless,
     bash, fprintd-pam, gmime, libusbx, NetworkManager-openvpn-gnome,
     qrencode-libs, hugin, libgexiv2, drpm, qemu-block-nfs, createrepo_c-
     libs, grilo, libgpod, perl-Compress-Raw-Zlib, speexdsp, upower, dee,
     libreoffice-x11, nautilus, xcb-util-wm, gtk2-devel, Thunar, atk,
     dbxtool, gnome-vfs2, alsa-lib, gstreamer1-plugins-good-gtk, libwnck3,
     x264-libs, python2-gobject, gtkmm24, libvirt-daemon-driver-storage-
     disk, brasero-libs, mesa-dri-drivers, sgpio, python3-abrt, libffado,
     gtk3, suitesparse, ibus-kkc, gdbm-libs, fribidi, libgnomekbd,
     libblockdev-kbd, ibus-rawcode, docbook2X, pciutils, libini_config,
     openssh-clients, texlive-mfware, libX11, celt051, beignet, htop,
     kyotocabinet-libs, python3-pwquality, gvfs-mtp, python3-cryptography,
     gnome-bluetooth, atkmm, gnome-software, libnl3, gimp-libs, libidn,
     grubby, openjpeg-libs, python3-libreport, libdbusmenu, libbytesize,
     libmpeg2, qemu-block-rbd, python3-systemd, rpm-ostree-libs,
     libnl3-cli, ibus-libs, python2-libcomps, python2-pyyaml, audit-libs,
     cyrus-sasl-devel, bluez, gettext-libs, python2-cffi, cups, dcraw,
     libref_array, gvfs-afc, switcheroo-control, fwupd, raptor2, rubygem-
     io-console, plymouth-plugin-two-step, sbc, qt-x11, libsane-hpaio,
     libhangul, ocl-icd, poppler-glib, potrace, pcaudiolib, seahorse,
     libblockdev-lvm, libopenraw, lvm2, openfortivpn, harfbuzz, libva,
     dmraid, python3-wrapt, gvfs-client, NetworkManager-libnm,
     python2-libs, ibus-qt, gnome-boxes, lrzsz, libglvnd-egl, libunwind,
     unbound-libs, dhcp-libs, gamin, grep, hypervkvpd, libepoxy, perl-
     Variable-Magic, man-db, gedit, libvirt-daemon-driver-storage-core,
     libibumad, mesa-libgbm, boost-locale, timedatex, fltk, xdg-desktop-
     portal, sssd-nfs-idmap, rasqal, wireless-tools, libdb, passwd, cups-
     pk-helper, gnome-calculator, kmod-libs, NetworkManager-team, libdv,
     gutenprint-libs, lm_sensors-libs, libreoffice-writer, desktop-file-
     utils, libXdamage, xorg-x11-utils, libmwaw, exo, dleyna-connector-
     dbus, gtkmm30, clang5.0-libs, libgit2, qt5-qtmultimedia, freeradius-
     client, texlive-xdvi, gobject-introspection, libpwquality, fontconfig,
     compat-ffmpeg28, libtalloc, libblockdev-dm, perl-Math-BigInt-FastCalc,
     evince-djvu, libtar, libdaemon, mariadb-connector-c, evince, flatpak,
     python3-librepo, pkgconf, vino, json-c, sed, sssd-ipa, perl-threads-
     shared, glib-networking, samba-libs, kpartx, libpng, libqmi,
     python3-pillow, util-linux-user, cyrus-sasl, hardlink, libcollection,
     libgcrypt, cairomm, perl-Unicode-UTF8, nss-softokn, openal-soft-devel,
     geoclue2, lsof, at-spi2-atk, libnsl2, gnome-online-miners, twolame-
     libs, adwaita-qt4, adwaita-qt5, gnome-shell, xorg-x11-server-Xorg,
     usbmuxd, libmbim, perl-IO, libomp, libverto, glibmm24, libXScrnSaver,
     realmd, libmspub, ncurses, nfs-utils, graphite2, python3-kerberos,
     perl-version, imlib2, libreport-plugin-kerneloops, libtdb, sssd-
     krb5-common, volume_key-libs, cdparanoia-libs, libzapojit, ffmpeg-
     libs, alsa-plugins-pulseaudio, perl-interpreter, powerline, oci-
     register-machine, bluez-cups, gimp, texlive-metafont, chromium-libs-
     media, libcurl, sssd-kcm, coreutils, libcap-ng, gvfs, dbus-x11, swig,
     gnome-tetravex, pinentry, libvirt-daemon-driver-storage-scsi, librepo,
     nautilus-extensions, qemu-common, docker, gsm, libuv, boost-
     filesystem, libtevent, ilbc, xcowsay, openblas-threads, libglvnd,
     gnome-documents-libs, boost-system, libpcap, wxBase3, snappy,
     libindicator, clutter-gst3, libdrm, genisoimage, rubygem-bigdecimal,
     pcre2, shotwell, xmlrpc-c, jsoncpp, perl-TermReadKey, jq, espeak-ng,
     protobuf-c, rygel, libpng-devel, python3-PyYAML, libvirt-glib,
     python2-wxpython, telepathy-logger, libssh, libmodulemd, inkscape,
     GConf2, glibc, fldigi, flatpak-libs, fipscheck, libss7, mactel-boot,
     bc, gtk-vnc2, quota, wget, libijs, openssl, libreport-web, libgomp,
     libexif, libvirt-daemon-driver-secret, ladspa, php-cli, libgusb,
     glib2, qemu-system-x86-core, ImageMagick-libs, libwmf, pcre2-utf16,
     libmnl, libzmf, gdisk, nss, pcre, libchamplain-gtk, tcp_wrappers-libs,
     sane-backends, gstreamer1-plugins-base, spax, speech-dispatcher, php-
     common, pciutils-libs, libiptcdata, libmpc, libXi, file-roller,
     openjpeg2, flac-libs, libXt, libXv, rubygem-openssl, rpm-libs, info,
     libnfnetlink, libiec61883, device-mapper-event, libusal, libreport-
     plugin-bugzilla, qt5-qtbase, libpskc, lirc-core, ibus, jwhois, qemu-
     block-dmg, curl, yelp-libs, cmake, gnutls-dane, libdmapsharing,
     rubygem-json, fipscheck-lib, python2-pycurl, dos2unix, paps, libqxp,
     abrt-tui, lzo-minilzo, harfbuzz-devel, gtk3-devel, abrt-addon-xorg,
     libdhash, caribou, sssd-proxy, totem, gd, gc, python3-cups,
     libxshmfence, ncurses-c++-libs, libreport-plugin-systemd-journal,
     gstreamer1-plugins-ugly-free, atlas, openscap, unzip, gtk2,
     libxfce4ui, libv4l, u2f-hidraw-policy, npth, abrt-addon-coredump-
     helper, libyaml, libXaw, gspell, xcb-util-image, m17n-lib, mozjs17,
     libblockdev-mdraid, glusterfs, exiv2-libs, lensfun, xmlstarlet,
     libunistring, dleyna-server, freetds, hugin-base, qgnomeplatform,
     gstreamer1-plugins-good, python2-rpm, libasyncns, qemu-block-curl,
     device-mapper-multipath, c-ares, xmlsec1-openssl, libspiro,
     python2-cairo, gfbgraph, NetworkManager-pptp-gnome, jansson, bind-
     utils, garcon, librsvg2, firefox, apr, libsss_nss_idmap, gupnp-dlna,
     trousers-lib, zip, webrtc-audio-processing, bcache-tools, libproxy-
     mozjs, feh, babl, libstaroffice, pinfo, xfce4-panel, bubblewrap,
     libesmtp, gcc-c++, speech-dispatcher-espeak-ng, libtasn1, jbigkit-
     libs, perl-libintl-perl, libe-book, alsa-utils, sqlite, tar, sudo,
     dhcp-client, fprintd, pinentry-gtk, gcc, dwz, xorg-x11-drv-qxl, gcr,
     python2-psutil, oddjob, ebtables, avahi-libs, pigz, libquvi, gvfs-
     archive, libao, perl-libs, lz4, kbd, libreoffice-core, wayland-devel,
     libwayland-cursor, openvpn, dahdi-tools-libs, libpaper, chromium-libs,
     xvidcore, libwacom, lzo, pango, libss, aspell, mod_dnssd, esmtp, dbus,
     polkit-libs, perl-threads, perl-Params-Validate, pangomm, cryptsetup,
     flickcurl, mesa-libxatracker, nss-sysinit, LibRaw, texlive-gsftopk,
     libtidy, nodejs-devel, nss-mdns, python3-cffi, openjade, vigra,
     libtgvoip, at-spi2-core, libvirt-daemon-driver-network, glibc-common,
     liblockfile, bind-export-libs, gnome-autoar, python3-libxml2, libnfs,
     systemd-pam, libgfortran, stoken-libs, gnome-contacts, libiscsi,
     texlive-kpathsea, groff-base, libusb, openssh-askpass, mesa-libGL,
     perl-HTML-Parser, abrt-addon-ccpp, libldb, python2-gobject-base,
     NetworkManager-vpnc, libvirt-daemon-driver-nodedev, libXres, samba-
     winbind-modules, libcanberra, tidy, grub2-tools-efi, libart_lgpl,
     libgudev, xorg-x11-drv-wacom, libsrtp, perl-Package-Stash-XS, samba-
     client-libs, which, boost-chrono, samba-client, libaio, lua-expat,
     libquadmath, mplayer, qemu-ui-curses, libshout, python2-krbv, brlapi,
     createrepo_c, python2-markupsafe, elinks, libreport-gtk, liboauth,
     xmlsec1, gnome-todo, texlive-tex4ht, isns-utils-libs, libwsman1,
     krb5-workstation, mcpp, freetype, libglvnd-opengl, lz4-libs, libgltf,
     usb_modeswitch, tbb, mythes, mesa-libOpenCL, evolution,
     NetworkManager-wifi, qt, abrt-retrace-client, teamd, libvorbis,
     NetworkManager-openconnect-gnome, vconfig, wxGTK3-media, pcre-cpp,
     python3-libselinux, libodfgen, liblouis, gtkglext-libs, wsjtx, exiv2,
     iptables, texlive-xetex, yasm, lua, gnutls-c++, libpeas-loader-
     python3, llvm-libs, gnome-logs, doxygen, pulseaudio-module-bluetooth,
     libvirt-libs, valgrind, portaudio, passwdqc, libXft, schroedinger,
     libattr, qt5-qtbase-devel, hyphen, gnupg2-smime, rpm, qemu-audio-oss,
     syslinux, libxcrypt, gts, sssd-ldap, iptstate, glib2-devel, libreport-
     plugin-ureport, radvd, enblend, python3-libs, libappindicator,
     glusterfs-cli, perl-PathTools, ipset-libs, netpbm-progs, perl-Devel-
     Size, plymouth-graphics-libs, mozjs38, gnome-menus, glusterfs-client-
     xlators, libreoffice-pyuno, libxml2, libgepub, libreoffice-ure, iscsi-
     initiator-utils-iscsiuio, cyrus-sasl-gssapi, xfwm4, mpage, libargon2,
     libimagequant, mousetweaks, libvirt-daemon, scap-workbench, libsecret,
     openblas, libnet, p11-kit-trust, NetworkManager-bluetooth, augeas-
     libs, libsysfs, lasi, audit, wxGTK3-gl, abrt-dbus, gnome-desktop3,
     gdk-pixbuf2-modules, binutils, xfconf, xen-libs, openscap-utils, nss-
     pem, vim-common, python2-kerberos, less, brltty, libvpx, tcl, rpm-
     build-libs, libnghttp2, ostree-libs, totem-nautilus, libsolv, exempi,
     libxkbcommon-x11, gmp, python3-gpg, libXdmcp, perl-Socket, apr-util,
     krb5-devel, libvisual, python3, python2, gpm-libs, xorg-x11-server-
     Xwayland, perl-DB_File, shared-mime-info, httpd-tools, SDL2,
     webkit2gtk3, python2-twisted, libsigsegv, boost-thread, caribou-
     gtk2-module, grilo-plugins, shadow-utils, libcgroup, dbus-glib-devel,
     libXau, netcf-libs, libgdata, pulseaudio-module-x11, dmidecode, qemu-
     audio-alsa, python3-libcomps, libjpeg-turbo, spice-gtk3, libmount,
     spice-vdagent, xorg-x11-drv-wacom-serial-support, xorg-x11-drv-fbdev,
     libqb, libavc1394, lldpad, libtiff, python3-libsemanage, sg3_utils-
     libs, libnotify, ima-evm-utils, texlive-tex, cairo, bind-libs-lite,
     python3-pygit2, grub2-tools-extra, qemu-audio-sdl, openssh-server,
     darktable, mutter, taglib, sphinx, libXext, libblockdev-utils,
     ModemManager-glib, bridge-utils, ostree, device-mapper-event-libs,
     initscripts, hunspell, libieee1284, wxGTK3, libndp, usbutils, qemu-ui-
     sdl, bzip2, tqsllib, libeasyfc, elfutils-libelf, nss-softokn-freebl,
     open-vm-tools, evolution-ews, python3-smartcols, libavdevice, libtool-
     ltdl, readline, eog, yelp, xorg-x11-drv-intel, abrt-java-connector,
     passwdqc-lib), /usr/lib/.build-id/f8(lirc-core, fortune-mod,
     python2-wxpython, ppp, libsss_sudo, wsjtx, cups, libreoffice-core,
     gimp, libaio, httpd, glibc, gegl, libreport-plugin-systemd-journal,
     frei0r-plugins, iptables, libgphoto2, sane-backends-drivers-scanners,
     chromium-libs, GraphicsMagick, ostree, hexchat, netpbm-progs,
     pulseaudio, bind-utils, samba-client-libs)
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[!]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 30720 bytes in 5 files.
[!]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: %config files are marked noreplace or the reason is justified.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: No %config files under /usr.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[!]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in emacs-
     cdargs , emacs-cdargs-el , cdargs-debuginfo , cdargs-debugsource
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Spec use %global instead of %define unless justified.
     Note: %define requiring justification: %define profiledir
     %{_sysconfdir}/profile.d
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: cdargs-1.35-18.fc29.x86_64.rpm
          cdargs-devel-1.35-18.fc29.x86_64.rpm
          emacs-cdargs-1.35-18.fc29.noarch.rpm
          emacs-cdargs-el-1.35-18.fc29.noarch.rpm
          cdargs-debuginfo-1.35-18.fc29.x86_64.rpm
          cdargs-debugsource-1.35-18.fc29.x86_64.rpm
          cdargs-1.35-18.fc29.src.rpm
cdargs.x86_64: W: spelling-error Summary(en_US) cd -> CD, dc, Cd
cdargs.x86_64: W: spelling-error %description -l en_US cd -> CD, dc, Cd
cdargs.x86_64: W: only-non-binary-in-usr-lib
cdargs.x86_64: E: incorrect-fsf-address /usr/share/licenses/cdargs/COPYING
cdargs-devel.x86_64: W: no-documentation
emacs-cdargs.noarch: W: spelling-error %description -l en_US cv -> CV, xv, cc
emacs-cdargs.noarch: W: no-documentation
emacs-cdargs-el.noarch: W: spelling-error Summary(en_US) Elisp -> Lisp, Elise, Elisa
emacs-cdargs-el.noarch: W: no-documentation
emacs-cdargs-el.noarch: E: incorrect-fsf-address /usr/share/licenses/emacs-cdargs-el/COPYING
cdargs-debugsource.x86_64: W: no-documentation
cdargs.src: W: spelling-error Summary(en_US) cd -> CD, dc, Cd
cdargs.src: W: spelling-error %description -l en_US cd -> CD, dc, Cd
cdargs.src: E: specfile-error warning: line 38: Possible unexpanded macro in: Requires:    emacs(bin) >= %{_emacs_version}
7 packages and 0 specfiles checked; 3 errors, 11 warnings.




Rpmlint (debuginfo)
-------------------
Checking: cdargs-debuginfo-1.35-18.fc29.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
cdargs.x86_64: W: spelling-error Summary(en_US) cd -> CD, dc, Cd
cdargs.x86_64: W: spelling-error %description -l en_US cd -> CD, dc, Cd
cdargs.x86_64: W: invalid-url URL: http://www.skamphausen.de/cgi-bin/ska/CDargs/ <urlopen error [Errno -2] Name or service not known>
cdargs.x86_64: W: only-non-binary-in-usr-lib
cdargs.x86_64: E: incorrect-fsf-address /usr/share/licenses/cdargs/COPYING
cdargs-debugsource.x86_64: W: invalid-url URL: http://www.skamphausen.de/cgi-bin/ska/CDargs/ <urlopen error [Errno -2] Name or service not known>
cdargs-debugsource.x86_64: W: no-documentation
emacs-cdargs-el.noarch: W: spelling-error Summary(en_US) Elisp -> Lisp, Elise, Elisa
emacs-cdargs-el.noarch: W: invalid-url URL: http://www.skamphausen.de/cgi-bin/ska/CDargs/ <urlopen error [Errno -2] Name or service not known>
emacs-cdargs-el.noarch: W: no-documentation
emacs-cdargs-el.noarch: E: incorrect-fsf-address /usr/share/licenses/emacs-cdargs-el/COPYING
emacs-cdargs.noarch: W: spelling-error %description -l en_US cv -> CV, xv, cc
emacs-cdargs.noarch: W: invalid-url URL: http://www.skamphausen.de/cgi-bin/ska/CDargs/ <urlopen error [Errno -2] Name or service not known>
emacs-cdargs.noarch: W: no-documentation
cdargs-devel.x86_64: W: invalid-url URL: http://www.skamphausen.de/cgi-bin/ska/CDargs/ <urlopen error [Errno -2] Name or service not known>
cdargs-devel.x86_64: W: no-documentation
cdargs-debuginfo.x86_64: W: invalid-url URL: http://www.skamphausen.de/cgi-bin/ska/CDargs/ <urlopen error [Errno -2] Name or service not known>
6 packages and 0 specfiles checked; 2 errors, 15 warnings.



Requires
--------
cdargs (rpmlib, GLIBC filtered):
    config(cdargs)
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libncurses.so.6()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libtinfo.so.6()(64bit)
    rtld(GNU_HASH)

cdargs-debugsource (rpmlib, GLIBC filtered):

emacs-cdargs-el (rpmlib, GLIBC filtered):
    emacs-cdargs

emacs-cdargs (rpmlib, GLIBC filtered):
    cdargs
    emacs(bin)

cdargs-devel (rpmlib, GLIBC filtered):
    cdargs(x86-64)

cdargs-debuginfo (rpmlib, GLIBC filtered):



Provides
--------
cdargs:
    cdargs
    cdargs(x86-64)
    config(cdargs)

cdargs-debugsource:
    cdargs-debugsource
    cdargs-debugsource(x86-64)

emacs-cdargs-el:
    emacs-cdargs-el

emacs-cdargs:
    emacs-cdargs

cdargs-devel:
    cdargs-devel
    cdargs-devel(x86-64)

cdargs-debuginfo:
    cdargs-debuginfo
    cdargs-debuginfo(x86-64)
    debuginfo(build-id)



Source checksums
----------------
http://www.skamphausen.de/downloads/cdargs/cdargs-1.35.tar.gz :
  CHECKSUM(SHA256) this package     : ee35a8887c2379c9664b277eaed9b353887d89480d5749c9ad957adf9c57ed2c
  CHECKSUM(SHA256) upstream package : ee35a8887c2379c9664b277eaed9b353887d89480d5749c9ad957adf9c57ed2c


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -b 1564512
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Java, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 2 Robert-André Mauchin 🐧 2018-04-06 15:57:50 UTC
(In reply to Jared Smith from comment #1)
> I'm assuming this is a re-review of the orphaned "cdargs" package.  If not,
> there's a conflict on the package name that will need to be resolved.

Yes, it's to un-retire this package.

> Also,
> the header file needs to go in a -devel package,

Which header file? The only header file /usr/include/cdargs.h is already in cdargs-devel.

> and the sub-packages should
> probably have archful depends (using %{?_isa})
> 

Only cdargs-devel is arched and thus has %{?_isa}, emacs-cdargs and emacs-cdargs-el are noarch and thus do not require %{?_isa}.

Comment 3 Robert-André Mauchin 🐧 2018-04-06 15:58:14 UTC
Thanks for the reviews!

Comment 4 Jared Smith 2018-04-06 15:59:49 UTC
Looks good -- package is approved.

Comment 5 Robert-André Mauchin 🐧 2018-04-06 16:01:14 UTC
If you're talking about this header:

- Header files in -devel subpackage, if present.
  Note: cdargs-debugsource :
  /usr/src/debug/cdargs-1.35-18.fc29.x86_64/src/cdargs.h


It's a "bug" of fedora-review which doesn't ignore the new debugsource packages as it should. I actually did a PR to fix that and it has been merged en the devel branch of fedora-review.


Note You need to log in before you can comment on or make changes to this bug.