Bug 1564539 - openshift-provisioners.yml playbook runs through to completion but fails to successfully deploy components
Summary: openshift-provisioners.yml playbook runs through to completion but fails to s...
Keywords:
Status: CLOSED DUPLICATE of bug 1525014
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.7.z
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 14:58 UTC by Eric Jones
Modified: 2018-04-11 02:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 23:52:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eric Jones 2018-04-06 14:58:13 UTC
Description of problem:

Version-Release number of the following components:
openshift-ansible-playbooks-3.7.23-1.git.0.bc406aa.el7.noarch
ansible-2.4.2.0-2.el7.noarch
openshift-ansible-3.7.23-1.git.0.bc406aa.el7.noarch

ansible-playbook 2.4.2.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible-playbook
  python version = 2.7.5 (default, May  3 2017, 07:55:04) [GCC 4.8.5 20150623 (Red Hat 4.8.5-14)]

Actual results:
Sparce error messages in full output regarding the deployment of specific components but installer finishes and says complete.

Expected results:
provisioners components properly deployed

Notes:
Attaching content shortly

Comment 4 Kenjiro Nakayama 2018-04-10 23:52:38 UTC
I was assigned on the support ticket in APAC working hour and checked logs.

The issue was caused by the task "name": "Check efs anyuid permissions", and it failed to get scc with same reason of bz1525014.

    "stderr": "the server doesn't have a resource type \"scc\"",
    "stderr_lines": [
        "the server doesn't have a resource type \"scc\""
     ],

After the customer proceeded workaround discussed in bz1525014, ansible completed. As this is not an original issue, I am closing this ticket as duplicated.

*** This bug has been marked as a duplicate of bug 1525014 ***

Comment 5 Scott Dodson 2018-04-11 02:41:27 UTC
Nice work, thanks Kenjiro!


Note You need to log in before you can comment on or make changes to this bug.