Bug 1564582 - Delete non-existent hosts causes stuck deletion tasks on Satellite 6.2
Summary: Delete non-existent hosts causes stuck deletion tasks on Satellite 6.2
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Control
Version: 5.7.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: GA
: 5.8.4
Assignee: Greg McCullough
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 16:59 UTC by Ash Westbrook
Modified: 2018-04-10 13:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-09 14:38:45 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Ash Westbrook 2018-04-06 16:59:03 UTC
Description of problem:

Roughly 30 tasks for 'Destroy Content Host' are in a paused/error state. Resuming the jobs does not help.  Exception: RestClient::InternalServerError: 500 Internal Server Error.

This is caused when VMs that were created by CloudForms and then are deleted from CloudForms cause stuck state in Satellite 6.

Version-Release number of selected component (if applicable):

CFME 5.7
Satellite 6.2.14

How reproducible:

Always


Additional info:

Attached reports from the case, 02066982.

Comment 4 Ian Tewksbury 2018-04-06 18:46:20 UTC
Updated Description:

Satellite has stuck tasks.
Those stuck tasks are host delete tasks.
The hosts that those tasks are trying to delete are are deleted.
It is unclear whether the stuck task deleted the host and then got stuck, or the host was otherwise already deleted and then a new task was created to delete the same host and then it got stuck.

CFME only comes into the picture because we have automate that calls the Satellite API to delete host records on VM retirement, thats it, this issue has nothing to do with CFME. It could be that CFME ends up trying to delete the same host twice, but that is inconsequential. Whether or not CFME tries to delete the same host twice using the API, Satellite shouldn't have stuck tasks, period. This is a satellite task issue.

Comment 7 Greg McCullough 2018-04-09 14:38:45 UTC
Closing as not-a-bug based on comments above.


Note You need to log in before you can comment on or make changes to this bug.