Bug 1564651 - [abrt] gns3-server: module(): compute.py:54:<module>:AttributeError: module 'aiohttp' has no attribute 'Timeout'
Summary: [abrt] gns3-server: module(): compute.py:54:<module>:AttributeError: module '...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gns3-server
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Othman Madjoudj
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:92d94e7c58f67cff9c5b780206f...
: 1589891 1631810 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 19:18 UTC by Charles Barto
Modified: 2019-08-08 01:20 UTC (History)
4 users (show)

Fixed In Version: gns3-server-2.1.5-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-13 19:59:34 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (9.21 KB, text/plain)
2018-04-06 19:18 UTC, Charles Barto
no flags Details
File: cgroup (351 bytes, text/plain)
2018-04-06 19:18 UTC, Charles Barto
no flags Details
File: cpuinfo (1.38 KB, text/plain)
2018-04-06 19:18 UTC, Charles Barto
no flags Details
File: environ (1.05 KB, text/plain)
2018-04-06 19:18 UTC, Charles Barto
no flags Details
File: mountinfo (3.80 KB, text/plain)
2018-04-06 19:18 UTC, Charles Barto
no flags Details
File: namespaces (129 bytes, text/plain)
2018-04-06 19:18 UTC, Charles Barto
no flags Details
File: open_fds (236 bytes, text/plain)
2018-04-06 19:18 UTC, Charles Barto
no flags Details

Description Charles Barto 2018-04-06 19:18:50 UTC
Description of problem:
Just started the gns3 server through the gns3-gui program.

Version-Release number of selected component:
gns3-server-2.1.4-2.fc28

Additional info:
reporter:       libreport-2.9.4
cmdline:        /usr/bin/python3 /usr/bin/gns3server --local --log=/home/bartoc/.config/GNS3/gns3_server.log --pid=/home/bartoc/.config/GNS3/gns3_server.pid
crash_function: module
exception_type: AttributeError
executable:     /usr/bin/gns3server
interpreter:    python3-3.6.5-1.fc28.x86_64
kernel:         4.16.0-300.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            420200001

Truncated backtrace:
#1 <module> in /usr/lib/python3.6/site-packages/gns3server/controller/compute.py:54
#2 <module> in /usr/lib/python3.6/site-packages/gns3server/controller/node.py:25
#3 <module> in /usr/lib/python3.6/site-packages/gns3server/controller/project.py:29
#4 <module> in /usr/lib/python3.6/site-packages/gns3server/controller/__init__.py:27
#5 <module> in /usr/lib/python3.6/site-packages/gns3server/web/route.py:31
#6 <module> in /usr/lib/python3.6/site-packages/gns3server/web/web_server.py:32
#7 <module> in /usr/lib/python3.6/site-packages/gns3server/run.py:31
#8 main in /usr/lib/python3.6/site-packages/gns3server/main.py:81
#9 <module> in /usr/bin/gns3server:11

Comment 1 Charles Barto 2018-04-06 19:18:53 UTC
Created attachment 1418276 [details]
File: backtrace

Comment 2 Charles Barto 2018-04-06 19:18:54 UTC
Created attachment 1418277 [details]
File: cgroup

Comment 3 Charles Barto 2018-04-06 19:18:55 UTC
Created attachment 1418278 [details]
File: cpuinfo

Comment 4 Charles Barto 2018-04-06 19:18:56 UTC
Created attachment 1418279 [details]
File: environ

Comment 5 Charles Barto 2018-04-06 19:18:57 UTC
Created attachment 1418280 [details]
File: mountinfo

Comment 6 Charles Barto 2018-04-06 19:18:58 UTC
Created attachment 1418281 [details]
File: namespaces

Comment 7 Charles Barto 2018-04-06 19:18:59 UTC
Created attachment 1418282 [details]
File: open_fds

Comment 8 Othman Madjoudj 2018-04-14 18:01:02 UTC
Unfortunately, F28 has py-aiohttp > 3.0 which is not compatible with the latest version of GNS3, upstream is working on it [1][2]

As a workaround, you can downgrade py-aiohttp to 2.x series via my copr repo [3], or just the pkg itself using the following command:


sudo dnf install https://copr-be.cloud.fedoraproject.org/results/athmane/gns3/fedora-28-x86_64/00741072-python-aiohttp/python3-aiohttp-2.3.10-2.fc28.x86_64.rpm


[1] https://github.com/GNS3/gns3-server/issues/463

[2] https://github.com/GNS3/gns3-server/issues/1296

[3] https://copr.fedorainfracloud.org/coprs/athmane/gns3/

Comment 9 Fedora Update System 2018-04-22 02:16:56 UTC
gns3-server-2.1.5-2.fc28 gns3-gui-2.1.5-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a101e28f70

Comment 10 Fedora Update System 2018-04-29 09:41:21 UTC
gns3-gui-2.1.5-1.fc28, gns3-server-2.1.5-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a101e28f70

Comment 11 Fedora Update System 2018-05-13 19:59:34 UTC
gns3-gui-2.1.5-1.fc28, gns3-server-2.1.5-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 ECHACHAGUA 2018-06-11 15:26:29 UTC
*** Bug 1589891 has been marked as a duplicate of this bug. ***

Comment 13 Ramesh Khattri 2018-09-21 15:34:40 UTC
*** Bug 1631810 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.