Bug 1564673 - atomic fails to install system containers when selinux is disabled
Summary: atomic fails to install system containers when selinux is disabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1186913 1561841
TreeView+ depends on / blocked
 
Reported: 2018-04-06 20:40 UTC by Steve Milner
Modified: 2020-09-04 06:52 UTC (History)
11 users (show)

Fixed In Version: atomic-1.22.1-4.git1895984.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 18:39:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github projectatomic atomic pull 1213 0 None closed Do not call any selinux methods if selinux is disabled 2020-10-01 22:30:14 UTC
Red Hat Product Errata RHBA-2018:2033 0 None None None 2018-06-26 18:39:14 UTC

Description Steve Milner 2018-04-06 20:40:38 UTC
Description of problem:
When SELinux is set to disabled (not permissive or enforcing) the atomic command throws a stack trace attempting to install a new system container.

Version-Release number of selected component (if applicable):
1.22.1

How reproducible:
When SELinux is disabled, every time.

Steps to Reproduce:
1. Fully disable SELinux
2. Restart the machine
3. atomic install --system --system-package=no registry.access.redhat.com/rhel7/etcd

Actual results:
Traceback (most recent call last):
  File "/usr/bin/atomic", line 185, in <module>
    sys.exit(_func())
  File "/usr/lib/python2.7/site-packages/Atomic/install.py", line 134, in install
    return be.install(self.image, self.name)
  File "/usr/lib/python2.7/site-packages/Atomic/backends/_ostree.py", line 128, in install
    return self.syscontainers.install(image, name)
  File "/usr/lib/python2.7/site-packages/Atomic/syscontainers.py", line 578, in install
    return_value = self._install(image, name)
  File "/usr/lib/python2.7/site-packages/Atomic/syscontainers.py", line 706, in _install
    self._checkout_wrapper(repo, name, image, 0, SystemContainers.CHECKOUT_MODE_INSTALL, values=values, remote=self.args.remote, system_package=self.args.system_package)
  File "/usr/lib/python2.7/site-packages/Atomic/syscontainers.py", line 817, in _checkout_wrapper
    return self._checkout(repo, options)
  File "/usr/lib/python2.7/site-packages/Atomic/syscontainers.py", line 848, in _checkout
    raise e
OSError: [Errno 22] Invalid argument


Expected results:
Successful installation

Additional info:
This was reported by a user on RHEL 7.4 on freenode.

A fix already exists: https://github.com/projectatomic/atomic/commit/119f1236bb08b079241b6ad64230e58fec217f26

Comment 2 Giuseppe Scrivano 2018-04-26 20:52:09 UTC
this was fixed upstream:

https://github.com/projectatomic/atomic/pull/1213

Comment 6 Edward Shen 2018-06-15 04:09:37 UTC
Tested with atomic-1.22.1-4.git1895984.el7, this issue is fixed.

Comment 8 errata-xmlrpc 2018-06-26 18:39:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2033


Note You need to log in before you can comment on or make changes to this bug.