Bug 1564736 - modify auth command fails
Summary: modify auth command fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block
Version: cns-3.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.10
Assignee: Prasanna Kumar Kalever
QA Contact: krishnaram Karthick
URL:
Whiteboard:
Depends On:
Blocks: 1568861
TreeView+ depends on / blocked
 
Reported: 2018-04-07 09:09 UTC by Prasanna Kumar Kalever
Modified: 2019-02-12 06:06 UTC (History)
4 users (show)

Fixed In Version: gluster-block-0.2.1-18.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-12 09:25:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2691 0 None None None 2018-09-12 09:26:41 UTC

Description Prasanna Kumar Kalever 2018-04-07 09:09:17 UTC
Description of problem:

$ gluster-block create test/blockX1 ring-buffer 32 192.168.124.227 1G
IQN: iqn.2016-12.org.gluster-block:50c787bd-9617-49b2-813f-4d03432c80ba
PORTAL(S): 192.168.124.227:3260
RESULT: SUCCESS

Modify AUTH Fails:

$ gluster-block modify test/blockX1 auth enable
Volume does not exist
RESULT:FAIL

But Modify SIZE succeeds:

$ gluster-block modify test/blockX1 size 2G
IQN: iqn.2016-12.org.gluster-block:50c787bd-9617-49b2-813f-4d03432c80ba
SIZE: 2.0 GiB
SUCCESSFUL ON: 192.168.124.227
RESULT: SUCCESS

We will have to fix modify auth cli command args parsing                        

this is a regression introduced by:
                                                             
commit cfa7677b1ee064978aa8222928ce05e2ba48e225
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Wed Mar 21 16:28:15 2018 +0530

    gluster-block: add resize support

Comment 2 Prasanna Kumar Kalever 2018-04-07 09:11:30 UTC
PR: (posted upstream)
https://github.com/gluster/gluster-block/pull/72

Comment 9 errata-xmlrpc 2018-09-12 09:25:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2691


Note You need to log in before you can comment on or make changes to this bug.