Bug 156475 - Eclipse help launches Mozilla instead of default browser Firefox
Eclipse help launches Mozilla instead of default browser Firefox
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: eclipse-bugs
:
: 157136 157998 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-30 19:30 EDT by Ricky Ng-Adam
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 10:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 93912 None None None Never

  None (edit)
Description Ricky Ng-Adam 2005-04-30 19:30:11 EDT
Description of problem:

Accessing Eclipse help launches Mozilla instead of default browser Firefox. I
didn't even realize Mozilla was installed until this as it does not appear in
the menus...

Version-Release number of selected component (if applicable):

3.1.0_fc-0.M6.12

How reproducible:

always

Steps to Reproduce:
1. launch help
2.
3.
  
Actual results:

help appears in Mozilla browser, compounding low memory problems using Eclipse...

Expected results:

help appears in Firefox browser

Additional info:
Comment 1 Andrew Overholt 2005-05-01 12:42:03 EDT
You need to tell it to explicitly use Firefox:  Window->Preferences->Help.

Perhaps we can look into making firefox the default but I'd rather stay with
upstream's default.

Closing NOTABUG.
Comment 2 Ricky Ng-Adam 2005-05-01 13:12:30 EDT
Shouldn't this be WONTFIX or even better DEFERRED? For me, it is definitely a
bug; it is clear that the flagship web browser for Fedora Core is Firefox as
Mozilla does not even appear in the GNOME menus.

There is the expectation that preferences can be set system-wide for filetype ->
default apps and every applications (GNOME, KDE or Java) should use these
preferences instead of hardcoding them in each application. This is what Desktop
-> Preferences -> More Preferences -> Preferred Applications is for after all...

This is already broken in Linux as can be seen in
http://kb.mozillazine.org/Setting_Your_Default_Browser; changing default browser
is the most complex in Linux.  No need to make it more complex under a GNOME
desktop by adding extra configuration in Java applications too!

Also, what happens when Fedora gets definitely rids of Mozilla in the default
install (which on my system, only yelp depends on at the moment)?
Comment 3 Andrew Overholt 2005-05-02 12:21:26 EDT
Okay, let's re-open this and look into making Firefox the default browser.

I don't think we'll get it to the point where we can expect the GNOME or KDE
preferences to trickle down to Eclipse (without some hacks), but maybe we can
set Firefox as the default.

As for when mozilla goes away, we'll cross that bridge when we come to it ;)
Comment 4 Ricky Ng-Adam 2005-05-02 13:21:32 EDT
I did open bug #156563 to ask for removal of Mozilla since only yelp seems to
depend on it.
Comment 5 Phil Anderson 2005-05-06 09:57:27 EDT
Doesn't RedHat & Fedora use /usr/bin/htmlview to launch the users prefered web
browser?  I thought apps, etc were being changed to use that program instead of
hard coded references to mozilla, firefox, konquer, etc.
Comment 6 Andrew Overholt 2005-05-09 10:22:28 EDT
This is an upstream issue and I've made a reference below to the Eclipse bug #.
Comment 7 Andrew Overholt 2005-05-09 10:22:37 EDT
*** Bug 157136 has been marked as a duplicate of this bug. ***
Comment 8 Andrew Overholt 2005-05-17 14:27:32 EDT
*** Bug 157998 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.