Bug 1564774 - [ironic] Fetching necessary kernel and ramdisk missing validation
Summary: [ironic] Fetching necessary kernel and ramdisk missing validation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: z2
: 13.0 (Queens)
Assignee: RHOS Maint
QA Contact: bjacot
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-07 18:38 UTC by Marc Methot
Modified: 2018-09-17 13:16 UTC (History)
7 users (show)

Fixed In Version: openstack-ironic-10.1.3-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 16:32:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
ironic-conductor.log followed one req (13.50 KB, text/plain)
2018-04-07 18:38 UTC, Marc Methot
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack Storyboard 2001797 None None None 2018-04-07 18:38:13 UTC
OpenStack gerrit 564515 None stable/queens: MERGED ironic: Implement a function to check the image status (Ib261401ab5681fd8ba1a91252a5bed51ec73c757) 2018-07-19 01:38:31 UTC
Red Hat Product Errata RHBA-2018:2593 None None None 2018-08-29 16:32:53 UTC

Description Marc Methot 2018-04-07 18:38:13 UTC
Created attachment 1418640 [details]
ironic-conductor.log followed one req

Missing image data if the image is in queued state, and will lead to failure a ways down the road. The ERROR message was not very helpful at that point.

When the ERROR does indeed show up, it's not on what is actually the problem.

2018-04-05 20:55:05.580 25826 ERROR ironic.conductor.manager [req-c9fac81a-abc3-420d-9154-117942a4bdf6 44c21dbd81ad43aaaa8a5f89517484aa 1de23097da384f6180aa7664416a785c - default default] Error while preparing to deploy to node b4ebad15-7890-4737-b3ff-1558e58fa320: unsupported operand type(s) for +: 'int' and 'NoneType'

Reproducing it, without forcing it in the DB directly, seems to be doable if rmq or something fails to receive the "delete" glance action.
https://docs.openstack.org/glance/pike/user/statuses.html


Expected results:
Something like - "ERROR ironic.common.glance_service.base_image_service [req-c9fac81a-abc3-420d-9154-117942a4bdf6 44c21dbd81ad43aaaa8a5f89517484aa 1de23097da384f6180aa7664416a785c - default default] Image $image_id is unacceptable: The image status requires to be active."

I took a stab at submitting upstream a possible fix.
https://storyboard.openstack.org/#!/story/2001797
https://review.openstack.org/#/c/559500/
** Not sure I commited it properly, I can amend it if that's the case.

Actual results:
Check attachment "ironic-req-full.txt"
This was gathered by `fgrep req-c9fac81a-abc3-420d-9154-117942a4bdf6 /var/log/ironic/ironic-conductor.log`


Cheers,
MM

Comment 1 Bob Fournier 2018-04-17 11:21:54 UTC
Marc - nice find and fix. Would it be possible to Cherry-pick the fix upstream to Queens so that we can get this in OSP-13?

Comment 2 Bob Fournier 2018-04-26 13:59:55 UTC
Backported change to stable/queens.

Comment 11 bjacot 2018-08-07 19:02:08 UTC
Install OSP13 

cat /etc/yum.repos.d/latest-installed 
13   -p 2018-07-30.2

Verified that Gerrit commited changes are included in this release.  Please reopen if this change is still preset.

Comment 12 Joanne O'Flynn 2018-08-15 13:50:04 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 14 errata-xmlrpc 2018-08-29 16:32:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2593


Note You need to log in before you can comment on or make changes to this bug.