Bug 1564776 - Enable dnstap in bind
Summary: Enable dnstap in bind
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: rawhide
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-07 19:29 UTC by Serge Droz
Modified: 2019-03-14 19:00 UTC (History)
8 users (show)

Fixed In Version: bind-9.11.5-13.P4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-14 19:00:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Serge Droz 2018-04-07 19:29:11 UTC
Description of problem: bind 9.11 has support for dnstap http://dnstap.info/ which useful, if you want to run eg  a passive DNS service.
Currently this is not enabled. It would be desireable to enable this feature, possibly through a config option in the spec file. 

Version-Release number of selected component (if applicable):

9.11.x

How reproducible:

It's not there (The config file does not contain --dnstap)

Comment 1 Petr Menšík 2018-11-05 17:10:25 UTC
I played with it, all dependencies are already there. I put experimental commits to my beta fork branch [1]. But it does one thing that prevented me pushing it into master. It adds new dependencies not only to named service, but also to all tools and libraries used. I am not sure whether we want such thing. bind-utils would require protobuf library this way.

We want dnstap inside, but I would like to find a way to include it just in server.

1. https://src.fedoraproject.org/fork/pemensik/rpms/bind/commits/master-beta

Comment 2 Petr Menšík 2018-11-05 17:53:45 UTC
It is implemented that way on Debian, also utils depends on protobuf-c library. It is done so since buster, not yet in stable [1].

1. https://packages.debian.org/buster/bind9

Comment 3 Petr Menšík 2018-11-05 17:56:49 UTC
Pushed support for it into current master, but it has to be enabled when compiling. If someone wants to build his own package with its support:

fedpkg clone --anonymous bind
cd bind
fedpkg [--release f28] mockbuild --with DNSTAP

Comment 4 Petr Menšík 2019-03-14 19:00:39 UTC
Forgot to change bug status. Enabled it in Fedora 30 and more recent. Because new dependencies not enabling it in Fedora 29 and earlier.


Note You need to log in before you can comment on or make changes to this bug.