Bug 1564792 - "unexpected command 16 error" booting Fedora-Minimal-28 on aarch64
Summary: "unexpected command 16 error" booting Fedora-Minimal-28 on aarch64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 28
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-07 22:43 UTC by John Reiser
Modified: 2018-04-17 02:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-17 02:25:05 UTC
Type: Bug


Attachments (Terms of Use)

Description John Reiser 2018-04-07 22:43:35 UTC
Description of problem: Booting Fedora-Minimal-28-20180407.n.0.aarch64.raw.xz on RaspberryPi-3B fails to load the kernel from uSDHC, and after a while begins attempting to boot over ethernet via PXE.


Version-Release number of selected component (if applicable):
Fedora-Minimal-28-20180407.n.0.aarch64.raw.xz

How reproducible: every time (2 out of 2 so far)


Steps to Reproduce:
1.xzcat Fedora-Minimal-28-20180407.n.0.aarch64.raw.xz  > /dev/sdX
2.boot via uSDHC on RaspberryPi-3B
3.

Actual results:
Normal uboot prompts on VGA console (3 seconds), then about 22 seconds of rapid scrolling:
  .../bcm2035_sdhost.c:437/bcm2035_send_command()!
  unexpected command 16 error
     <<the above 2 lines appear 6 times total>>
  ** Can't read partition table on 0:0 **
  <<the above 13 lines (6*2 + 1) are repeated rapidly many times>>
then at about 25 seconds elapsed from power-on, attempt to boot over the network using PXE.


Expected results: normal boot from uSDHC.


Additional info: 32-bit ARM does boot from uSDHC (Fedora-Minimal-armhfp-28-20180407.n.0-sda.raw.xz)

Comment 1 John Reiser 2018-04-11 02:52:30 UTC
Fedora-Minimal-28-20180410.n.1.aarch64.raw.xz still fails the same way.

Comment 2 John Reiser 2018-04-17 02:25:05 UTC
Fedora-Minimal-28-20180415.n.0.aarch64.raw.xz gets beyond this stage.  The uboot "select a kernel" line appears and is selected automatically after a few seconds.  VGA console text begins to scroll after another 1/2 minute or so, then after several more seconds video sync is not detected, similar to bug #1563421 on 32-bit ARM.  I Close this bug because the symptom went away.


Note You need to log in before you can comment on or make changes to this bug.