Bug 1564818 - VNX Cinder Driver get error when run case test_force_detach_volume [NEEDINFO]
Summary: VNX Cinder Driver get error when run case test_force_detach_volume
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 12.0 (Pike)
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: z3
: 12.0 (Pike)
Assignee: Jon Bernard
QA Contact: Avi Avraham
Kim Nylander
URL:
Whiteboard:
Depends On:
Blocks: 1516324 1394885
TreeView+ depends on / blocked
 
Reported: 2018-04-08 02:39 UTC by Zhimou Peng
Modified: 2018-08-20 12:47 UTC (History)
10 users (show)

Fixed In Version: openstack-cinder-11.1.0-11.el7ost
Doc Type: Bug Fix
Doc Text:
This patch adds force-detach to the Cinder VNX driver.
Clone Of:
Environment:
Last Closed: 2018-08-20 12:46:46 UTC
Target Upstream Version:
tshefi: automate_bug-
smerrow: needinfo? (zhimou.peng)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2516 0 None None None 2018-08-20 12:47:54 UTC

Description Zhimou Peng 2018-04-08 02:39:59 UTC
Description of problem:

Hi,
we found this exception when run force_detach case:

Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager [None req-9735f9f1-0fe9-4c0d-9e74-27943af08986 tempest-VolumesActionsTest-1258472487 None] Terminate volume connection failed: argument of type 'NoneType' is not iterable: TypeError: argument of type 'NoneType' is not iterable
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager Traceback (most recent call last):
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager File "/opt/stack/new/cinder/cinder/volume/manager.py", line 1799, in terminate_connection
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager force=force)
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager File "/opt/stack/new/cinder/cinder/zonemanager/utils.py", line 104, in decorator
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager conn_info = terminate_connection(self, *args, **kwargs)
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager File "/opt/stack/new/cinder/cinder/volume/drivers/dell_emc/vnx/driver.py", line 214, in terminate_connection
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager conn_info = self.adapter.terminate_connection(volume, connector)
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager File "/opt/stack/new/cinder/cinder/volume/drivers/dell_emc/vnx/adapter.py", line 1003, in terminate_connection
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager return self._terminate_connection(volume, connector)
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager File "/opt/stack/new/cinder/cinder/volume/drivers/dell_emc/vnx/adapter.py", line 1013, in _terminate_connection
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager host = self.build_host(connector)
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager File "/opt/stack/new/cinder/cinder/volume/drivers/dell_emc/vnx/adapter.py", line 1368, in build_host
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager if 'wwnns' not in connector or 'wwpns' not in connector:
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager TypeError: argument of type 'NoneType' is not iterable
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR cinder.volume.manager
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server [None req-9735f9f1-0fe9-4c0d-9e74-27943af08986 tempest-VolumesActionsTest-1258472487 None] Exception during message handling: VolumeBackendAPIException: Bad or unexpected response from the storage volume backend API: Terminate volume connection failed: argument of type 'NoneType' is not iterable
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server Traceback (most recent call last):
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server File "/usr/local/lib/python2.7/dist-packages/oslo_messaging/rpc/server.py", line 163, in _process_incoming
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server res = self.dispatcher.dispatch(message)
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server File "/usr/local/lib/python2.7/dist-packages/oslo_messaging/rpc/dispatcher.py", line 220, in dispatch
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server return self._do_dispatch(endpoint, method, ctxt, args)
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server File "/usr/local/lib/python2.7/dist-packages/oslo_messaging/rpc/dispatcher.py", line 190, in _do_dispatch
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server result = func(ctxt, **new_args)
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server File "/opt/stack/new/cinder/cinder/volume/manager.py", line 1804, in terminate_connection
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server raise exception.VolumeBackendAPIException(data=err_msg)
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server VolumeBackendAPIException: Bad or unexpected response from the storage volume backend API: Terminate volume connection failed: argument of type 'NoneType' is not iterable
Jan 08 02:06:30 cdh2h14 cinder-volume[26522]: ERROR oslo_messaging.rpc.server

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

We have fixed this on pike release,
https://review.openstack.org/#/c/551832/

Please help to update this patch to OSP12, thanks!

Comment 2 Alan Bishop 2018-04-30 19:57:50 UTC
Patch is in the process of being backported to OSP-12.

Comment 8 Sean Merrow 2018-07-02 13:30:30 UTC
Ready for Dell EMC to perform QA on with openstack-cinder-11.1.0-11.el7ost or later.

Let me know if you need assistance in getting this package.

Comment 10 errata-xmlrpc 2018-08-20 12:46:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2516


Note You need to log in before you can comment on or make changes to this bug.