Bug 1564845 - “Red Hat Container Registry” brand shows two times on navbar
Summary: “Red Hat Container Registry” brand shows two times on navbar
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Registry Console
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.11.z
Assignee: Martin Pitt
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-08 08:09 UTC by Yanping Zhang
Modified: 2020-05-13 18:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2020-05-13 18:07:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yanping Zhang 2018-04-08 08:09:50 UTC
Description of problem:
“Red Hat Container Registry” brand shows two times on navbar

Version-Release number of selected component (if applicable):
openshift v3.9.19
kubernetes v1.9.1+a0ce1bc657
etcd 3.2.16

cockpit-bridge-160-3.el7.x86_64
cockpit-kubernetes-160-3.el7.x86_64
cockpit-ws-160-3.el7.x86_64
cockpit-dashboard-160-3.el7.x86_64
cockpit-system-160-3.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.Login registry console, check navbar
2.
3.

Actual results:
1.“Red Hat Container Registry” brand shows two times

Expected results:
1.Should show one time only.

Additional info:

Comment 1 Martin Pitt 2018-06-22 17:39:10 UTC
As I don't see this on the clusters/deployments I have access to: Do you have a screenshot of this? This might allow us to draw some conclusions what happens. Could you provide access for us to an affected deployment? Thanks!

Comment 2 Yanping Zhang 2018-06-25 02:59:31 UTC
I met this issue several times on ocp 3.9 env, but now it works normal on the latest 3.9 env with version v3.9.31.
Pls move the bug to ON_QA, let me verify it.

Comment 3 Martin Pitt 2018-06-25 06:23:05 UTC
Ack, thanks. Changing accordingly.

Comment 4 Yanping Zhang 2018-06-25 06:54:19 UTC
Checked on OCP v3.9.31 and OCP v3.10.6, “Red Hat Container Registry” brand shows once on navbar, so move the bug to Verified.

Comment 5 Yanping Zhang 2018-07-26 08:33:31 UTC
@martin, I meet this issue again on ocp 3.9 and ocp 3.11. I found it reproduced when cockpit packages are:
# oc rsh registry-console-1-w9ffq rpm -qa|grep cockpit
cockpit-ws-160-3.el7.x86_64
cockpit-dashboard-169-1.el7.x86_64
cockpit-system-160-3.el7.noarch
cockpit-bridge-160-3.el7.x86_64
cockpit-kubernetes-160-3.el7.x86_64

And it doesn't reproduce when cockpit versions are:
# oc rsh registry-console-1-28fbf rpm -qa|grep cockpit
cockpit-bridge-154-3.el7.x86_64
cockpit-kubernetes-160-3.el7.x86_64
cockpit-ws-154-3.el7.x86_64
cockpit-dashboard-169-1.el7.x86_64
cockpit-system-154-3.el7.noarch

Compared the version, it should be one of the three packages causing the issue: cockpit-ws-160-3.el7.x86_64,cockpit-system-160-3.el7.noarch,cockpit-bridge-160-3.el7.x86_64

Comment 9 Martin Pitt 2020-05-13 18:07:27 UTC
Minor feature/bug, not relevant any more for current OpenShift, and this product is in low-maintenance mode. I couldn't reproduce this either.


Note You need to log in before you can comment on or make changes to this bug.