Bug 1564849 - Command in warning message is incomplete
Summary: Command in warning message is incomplete
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Maciej Szulik
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-08 09:28 UTC by Wenjing Zheng
Modified: 2019-06-04 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:28 UTC

Description Wenjing Zheng 2018-04-08 09:28:47 UTC
Description of problem:
Command in warning message is incomplete like below:
* WARNING: The Dockerfile has some invalid ports in EXPOSE instruction: [failed to parse port /tcp: [port number must be in range 0 - 65535]]
    * The image does not expose any ports - if you want to load balance or send traffic to this component
      you will need to create a service with 'expose dc/ocnewappexpose --port=[port]' later

Version-Release number of selected component (if applicable):
oc v3.10.0-0.16.0

How reproducible:
always

Steps to Reproduce:
1.Define incorrect port in Dockerfile
2.Build with it
3.

Actual results:
Command in warning is like below:
expose dc/ocnewappexpose --port=[port]

Expected results:
It should be oc expose dc/ocnewappexpose --port=[port]

Additional info:

Comment 2 Maciej Szulik 2019-03-01 21:22:01 UTC
Fix in https://github.com/openshift/origin/pull/22212

Comment 3 Wenjing Zheng 2019-04-03 10:03:25 UTC
Verified with below version:
Client Version: v4.0.22
Server Version: v1.12.4+0ba401e

* WARNING: The Dockerfile has some invalid ports in EXPOSE instruction: [failed to parse port /tcp: [port number must be in range 0 - 65535]]
    * The image does not expose any ports - if you want to load balance or send traffic to this component
      you will need to create a service with 'oc expose dc/ocnewappexpose --port=[port]' later

Comment 5 errata-xmlrpc 2019-06-04 10:40:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.