Bug 1564851 - [online-stg][registration]Failure in inviting an account who has no subscription plan as a collaborator
Summary: [online-stg][registration]Failure in inviting an account who has no subscript...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Accounts and Billing
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Mike Dame
QA Contact: yufchang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-08 09:36 UTC by yufchang
Modified: 2018-06-18 16:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-18 16:10:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
pending (112.53 KB, image/png)
2018-04-08 09:36 UTC, yufchang
no flags Details

Description yufchang 2018-04-08 09:36:02 UTC
Created attachment 1418834 [details]
pending

Description of problem:
Prepare an account who has already signed up plan on online-stg,eg userA
Prepare a RH account who has not signed up plan on online-stg,eg userB
According to registration collaborator workflow, User A invites UserB as a collaborator.
Login registration by user B , user B's collaborator plan is pending in Queued for provisioning

Version-Release number of selected component (if applicable):
manage.stg.openshift.com

How reproducible:
always

Steps to Reproduce:
1.Prepare an account who has already signed up plan on online-stg,eg userA
2.Prepare a RH account who has not signed up plan on online-stg,eg userB
3.User A adds userB in "Collaborator manage" on registration
4.Create a project proA by userA
5.oc policy add-role-to-user edit userB
5.loging registration by userB

Actual results:
5.UserB's collaborator plan is still in pending 'in Queued for provisioning', userB can not access openshift webconsole unless signing a plan.

Expected results:
As a collaborator, UserB can enter openshift web console and access proA without signing up a plan

Additional info:
on online-stg1, works well

Comment 1 Mike Dame 2018-05-30 19:20:24 UTC
Is this still an issue? Trying with new accounts on online-stg and didn't have any problems

Comment 2 Mike Dame 2018-05-30 19:22:41 UTC
Actually seeing a problem where when I remove the userB as a collaborator, userB still has a card with access to the web console (they shouldn't because they don't have any other subscriptions)

If you can confirm that, can you please open a Bugzilla for it?


Note You need to log in before you can comment on or make changes to this bug.