Bug 1564915 - clamscan no longer running on Fedora updates
Summary: clamscan no longer running on Fedora updates
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmgrill
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ed Santiago
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-08 22:19 UTC by "FeRD" (Frank Dana)
Modified: 2018-08-20 13:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-20 13:00:47 UTC
Type: Bug


Attachments (Terms of Use)

Description "FeRD" (Frank Dana) 2018-04-08 22:19:18 UTC
I happened to look at the taskotron output of a few recent package builds, and I noticed that the dist.rpmgrill.virus-check scan is no longer being run due to a missing clamscan executable.

e.g., the ampache_browser update built yesterday:
https://bodhi.fedoraproject.org/updates/FEDORA-2018-59674a8e05

which has this taskotron output:
https://taskotron.fedoraproject.org/artifacts/all/b7894b90-3abe-11e8-bdec-525400fc9f92/tests.yml/rpmgrill.json

that includes the following:
========
   "tests" : [
      {
         "failure_code" : "Command 'clamscan' not found in /usr/bin, /bin at /usr/share/perl5/vendor_perl/RPM/Grill/Plugin/VirusCheck.pm line 73.\n",
         "module" : "VirusCheck",
         "order" : 2,
         "results" : [],
         "run_time" : 0,
         "status" : "failed"
      },
========

The test is marked as Passed by bodhi, which I thought was a little odd. (I've filed an issue about that separately, which is here: https://github.com/fedora-infra/bodhi/issues/2265 ) 

Bug 1477130 seems to indicate that virus scans were working 8 months ago, but they've been broken for at least the past month. Before determining that this is still an issue with recent builds, the update where I first noticed it was this selinux-policy build from 2018-03-07: https://bodhi.fedoraproject.org/updates/selinux-policy-3.13.1-283.28.fc27

Comment 1 Roman Joost 2018-04-08 23:31:42 UTC
Dear Frank,

thanks for your bug report. I think this ties into Bug 1477130 and Bug 1477777. It seems none of the solutions seem good at this point. Certainly not one which I'd bee keen on maintaining.

Comment 2 Adam Williamson 2018-05-25 20:48:36 UTC
For the record, I think the cause of this particular problem wasn't really much to do with 1477130 or 1477777, it was the mistaken spec file change that reached Fedora in 0.32-2 on 2018-02-01, that we fixed recently:

https://github.com/default-to-open/rpmgrill/commit/d99b3207b97ece4f6835834f4c73bd73e47c7c35
https://src.fedoraproject.org/rpms/rpmgrill/c/3516c229b01c7c6c1ea65362f9215347784aac81?branch=master

I've sent out Koji builds with the fix, but I actually wound up sending fixes for a couple other issues that Roman was kind enough to merge, and now I think the plan is for Roman to cut a 0.33 release upstream that would bundle up all the changes; at that point we can send out 0.33 package builds and updates for Fedora which will contain all the fixes and also be in sync with the spec file stored upstream.

Comment 3 Jan Kurik 2018-08-14 10:07:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 4 "FeRD" (Frank Dana) 2018-08-20 13:00:47 UTC
It looks like the dist.rpmgrill.virus-check test is executing successfully for Fedora updates again, so closing this as fixed.


Note You need to log in before you can comment on or make changes to this bug.