Bug 1564947 - Regression: get "UNKNOWN" by "service-catalog --version"
Summary: Regression: get "UNKNOWN" by "service-catalog --version"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Jeff Peeler
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 02:17 UTC by Zhang Cheng
Modified: 2018-07-30 19:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:12:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:12:47 UTC

Comment 2 Zhang Cheng 2018-04-12 01:48:13 UTC
@Jeff,

The current fix as below, version of service-catalog is using image tag. Is it intended? Why not keep to use SC self record to trace as usual? Such as: v0.1.14

# docker run --entrypoint=service-catalog brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/ose-service-catalog:v3.10.0-0.20.0.0 --version
v3.10.0-0.20.0

Comment 3 Jeff Peeler 2018-04-12 14:37:29 UTC
It is intended. I understand that it's not ideal and am working on trying to figure out a way to make it known what upstream version of catalog has been built for OCP.

Comment 4 Jeff Peeler 2018-04-12 18:42:42 UTC
I added additional version information that includes both the git tag and the upstream version. Should be in the next rebuild.

Comment 5 Zhang Cheng 2018-04-13 02:10:36 UTC
@Jeff, that is great! The upstream is very important for QE and user. Thanks.

Comment 6 Zhang Cheng 2018-04-13 09:55:12 UTC
Changing status to ON_QA since downstream image is ready for test.

Comment 7 Zhang Cheng 2018-04-13 09:55:45 UTC
Verified and thanks.

# service-catalog --version
v3.10.0-0.21.0;Upstream:v0.1.13

Comment 8 Jeff Peeler 2018-04-13 13:07:58 UTC
Unsure if this will satisfy the PR checker with the bug tracker bot:

Fixed in:
https://github.com/openshift/service-catalog/commit/6338d88f9725ecf5755737de6c46f2008a4f4733

Comment 10 errata-xmlrpc 2018-07-30 19:12:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.