Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1565002 - Check vdsmd status before starting rpm upgrade
Summary: Check vdsmd status before starting rpm upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: Packaging.rpm
Version: 4.20.23
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Martin Perina
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 06:38 UTC by Yaniv Bronhaim
Modified: 2018-06-26 08:39 UTC (History)
3 users (show)

Fixed In Version: vdsm-4.20.28-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:39:19 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 89446 0 master MERGED Checking if vdsmd status was up before starting upgrade 2018-04-27 07:50:33 UTC
oVirt gerrit 90712 0 ovirt-4.2 MERGED Checking if vdsmd status was up before starting upgrade 2018-05-09 12:49:56 UTC

Description Yaniv Bronhaim 2018-04-09 06:38:13 UTC
Description of problem:
In bug #1557735 we recognized case where vdsmd is being restarted during upgrade and fails to start. We are not sure exactly if this flow is right or wrong, but in case it happens vdsmd stays down after upgrade. In this bugzilla we add logic to remember vdsmd status before starting the upgrade and re-establish same state after upgrade is done. 
This change is done as part of the rpm spec and related to vdsm packaging.

Version-Release number of selected component (if applicable):
v4.20.23

Actual results:
Vdsm stays with same status after upgrade (stopped or started)

Additional info:
This flow requires verification for upgrades scenarios to latest vdsm build

Comment 1 Yaniv Kaul 2018-04-10 13:57:13 UTC
Severity?

Comment 2 Yaniv Bronhaim 2018-04-15 09:03:41 UTC
We don't have regressions so far. It will be critical if vdsm introduces new config values, but as far as 4.2 we don't have it between recent versions.

Comment 4 Pavol Brilla 2018-06-25 19:46:47 UTC
3.6 -> 4.2.4  upgrade OK

4.1 -> 4.2.4 upgrade OK

( tested with stopped and also with started vdsm - status was OK in both cases )

Comment 5 Sandro Bonazzola 2018-06-26 08:39:19 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.