Bug 1565028 - [Infra] Missing Readme about moving opendaylight logs to docker logs
Summary: [Infra] Missing Readme about moving opendaylight logs to docker logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z2
: 13.0 (Queens)
Assignee: Janki
QA Contact: Tomas Jamrisko
URL:
Whiteboard: Infra
Depends On:
Blocks: 1566157
TreeView+ depends on / blocked
 
Reported: 2018-04-09 08:00 UTC by Itzik Brown
Modified: 2018-12-24 11:40 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.3-2.el7ost
Doc Type: Release Note
Doc Text:
README has been added to /var/log/opendaylight, stating the correct OpenDaylight log path.
Clone Of:
Environment:
N/A
Last Closed: 2018-08-29 16:35:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 563819 0 None master: MERGED tripleo-heat-templates: Add /var/log/opendaylight directory to ODL (Id8128ad123b07f5e78eefef407606efedab12aa7) 2018-07-19 14:52:27 UTC
OpenStack gerrit 565756 0 None stable/queens: MERGED tripleo-heat-templates: Add /var/log/opendaylight directory to ODL (Id8128ad123b07f5e78eefef407606efedab12aa7) 2018-07-19 14:52:21 UTC
Red Hat Product Errata RHBA-2018:2574 0 None None None 2018-08-29 16:36:16 UTC

Description Itzik Brown 2018-04-09 08:00:42 UTC
Description of problem:
Recently opendaylight logs moved from /var/log/containers/opendaylight to using 
docker logs opendaylight_api command.
There should be a readme file under /var/log/containers/opendaylight documenting the move.
It should be also documented in the Product documentation.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. Verify there is no readme file for opendaylight under  /var/log/containers/opendaylight
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Sandra McCann 2018-04-11 16:03:41 UTC
Created doc bug to ensure this change is captured for OSP 13 ODL guide.

Comment 3 Mike Kolesnik 2018-04-16 06:50:53 UTC
Janki, any progress on this?

Comment 4 Janki 2018-04-16 07:23:04 UTC
I think better place to have this readme is at /var/log/opendaylight rather than /var/log/containers/opendaylight as anybody new to the setup will look at this location first. Also all other services have readme at this location with content (example heat)

"Log files from heat containers can be found under /var/log/containers/heat and /var/log/containers/httpd/heat-api*."

Comment 6 Mike Kolesnik 2018-05-06 07:07:10 UTC
This was cherry picked and merged to stable/queens

Comment 9 Janki 2018-06-14 15:09:42 UTC
@Itzik, I think it is safe to move this to verified now. Its been merged upstream for quite some time now.

Comment 10 Itzik Brown 2018-06-17 05:24:26 UTC
I don't see it in:
openstack-tripleo-heat-templates-8.0.2-33.el7ost.noarch

Comment 11 Janki 2018-06-18 11:15:25 UTC
@Itzik, you need an rpm with this fix:
https://review.openstack.org/#/c/565756/

Comment 12 Janki 2018-06-18 13:04:41 UTC
Please verify with openstack-tripleo-heat-templates-8.0.2-35.el7ost.noarch. It has all the changes and readme file is created in my machine running this rpm.

P.S. Itzik, adding you to this needinfo just to notify you of this comment.

Comment 15 Janki 2018-07-10 09:13:13 UTC
Steps to verify:

Make sure there is a file "/var/log/opendaylight/readme.txt" on each overcloud controller node with content

"Logs from OpenDaylight container can be found at /var/log/containers/opendaylight/karaf.log"

Comment 25 Janki 2018-08-01 11:01:38 UTC
To verify:

Ensure there is a /var/log/opendaylight/readme.txt file with content

"Logs from OpenDaylight container can be found at /var/log/containers/opendaylight/karaf.log"

Comment 26 Mike Kolesnik 2018-08-13 10:26:54 UTC
Is this still needed since bug 1597665 was fixed?

Comment 27 Janki 2018-08-13 10:36:31 UTC
Yes. This bug is about having a README file at /var/log/opendaylight/ saying where ODL logs can be found. bug 1597665 is about having actual karaf log files at /var/log/containers/opendaylight.

Comment 28 Joanne O'Flynn 2018-08-15 07:56:32 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 31 errata-xmlrpc 2018-08-29 16:35:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2574


Note You need to log in before you can comment on or make changes to this bug.