Bug 1565036 - PPC: CreateVDSCommand fails with NullPointerException for VM with sPAPR VSCSI disk attached
Summary: PPC: CreateVDSCommand fails with NullPointerException for VM with sPAPR VSCSI...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.2
Hardware: ppc64
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.2.3
: 4.2.3.2
Assignee: Sharon Gratch
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 08:29 UTC by Elad
Modified: 2018-05-10 06:30 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.2.3.2
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-05-10 06:30:26 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
engine and vdsm logs (1.32 MB, application/x-gzip)
2018-04-09 08:29 UTC, Elad
no flags Details
4.1 cluster (983.92 KB, application/x-gzip)
2018-04-10 14:19 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 90222 master MERGED core: fix SPAPR_VSCSI controller and disks issues for ppc arch 2018-04-17 10:32:44 UTC
oVirt gerrit 90379 ovirt-engine-4.2 MERGED core: fix SPAPR_VSCSI controller and disks issues for ppc arch 2018-04-17 12:46:01 UTC

Description Elad 2018-04-09 08:29:39 UTC
Created attachment 1419149 [details]
engine and vdsm logs

Description of problem:
Start a VM fails with NPE in PPC env in case the VM has a sPAPR VSCSI disk attached

Version-Release number of selected component (if applicable):
rhvm-4.2.2.6-0.1.el7.noarch
vdsm-4.20.23-1.el7ev.ppc64le
libvirt-3.9.0-14.el7_5.2.ppc64le
qemu-kvm-rhev-2.10.0-21.el7_5.1.ppc64le

How reproducible:
Always

Steps to Reproduce:
1. Create a VM and attach a sPAPR VSCSI disk to it
2. Start the VM


Actual results:
Start VM fails


2018-04-09 11:23:52,242+03 ERROR [org.ovirt.engine.core.vdsbroker.CreateVDSCommand] (EE-ManagedThreadFactory-engine-Thread-4466) [afcb7856-ce05-4907-8d05-37840c1fa871] Failed to create VM: java.lang.NullPointerE
xception
        at org.ovirt.engine.core.vdsbroker.builder.vminfo.VmInfoBuildUtils.calculateAddressForScsiDisk(VmInfoBuildUtils.java:1241) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.builder.vminfo.LibvirtVmXmlBuilder.writeDisks(LibvirtVmXmlBuilder.java:1147) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.builder.vminfo.LibvirtVmXmlBuilder.writeDevices(LibvirtVmXmlBuilder.java:967) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.builder.vminfo.LibvirtVmXmlBuilder.buildCreateVm(LibvirtVmXmlBuilder.java:237) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.CreateBrokerVDSCommand.generateDomainXml(CreateBrokerVDSCommand.java:93) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.CreateBrokerVDSCommand.createInfo(CreateBrokerVDSCommand.java:50) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.CreateBrokerVDSCommand.executeVdsBrokerCommand(CreateBrokerVDSCommand.java:42) [vdsbroker.jar:]
        at org.ovirt.engine.core.vdsbroker.vdsbroker.VdsBrokerCommand.executeVDSCommand(VdsBrokerCommand.java:112) [vdsbroker.jar:]


Expected results:
Start VM should succeed

Additional info:

Comment 1 Yaniv Kaul 2018-04-09 11:44:09 UTC
Arik, can you take a look?

Comment 2 Yaniv Kaul 2018-04-09 11:55:08 UTC
Does it work with CL 4.1?

Comment 3 Arik 2018-04-09 12:19:25 UTC
Seems related to [1].
Sharon, please check this.

[1] https://gerrit.ovirt.org/#/c/88065/

Comment 5 Elad 2018-04-10 14:19:30 UTC
Created attachment 1419909 [details]
4.1 cluster

Yaniv - The bug does reproduce on 4.1 cluster. Logs attached.

Sharon - In the engine.log attached it is the case since that's the way I've reproduced the issue. 
The bug is reproduced also with a simpler scenario of creating a VM with no disks, attach a SPAPR_VSCSI disk to it and start it.

Comment 8 Michal Skrivanek 2018-04-12 10:16:54 UTC
reducing severity because this is a pre-existing bugs no one reported for a long time

Comment 9 Red Hat Bugzilla Rules Engine 2018-04-12 10:17:00 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 10 Elad 2018-04-12 10:26:47 UTC
(In reply to Michal Skrivanek from comment #8)
> reducing severity because this is a pre-existing bugs no one reported for a
> long time

Michael, this test passed on previous 4.2 builds, the last PPC RHV automation execution that this case passed was on 4.2.2-7 from March 24.

Comment 11 Michal Skrivanek 2018-04-12 12:38:57 UTC
Ah, so Sharon asked about that earlier and the answer was indicating otherwise. Ok then

Comment 12 Red Hat Bugzilla Rules Engine 2018-04-12 12:39:03 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 13 Israel Pinto 2018-04-22 13:00:55 UTC
Verify with:
Engine: 4.2.3.2-0.1.el7
Host: 
OS Version:RHEL - 7.5 - 8.el7
Kernel Version:3.10.0 - 862.el7.ppc64le
KVM Version:2.10.0 - 21.el7_5.2
LIBVIRT Version:libvirt-3.9.0-14.el7_5.3
VDSM Version:vdsm-4.20.26-1.el7ev

Steps:
1. Create a VM and attach a sPAPR VSCSI disk to it
2. Start the VM

VM started

Comment 14 Sandro Bonazzola 2018-05-10 06:30:26 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.