Bug 1565058 - Installation failed at Update the sysconfig to group "node-config-master"
Summary: Installation failed at Update the sysconfig to group "node-config-master"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Russell Teague
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 09:32 UTC by Wenkai Shi
Modified: 2018-07-30 19:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Sysconfig location has been updated to coincide with static pods configuration.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:12:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:12:47 UTC
Red Hat Bugzilla 1567783 None CLOSED Mater node bootstrap failed if openshift_node_bootstrap is set to false 2019-06-12 18:14:53 UTC

Internal Links: 1567783

Description Wenkai Shi 2018-04-09 09:32:21 UTC
Description of problem:
Installation failed when set openshift_node_bootstrap=false

Version-Release number of the following components:
openshift-ansible-3.10.0-0.16.0.git.0.8925606.el7

How reproducible:
100%

Steps to Reproduce:
1. install OCP with openshift_node_bootstrap=false
2.
3.

Actual results:
ansible-playbook -i hosts -v /usr/share/ansible/openshift-ansible/playbooks/deploy_cluster.yml
...
TASK [openshift_node_group : Update the sysconfig to group "node-config-master"] ***
Monday 09 April 2018  03:29:02 -0400 (0:00:00.675)       0:03:02.686 ********** 

failed: [qe-weshi.example.com] (item={u'regexp': u'^BOOTSTRAP_CONFIG_NAME=.*', u'line': u'BOOTSTRAP_CONFIG_NAME=node-config-master'}) => {"changed": false, "failed": true, "item": {"line": "BOOTSTRAP_CONFIG_NAME=node-config-master", "regexp": "^BOOTSTRAP_CONFIG_NAME=.*"}, "msg": "Destination /etc/sysconfig/atomic-openshift-node does not exist !", "rc": 257}
...

Expected results:
Should pass this task

Additional info:

Comment 1 Scott Dodson 2018-04-19 13:16:02 UTC
Clayton,

Can we remove openshift_node_bootstrap=false ?

Comment 2 Russell Teague 2018-04-19 19:13:03 UTC
The issue noted by the failure in the 'Actual Results' above was fixed by
https://github.com/openshift/openshift-ansible/pull/7723
and was in build openshift-ansible-3.10.0-0.20.0.  The problem of installing with "openshift_node_bootstrap=false" is being tracked in 1567783.

Comment 3 Wenkai Shi 2018-04-20 02:27:44 UTC
According to BZ #1567783(openshift-ansible-3.10.0-0.21) , confirmed that this issue have been solved in openshift-ansible-3.10.0-0.20.0.

Comment 5 errata-xmlrpc 2018-07-30 19:12:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.