Bug 1565060 - Fix a deprecation warning from ansible on Hosted-Engine deployment
Summary: Fix a deprecation warning from ansible on Hosted-Engine deployment
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.16
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.2.3
: ---
Assignee: Ido Rosenzwig
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1458709
TreeView+ depends on / blocked
 
Reported: 2018-04-09 09:46 UTC by Ido Rosenzwig
Modified: 2018-05-10 06:31 UTC (History)
4 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.17-1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:31:05 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
ylavi: exception+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90009 0 master MERGED Ansible setup: Fix a deprecated feature 2020-01-24 11:28:06 UTC
oVirt gerrit 90010 0 ovirt-hosted-engine-setup-2.2 MERGED Ansible setup: Fix a deprecated feature 2020-01-24 11:28:06 UTC

Description Ido Rosenzwig 2018-04-09 09:46:02 UTC
Description of problem:
Ansible deprecation warnings are presented to the user while installing Hosted-engine.

[ INFO  ] TASK [Remove host-deploy configuration file]
[ INFO  ] changed: [localhost]
[ ERROR ] [DEPRECATION WARNING]: Using tests as filters is deprecated. Instead of using 
         
[ ERROR ] `result|succeeded` instead use `result is succeeded`. This feature will be 
         
[ ERROR ] removed in version 2.9. Deprecation warnings can be disabled by setting 
         
[ ERROR ] deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: Using tests as filters is deprecated. Instead of using 
         
[ ERROR ] `result|succeeded` instead use `result is succeeded`. This feature will be 
         
[ ERROR ] removed in version 2.9. Deprecation warnings can be disabled by setting 
         
[ ERROR ] deprecation_warnings=False in ansible.cfg.
         
[ ERROR ] [DEPRECATION WARNING]: Using tests as filters is deprecated. Instead of using 
         
[ ERROR ] `result|succeeded` instead use `result is succeeded`. This feature will be 
         
[ ERROR ] removed in version 2.9. Deprecation warnings can be disabled by setting 
         
[ ERROR ] deprecation_warnings=False in ansible.cfg.
         
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]:



How reproducible:
100%

Steps to Reproduce:
1. run hosted-engine --deploy with default answers


Actual results:
deprecation warnings are shown as Errors

Expected results:
no Ansible warnings should appear

Additional info:

Comment 1 Yaniv Kaul 2018-04-09 12:21:10 UTC
We need another BZ to fix those deprecated items.

Comment 2 Ido Rosenzwig 2018-04-09 14:34:14 UTC
On the other hand, we do want to view those warnings and handle them when they appear.

Comment 3 Nikolai Sednev 2018-04-22 14:30:19 UTC
Works for me on these components:
ovirt-hosted-engine-setup-2.2.18-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.10-1.el7ev.noarch
rhvm-appliance-4.2-20180420.0.el7.noarch
Linux 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)

Comment 4 Sandro Bonazzola 2018-05-10 06:31:05 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.