Bug 1565062 - Please enable the "xorg-x11-drv-libinput" and/or "xorg-x11-drv-evdev" package for s390x, too
Summary: Please enable the "xorg-x11-drv-libinput" and/or "xorg-x11-drv-evdev" package...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-libinput
Version: 27
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1565067 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 09:48 UTC by Thomas Huth
Modified: 2018-07-18 18:30 UTC (History)
12 users (show)

Fixed In Version: xorg-x11-drv-libinput-0.27.1-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1565067 (view as bug list)
Environment:
Last Closed: 2018-04-17 00:17:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas Huth 2018-04-09 09:48:12 UTC
Description of problem:
Recent versions of QEMU provide a virtual graphic card called "virtio-gpu-ccw" and virtual input devices "virtio-keyboard-ccw" and "virtio-mouse-ccw". These can be used to supply graphical environment for KVM guests on s390x, too. Using a custom kernel that has support enabled for this, X11 also already starts fine with this graphics card in a s390x Fedora 27 guest, but the mouse and keyboard are not working there yet, since the "evdev" driver is still missing. The SPEC file of the package currently contains this line which blocks the package from being build on s390x:

ExcludeArch: s390 s390x

Please remove the line from the spec file, so that the package also gets build for s390x. I already did that locally here in my s390x F27 guest, and verified that the package then compiles fine on s390x, too. I then installed the compiled RPM and was able to use the mouse and keyboard in X11, too.

Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.10.5-4.fc27.s390x

How reproducible:
100%

Steps to Reproduce:
1. Install a F27 guest with a kernel that can deal with the virtio devices
   (requires CONFIG_VT, for example)
2. Start QEMU with the parameters "-device virtio-gpu-ccw -device virtio-keyboard-ccw -device virtio-mouse-ccw" to run the guest 
3. startx
4. Try to move the mouse or use the keyboard

Actual results:
Mouse and keyboard can not be used.

Expected results:
Mouse and keyboard are usable in X11

Comment 1 Adam Jackson 2018-04-09 15:28:54 UTC
Would not libinput be a better choice? We're trying to move to that from evdev iirc.

Comment 2 Thomas Huth 2018-04-09 17:51:23 UTC
xorg-x11-drv-libinput has the same problem: The spec file also contains "ExcludeArch: s390 s390x". Anyway, I've removed that line here and recompiled the package - and indeed, X11 keyboard and mouse input is working fine with that driver, too. So it should also be sufficient if you only enable xorg-x11-drv-libinput on s390x. OTOH, why should xorg-x11-drv-evdev be treated differently compared to other architectures? Both packages seem to work fine on s390x, so why not simply enable both?

Comment 3 Peter Hutterer 2018-04-09 22:23:44 UTC
All the xorg-x11-drv-$foo packages have this, leftover from when the xserver itself didn't build on s390 so there was no point building the drivers. Apparently that changed with 1.19.3-5 in May 2017.

We can build libinput for s390. All the other drivers I'll leave as-is. With the exception of xorg-x11-drv-wacom they're all in maintenance mode only. And I doubt you'll be using the Wacom tablet driver on s390.

Comment 4 Peter Hutterer 2018-04-12 06:08:36 UTC
xorg-x11-drv-libinput-0.27.1-2.fc29 is available for rawhide now

Comment 5 Fedora Update System 2018-04-12 06:11:26 UTC
xorg-x11-drv-libinput-0.27.1-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-78124e6948

Comment 6 Peter Hutterer 2018-04-12 23:16:43 UTC
Thomas, do you need F27 too or is F28 good enough?

Comment 7 Thomas Huth 2018-04-13 04:13:36 UTC
I think F28 is good enough, thanks! (I've got a self-compiled package for F27 which I can use for my testing purposes)

Comment 8 Fedora Update System 2018-04-13 16:30:33 UTC
xorg-x11-drv-libinput-0.27.1-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-78124e6948

Comment 9 Fedora Update System 2018-04-17 00:17:28 UTC
xorg-x11-drv-libinput-0.27.1-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Thomas Huth 2018-04-18 05:25:46 UTC
*** Bug 1565067 has been marked as a duplicate of this bug. ***

Comment 11 Peter Hutterer 2018-07-11 00:00:12 UTC
Just an update in case someone's watching. I changed evdev and wacom to remove the ExcludeArch line after all. They're still maintained drivers (well, evdev is sort-of maintained) so we might has well have them unconditional on all arches.

Comment 12 Fedora Update System 2018-07-11 00:35:15 UTC
xorg-x11-drv-evdev-2.10.6-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-75704f77e5

Comment 13 Fedora Update System 2018-07-11 00:45:55 UTC
xorg-x11-drv-wacom-0.36.1-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cba2b3649a

Comment 14 Fedora Update System 2018-07-11 23:44:14 UTC
xorg-x11-drv-evdev-2.10.6-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-75704f77e5

Comment 15 Fedora Update System 2018-07-11 23:44:18 UTC
xorg-x11-drv-wacom-0.36.1-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cba2b3649a

Comment 16 Fedora Update System 2018-07-18 18:30:42 UTC
xorg-x11-drv-evdev-2.10.6-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2018-07-18 18:30:46 UTC
xorg-x11-drv-wacom-0.36.1-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.