Bug 1565074 - targetcli: Storage Objects gets removed Upon restoreconfig, if the underlying backend is down
Summary: targetcli: Storage Objects gets removed Upon restoreconfig, if the underlying...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: targetcli
Version: 7.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Maurizio Lombardi
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On: 1524791
Blocks: 1554642 1537170 1546181 1559239 1566108 1592629
TreeView+ depends on / blocked
 
Reported: 2018-04-09 10:33 UTC by Maurizio Lombardi
Modified: 2021-03-11 17:18 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Previously, the targetcli utility removed storage objects under certain conditions. This happened when the volume hosting the storage objects was down and the user restored target configuration with the command "targetcli restoreconfig". With this update, configuration is now saved at a block granularity, and, as a result, the described problem no longer occurs.
Clone Of: 1524791
: 1566108 (view as bug list)
Environment:
Last Closed: 2018-10-30 07:55:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3040 0 None None None 2018-10-30 07:56:11 UTC

Comment 4 Prasanna Kumar Kalever 2018-04-09 15:27:09 UTC
PR: (merged upstream)
https://github.com/open-iscsi/targetcli-fb/pull/104

Comment 5 Maurizio Lombardi 2018-04-11 11:31:28 UTC
Package built: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=15764021

Comment 9 Martin Hoyer 2018-07-10 07:46:03 UTC
Tested with kernel-3.10.0-915.el7:
The issue is no longer reproducible; No regression found.

Comment 10 Martin Hoyer 2018-07-10 07:48:29 UTC
(In reply to Martin Hoyer from comment #9)
Forgot to mention tested targetcli package:
 - targetcli-2.1.fb46-6.el7
 - python-configshell-1.1.fb23-4.el7
 - python-rtslib-2.1.fb63-12.el7

Comment 12 errata-xmlrpc 2018-10-30 07:55:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3040


Note You need to log in before you can comment on or make changes to this bug.