Bug 1565077 - Unknown filter plugin elasticsearch_genid in fluentd pod
Summary: Unknown filter plugin elasticsearch_genid in fluentd pod
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.6.z
Assignee: Samuel Munilla
QA Contact: Wei Sun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 10:42 UTC by Anping Li
Modified: 2018-04-12 06:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-12 06:05:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1106 0 None None None 2018-04-12 06:06:03 UTC

Description Anping Li 2018-04-09 10:42:56 UTC
Description of problem:
The fluentd pod cann't be started. it failed with the following error. No such issue when use openshift3/logging-fluentd/images/v3.6.173.0.112-1


Version-Release number of selected component (if applicable):
openshift3/logging-fluentd/images/v3.6.173.0.112-2

How reproducible:
always

Steps to Reproduce:
1.   Deploy logging v3.6 
2. Check the pod status

Actual Result:
The fluentd cann't be started


Expected Result:
The EFK can gather, display logs.

Additional info:

Comment 1 Anping Li 2018-04-09 10:46:42 UTC
[root@host-8-245-223 log]# cat fluentd.log 
2018-04-09 10:45:47 +0000 [info]: fluent/supervisor.rb:471:read_config: reading config file path="/etc/fluent/fluent.conf"
2018-04-09 10:45:48 +0000 [error]: fluent/supervisor.rb:369:rescue in main_process: config error file="/etc/fluent/fluent.conf" error="Unknown filter plugin 'elasticsearch_genid'. Run 'gem search -rd fluent-plugin' to find plugins"
[r

Comment 2 Jeff Cantrill 2018-04-09 17:49:04 UTC
Who should this be assigned to and it what state given it appears to be a build issue?

Comment 4 Junqi Zhao 2018-04-10 03:15:38 UTC
Tested with logging-fluentd/images/v3.6.173.0.112-3, fluentd pods can be started up now

# oc get po -n logging | grep fluentd
logging-fluentd-1c29h                         1/1       Running   0          12m
logging-fluentd-g3vr9                         1/1       Running   0          12m

# openshift version
openshift v3.6.173.0.112
kubernetes v1.6.1+5115d708d7
etcd 3.2.1

Comment 7 errata-xmlrpc 2018-04-12 06:05:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1106


Note You need to log in before you can comment on or make changes to this bug.