Bug 1565078 - system container install failed due to 'openshift_image_tag' is undefined
Summary: system container install failed due to 'openshift_image_tag' is undefined
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 10:43 UTC by Weihua Meng
Modified: 2018-07-30 19:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:12:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:12:47 UTC

Description Weihua Meng 2018-04-09 10:43:20 UTC
Description of problem:
Install failed HA lb and system container

should not pull image on lb

Version-Release number of the following components:
openshift-ansible-3.10.0-0.16.0.git.0.8925606.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. install OCP HA with embedded haproxy, system container
$ ansible-playbook  playbooks/prerequisites.yml

Actual results:
TASK [container_runtime : Pre-pull Container Engine System Container image] ****
Sunday 08 April 2018  22:39:42 -0400 (0:00:00.914)       0:01:11.080 ********** 
fatal: [host-8-249-2.host.centralci.eng.rdu2.redhat.com]: FAILED! => {"failed": true, "msg": "The task includes an option with an undefined variable. The error was: {{ openshift_docker_systemcontainer_image_override | default(l_docker_image_default) }}: {{ l_docker_image_prepend }}:{{ l_docker_image_tag }}: {{ l_crt_docker_image_tag_dict[openshift_deployment_type] }}: {u'origin': u'{{ openshift_docker_image_tag | default(openshift_docker_image_tag_default) }}', u'openshift-enterprise': u'{{ l_openshift_image_tag }}'}: {{ openshift_image_tag | string }}: 'openshift_image_tag' is undefined\n\nThe error appears to have been in '/home/slave6/workspace/Launch Environment Flexy/private-openshift-ansible/roles/container_runtime/tasks/systemcontainer_docker.yml': line 53, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n# NOTE: no_proxy added as a workaround until https://github.com/projectatomic/atomic/pull/999 is released\n- name: Pre-pull Container Engine System Container image\n  ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: {{ openshift_docker_systemcontainer_image_override | default(l_docker_image_default) }}: {{ l_docker_image_prepend }}:{{ l_docker_image_tag }}: {{ l_crt_docker_image_tag_dict[openshift_deployment_type] }}: {u'origin': u'{{ openshift_docker_image_tag | default(openshift_docker_image_tag_default) }}', u'openshift-enterprise': u'{{ l_openshift_image_tag }}'}: {{ openshift_image_tag | string }}: 'openshift_image_tag' is undefined"}

host-8-249-2.host.centralci.eng.rdu2.redhat.com is lb

Expected results:
install succeeds

Comment 2 Scott Dodson 2018-04-19 13:13:23 UTC
Need to add lb to the hosts that get openshift_image_tag set.

Comment 3 Weihua Meng 2018-04-26 10:01:06 UTC
Not meet this error again. 
Install succeeded.
openshift-ansible-3.10.0-0.29.0

TASK [container_runtime : Pre-pull Container Engine System Container image] ****
Thursday 26 April 2018  05:21:28 -0400 (0:00:00.125)       0:01:57.524 ******** 
skipping: [qe-wmengah-master-etcd-1.0426-dne.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}
skipping: [qe-wmengah-master-etcd-2.0426-dne.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}
skipping: [qe-wmengah-master-etcd-3.0426-dne.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}
skipping: [qe-wmengah-nrri-1.0426-dne.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}
skipping: [qe-wmengah-nrri-2.0426-dne.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}
skipping: [qe-wmengah-node-primary-1.0426-dne.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}
skipping: [qe-wmengah-node-primary-2.0426-dne.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}
skipping: [qe-wmengah-lb-1.0426-dne.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}

Kernel Version: 3.10.0-862.el7.x86_64
Operating System: Red Hat Enterprise Linux Atomic Host 7.5.0

Comment 4 Michael Gugino 2018-05-10 16:18:07 UTC
System Container removal PR: https://github.com/openshift/openshift-ansible/pull/8329

Comment 5 Weihua Meng 2018-05-15 07:36:06 UTC
Fixed.
openshift-ansible-3.10.0-0.41.0

Kernel Version: 3.10.0-862.el7.x86_64
Operating System: Red Hat Enterprise Linux Atomic Host 7.5.0

Comment 7 errata-xmlrpc 2018-07-30 19:12:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.