Bug 1565121 - v3.10.0-0.16.0.0 node and ose images missing from mirror
Summary: v3.10.0-0.16.0.0 node and ose images missing from mirror
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.10.0
Assignee: Justin Pierce
QA Contact: Walid A.
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 12:44 UTC by Mike Fiedler
Modified: 2018-07-30 19:12 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:12:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:12:47 UTC

Description Mike Fiedler 2018-04-09 12:44:22 UTC
Description of problem:

The latest ose and node images on the mirror are v3.10.0-0.14.0.0

0.15.0 and 0.16.0 are missing

Version-Release number of selected component (if applicable): v3.10.0-0.16.0.0


How reproducible: Always


Steps to Reproduce:

oc login --config=~/.kube/reg-aws --username=<user> --password=<password> https://api.reg-aws.openshift.com
docker login -u <user> -p $(oc --config=~/.kube/reg-aws whoami -t) registry.reg-aws.openshift.com:443# curl -H "Authorization: Bearer $(oc --config=~/.kube/reg-aws whoami -t)" https://registry.reg-aws.openshift.com/v2/openshift3/ose/tags/list  | python -m json.tool | grep 3.10                                                                                   


Actual results:

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current                                                              
                                 Dload  Upload   Total   Spent    Left  Speed                                                                
100  7463    0  7463    0     0  18218      0 --:--:-- --:--:-- --:--:-- 18202                                                               
        "v3.10.0-0.14.0.0",        
        "v3.10.0-0.14.0",          
        "v3.6.173.0.63-10",        
        "v3.3-1002",               
        "v3.10.0-0.13.0.0",        
        "v3.10.0",                 
        "v3.10",                   
        "v3.7.23-10",              
        "v3.10.0-0.13.0", 


Expected results:


Additional info:

Comment 1 Justin Pierce 2018-04-09 12:54:02 UTC
These images have been renamed for architectural reasons:

$ curl -H "Authorization: Bearer $(oc whoami -t)" https://registry.reg-aws.openshift.com/v2/openshift3/ose-control-plane/tags/list
{"name":"openshift3/ose-control-plane","tags":["v3.10.0-0.16.0","v3.10.0-0.16.0.0","v3.10","v3.10.0","v3.10.0-0.15.0","v3.10.0-0.15.0.0"]}

$ curl -H "Authorization: Bearer $(oc whoami -t)" https://registry.reg-aws.openshift.com/v2/openshift3/ose-node/tags/list
{"name":"openshift3/ose-node","tags":["v3.10.0","v3.10.0-0.15.0","v3.10.0-0.15.0.0","v3.10.0-0.16.0","v3.10.0-0.16.0.0","v3.10"]}

Comment 2 Walid A. 2018-04-10 15:43:42 UTC
Verified that we can pull the renamed images ose-control-plane and ose-node images from registry.reg-aws.openshift.com for v3.10.0-0.16.0.0.

Comment 4 errata-xmlrpc 2018-07-30 19:12:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.